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このリリースについて 
 

本書では、IMAGINE Photogrammetry（旧 LPS Core）と ERDAS ER Mapper を含め、ERDAS IMAGINE 

2020 Update1（v16.6.1）の機能強化について説明します。本書には製品リリース時点での最新の情報が反映されて

いますが、最新バージョンについては、Hexagon Geospatial Support の Web サイトを参照してください。 
 
Update 1 は、ERDAS IMAGINE 2020 の開発サイクルの後半にある新機能で特定されたいくつかの重要な問題に

対処するためのターゲットを絞ったリリースです。したがって、このドキュメントは Update 1 の変更を強調していますが、

ERDAS IMAGINE 2020 もカバーしています。 Update 1 で対処される重要な領域は次のとおりです。 

・ Pyramid generation 

・ Grow Features operator 

・ Predict Using Machine Learning operator 

・ Viewshed tool 

・ Subpixel Classifier 

 

このリリースには、機能強化と修正の両方が含まれています。v16.6.0 及び v16.6.1 リリースで ERDAS IMAGINE に

対して行われた修正については、「Issues Resolved」を参照してください。 
 
本書では製品の機能の概要だけを示し、詳細をすべて説明しているわけではありません。詳細については、ERDAS 

IMAGINE のオンライン ヘルプとその他の付属ドキュメントを参照してください。 
 
ERDAS IMAGINE 2020 は、ERDAS IMAGINE のほぼすべての側面を 64 ビットで実行できるようにすることに重点を置いて 

開発されました。その結果、インストーラーが ERDAS IMAGINE 2020 64 ビット、ERDAS IMAGINE 2020 32 ビット、

ERDAS ER Mapper 2020 の 3 つのインストーラーに分けられました。 
 
また、Compute Grey-Level Co-Occurrence Matrix 演算子などの新しい演算子が追加され、ソフトウェアの品質の改善

も多数行われています。 
 

ERDAS IMAGINEの製品群 
 

ERDAS IMAGINE®は、高度なリモート センシング解析と空間モデリングを実行することで新しい情報を作成します。また、

ERDAS IMAGINE では、2D、3D、動画、地図製作並みの地図構成で結果を表示できます。ERDAS IMAGINE 製品群

の中心部分は、地理空間データの生成に対するユーザーのニーズに対応できるように設計されています。また、生産性を高め、

機能を拡張するための専門的な機能を提供するオプション モジュール（アドオン）も用意されています。 
 
IMAGINE Essentials®は、地図作成ツールとシンプルなフィーチャー収集ツールを備えたエントリレベルの画像処理

製品です。IMAGINE Essentials では、シリアル バッチ処理が可能です。 
 
IMAGINE Advantage®は、高度なスペクトル処理、画像登録、モザイク化と画像解析、変化検出などの機能を備え

ています。IMAGINE Advantage では、パラレル バッチ処理によって出力を高速化できます。 
 
IMAGINE Professional®には、高度なスペクトル処理、ハイパースペクトル処理、レーダー処理、および空間モデリ
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ングのための製作ツール セットが用意されています。また、ERDAS ER Mapper も含まれています。 
 
IMAGINE Photogrammetry は、最先端の写真測量衛星画像および航空画像の処理アルゴリズムを使用して、生産

性を最大限に高めます。 
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新しいプラットフォーム ERDAS IMAGINE2020 Update 1 

 

フルインストーラー 

以前のリリースでは、更新プログラムのインストーラーは、更新プログラムをインストールする前に基本製品を最初にインストールする

必要がありました。たとえば、ERDAS IMAGINE 2018 Update 2（v16.5.2）をインストールするには、最初に ERDAS 

IMAGINE 2018（v16.5.0）をインストールする必要がありました（または以前のアップデート）。 

ERDAS IMAGINE 2020 Update 1 以降では、更新インストーラーはインクリメンタルではなくなります。これはフルインストー

ラーになります。 

つまり、スタンドアロンでインストールすることも（ERDAS IMAGINE 2020 Update 1 をインストールする必要なしに ERDAS 

IMAGINE 2020 Update 1 をインストールする）、または既存のインストールを更新するために使用することもできます

（ERDAS IMAGINE 2020 であっても ERDAS IMAGINE 2020 Update 1 をインストールします）は既にインストールされ

ており、既存のインストールを v16.6.1 に更新しています。 

これは、フルインストーラーとして、以前にインストールされたバージョンへの更新をロールバックすることができなくなることを意味しま

す。そのため、たとえば、ERDAS IMAGINE 2020 Update 1 を使用して ERDAS IMAGINE 2020 を更新した場合、アンイ

ンストールすると ERDAS IMAGINE 2020 全体が削除されます。その結果、「ロールバック」には ERDAS IMAGINE をアンイン

ストールしてから目的の以前のバージョンを再インストールする必要があります。 

新しいプラットフォーム ERDAS IMAGINE2020 
 

 

完全な 64 ビット インストーラー 

最新の 64 ビット コンピューターでは、真の 64 ビット アプリケーションとして実行できるため、4 GB を超えるメモリへの対応など、 

コンピューターのリソースを最大限に活用できます。 
 
Hexagonでは、64 ビットを実行するために、これまでのいくつかのリリースにわたって、ERDAS IMAGINE実行可能ファイルを
徐々に移行してきました。これらの各リリースでは、一部の非 GUI アプリケーション（ジョブ）が 32 ビットと 64 ビットの両方で
利用可能になり、 
ユーザーは実行するバージョンを Session Manager で構成できました。ERDAS IMAGINE 
2018 では、メインのリボン GUI（ewkspace.exe）が 32 ビットと 64 ビットの両方でリリースされましたが、これらの構成の

いずれかから起動したアプリケーションが 32 ビットと 64 ビット（利用可能な場合）のどちらとして実行されるかは、64 ビット構

成設定によって異なっていました。この混在アプローチには問題がいくつかありました。特に、ユーザーが実行しようとしているジョ

ブが 32 ビットと 64 ビットのどちらで実行されるかについて、ユーザーに対する透明性が欠如していました。 
 
そのため、ERDAS IMAGINE 2020では、2つの別々のインストーラー（およびERDAS ER Mapper用の3つ目のインストー

ラー）に明確に分けられました。1 つはスイート全体が 32 ビット アプリケーションとして実行され、もう 1 つはスイート全体が 64

ビットとして実行されます。つまり、ユーザーが ERDAS IMAGINE 2020 64 ビットを起動した場合、利用する機能が 64 ビット

で実行されるのは確実であるため、大容量のシステム メモリや他のリソースを活用できます。 
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また、この分割により、構成タスクがはるかに簡単になります。ERDAS IMAGINE 2020 32 ビットで Python を使用する場合

は、32 ビット バージョンの Python が必要です。ERDAS IMAGINE 2020 64 ビットで動作するように CSM/MSP を構成す

る場合は、64 ビット CSM/MSP が必要です。 
 
全 3 つのインストーラー（ERDAS IMAGINE 2020 64 ビット、ERDAS IMAGINE 2020 32 ビット、ERDAS ER 

Mapper 2020）は、必要に応じて 1 台のコンピューターにインストールできます。 
 
64 ビットが非常に優れているのに、ERDAS IMAGINE 2020 32 ビットが残されているのはなぜでしょうか。残念ながら、すべて

のプログラムを 64 ビットに移植できるわけではありません。通常、32 ビットでのみ使用できるサードパーティ コンポーネントへの依

存関係が存在するからです。このようなプログラムは、ERDAS IMAGINE 2020 64ビットに正常に組み込まれたプログラムの数

と比べると非常に限られています。ただし、製作ワークフローがこれらの機能のいずれかに依存している可能性があるため、これら

の機能を必要とするお客様が必要に応じて引き続き使用できるように、ERDAS IMAGINE 2020 32 ビットが提供されていま

す。 
 
ERDAS IMAGINE 2020 32 ビットでのみ使用可能な機能は次のとおりです。 

 
• Image Equalizer 

• Image Catalog 

• StereoSAR DEM 

• IMAGIZER 

• External Projections 

• Surfacing Tool（非推奨。Terrain Prep Tool を推奨） 

• ESRI Grid のサポート 

• MultiGen OpenFlight 形式のサポート 

• Oracle Geospatial Raster のサポート 

• ArcSDE のサポート 

• TerraModel TIN のサポート 

• IRS Sensor モデル 

• MapInfo のサポート 

• ジオデータベースのサポート 
 
コンポーネントの利用状況によっては、将来、これらの機能の一部が 64 ビット バージョンの ERDAS IMAGINE に移行する可

能性があります。 
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ArcGIS 10.7 

ERDAS IMAGINE 2020（32 ビット）は、ジオデータベース サポート ライブラリを提供するために、ライセンス版の ArcGIS 

10.6、10.6.1、および10.7がインストールされた環境でテストされており、この環境を使用している場合にサポート対象となるこ

とが発表されました。 
 
また、IMAGINE Geodatabase Support コンポーネント（ArcGIS Engine 10.7 ベース）をインストールして、ジオデータ

ベースをサポートすることもできます。 
 
現時点では、ArcGIS 10.7.1 はサポートされていないことに注意してください。 

 

 

ライセンス 

ERDAS IMAGINE 2020 では、Geospatial Licensing ツールはインストーラーの一部として自動的にインストールされなく

なりました。Geospatial Licensing ツールを使用する場合は（フローティング/同時接続ライセンス サーバーをセットアップす

る場合など）、Hexagon Geospatial Licensing 2020 ツールを別途ダウンロードする必要があります。 
 
最新バージョンの Hexagon Geospatial Licensing 2020 にアップグレードすることを 

強くお勧めします。バージョンが不明な場合は、Windows の[プログラムの追加と削除]ユーティリティを参照して、現在インストー

ルされているバージョンを 

確認してください。 
 
該当するダウンロードについては、Hexagon Geospatial の Web サイトの[Downloads]セクションで確認できます。 

 
https://download.hexagongeospatial.com/search?lang=en&product=b3b4786d3d4742ae8d1e7aeee5

0dae69 
 

新しい技術 ERDAS IMAGINE2020 Update 1 

SIPS 2.4 13a サポート 

インストーラーは、Unclassified SIPS v2.4.13a XML ファイルを使用してデフォルトのイメージチェーン表示パラメーターを制御

するように更新されました。 

SIPS の拡張バージョンは、IMAGINE Defense Productivity Module（DPM）から入手できます。。 

新しい技術 ERDAS IMAGINE2020 
 

 

Spatial Modeler の新しい演算子 

Hexagonでは、Spatial Modelerに新しい演算子を追加し続けています。新しい（または変更された）演算子とその機能に
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ついて、以下で簡単に説明します。各演算子の詳細については、ERDAS IMAGINE 2020 のヘルプを参照してください。また、

これらの機能の多くを使用した空間モデルの例については、Hexagon Geospatial Community の「Spatial Recipes」ペー

ジを参照してください。 
 

 

Classify Buildings 

 
 
この演算子は、入力ポイント クラウドから建物に位置するポイントを特定し、それらを Building クラス（クラス 6）に再割り当

てします。ポイント クラウド内の地面に位置するポイントがすでに分類されている（つまり、Ground クラス（クラス 2）に割り

当てられている）必要があります。入力ポイント クラウド内の地面ポイントが分類されていない場合は、Classify Ground 演

算子を使用して分類できます。 
 
分類は、指定された高さと面積の基準を満たす地上の平面領域を探して、非地面ポイントと隣接するポイントの幾何

学的関係を解析することによって実行されます。 
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Extract Building Footprints 

 
 

この演算子は、ポイント クラウド内の、Building ポイント（クラス 6）にすでに分類されているポイントに基づいて、建物の占有領

域を 

抽出します。ポイント クラウド内の地面に位置するポイントと建物に位置するポイントが、それぞれGroundクラス（クラス2）と

Building クラス（クラス 6）にすでに分類されている必要があります。 
 

 

Compute Ground Sampling Distance 

 
 
この演算子は、隣接するポイント間の距離を解析することによって、ポイント クラウドの地上サンプリング距離を計算します。デ

フォルトでは、ラスト リターンとシングル リターンを持つ最初の 1000 ポイントが計算に含まれます。SelectionCriteria ポートに

データを設定することで、これをオーバーライドできます。通常、この演算子からの出力は、ポイント クラウドからラスターに変換す

るときのセル サイズを指定するために使用されます。 
 

 

Calculate Cell Size 

 
 

この演算子は、リサンプリングされる入力グリッドまたは入力画像の適切な地上空間のピクセル寸法を計算します。これは、入力

グリッドがオルソ補正される参照可能なグリッドである場合（RPC が埋め込まれた NITF 画像など）、または入力グリッドを別の

CRS に再投影する場合に最も頻繁に必要となります。 
 
使用されるアルゴリズムは ERDAS IMAGINE の標準のリサンプル ダイアログにも組み込まれているため、各ダイアログに設

定されたデフォルトのピクセル サイズでは、（オーバーサンプリングなしで）最適なレベルの精度を維持するよう試みます。 
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Grow Features 

 
 
Grow Features 演算子は、シード ピクセルをより大きな領域に拡大して、ラスター データとシード ピクセルからフィーチャー

を抽出します。領域は、シード ピクセルにスペクトル的に類似する隣接ピクセルを追加することで拡大されます。シードとスペク

トル的に類似しているかどうかを判断するために各隣接ピクセルが評価され、類似している場合は領域に組み込まれます。拡

大された領域には、評価対象となる新しい隣接ピクセルが含まれます。このプロセスは、拡大中の領域に新しい隣接ピクセル

が追加されなくなるまで（または拡大の他の制約のいずれかが満たされるまで）続きます。 
 
改善された領域拡大アルゴリズムは、2D View のベクター編集ツールにも組み込まれています。 
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Initialize CART Regressor 

 
 
この演算子は、Regression Using Machine Learning 演算子を使用してデータを推定する際の入力として使用される 

CART リグレッサーを定義し、トレーニングします。 
 

 

Initialize Random Forest Regressor 

 
 
この演算子は、Regression Using Machine Learning 演算子を使用してデータを推定する際の入力として使用されるラ

ンダム フォレスト リグレッサーを定義し、トレーニングします。 
 

 

Predict Using Machine Learning 

 
 

この演算子は、MachineIntellect ポートで指定されたトレーニング済みリグレッサーを使用して、入力データの回帰を 

実行します。入力データには、IMAGINE.Features 型または IMAGINE.Raster 型のデータを指定できます。 
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Augment Training Data 
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この演算子は、既存のトレーニング データを変更して Classify Using Deep Learning 用の追加のトレーニング データを作

成します。選択したオプションに応じて、入力トレーニング データの回転、スケーリング、変換、または反転されたバージョンが生

成されます。 
 

 

Assess Object Detection Accuracy 

 
 

オブジェクト検出精度評価は、オブジェクト検出の結果をグラウンド トゥルース データと比較して、両者の一致を測定するプロ

セスです。この演算子は、グラウンド トゥルースを表すオブジェクトの矩形の境界ボックスとクラス属性を、オブジェクト検出によっ

て検出されたオブジェクトと比較することで精度評価を実行します。 
 

 

Densify Geometry 

 
 

Densify Geometry 演算子は、最大距離係数を使用して、入力フィーチャーのジオメトリに頂点を追加します。2 つの頂点

間の距離が MaxDistance よりも大きい場合は、2 つの頂点の中間に新しい頂点が挿入されます。頂点間の線分が

MaxDistance よりも短くなるまで、または出力ジオメトリが MaxSize のサイズを超えるまで、この処理が繰り返されます。 
 

 

Smooth Geometry 

 
 
Smooth Geometry 演算子は、加重平均平滑化アルゴリズムを使用して入力フィーチャーのジオメトリを平滑化します。平

滑化では、小さな摂動を取り除き、最も重要な傾向だけを取り込むために、ジオメトリ上のポイントの位置を変えます。単純化

とは異なり、平滑化ではジオメトリのポイントの数は保持されますが、外観が改善されます。この演算子では、緻密化許容値、

先読みカウント、重み付け係数によってアルゴリズムを制御できます。 
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Arrange Items 

 
 

RangeList ポートで指定された順序を考慮して、リストまたはテーブルから値を選択、配置、複製して、出力リストまたはテーブ

ルを作成します。 
 
例: 

 
DataIn が[ -2 , 0 , 2 , 3 , 7 , 8 ]、RangeList が[ 0 , 1 , 3 , 0 , 3 , 5 ]の場合、DataOut は[ -2 , 0 , 3 , -2 , 3 , 

8 ]になります。DataIn が[ -2 , 0 , 2 , 3 , 7 , 8 ]、RangeList が[ 0:2 , 1:4 ]の場合、DataOut は[ -2 , 0 , 2 , 0 , 

2 , 3 , 7 ]になります。 

値のセットを値の別のセットと同じ方法で順序付けることができるように、この演算子は、Sort Items 演算子によって作成され

た出力と共によく使用されます。たとえば、2 つのテーブルがあり、1 つはクラス名で構成され、もう 1 つはそれらのクラス名に関連

付けられたヒストグラム値で構成されているとします。Class Names テーブルが英数字順に並べ替えられている場合、ヒストグラ

ム値も対応するクラス名に対して正しく並べ替えられるように、Sort Items によるインデックス出力をこの演算子への

RangeList 入力として使用して、Histogram テーブルを再編成できます。 
 

 
 

Catch Error 

 
 
この演算子は、含まれているサブモデルの実行時にエラーが発生するかどうかの条件をブール値の結果に変換します。 
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たとえば、適用性が不確実なデータセット参照のコレクションに対して反復サブモデルを完了するまで実行できるようにする場合

にこの演算子が役立ちます。次に示すサブモデルが Multi Filename Input 演算子の結果によって提供される Iterator に配

置された場合、Catch Error サブモデルに含まれる Raster Input 演算子に適していないファイル名は、最終的に

BadFilenameOut リストに含まれます。 
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Catch Error を使用した Iterator 演算子の内容: 
 
 
 

 
 
 
 
Catch Error サブモデル: 

 

 
 
 
 
 

Color Input 

 
 

色を作成します。演算子をダブルクリックして構成ダイアログを開きます。[Color Chooser]が開きます。出力される 

色が Input ポートに配置されます。このポートはデフォルトで非表示になっています。 
 

 

Combine 

 
 
複数のリストを 1 つのリストに結合します。指定した順序で（Collection1 の要素の後に Collection2 の要素が続くなど）、

指定したリスト/テーブルの各要素で構成される新しいリスト/テーブルが作成されます。これは拡張可能な演算子であるため、

Collection ポートを必要な数だけ追加できます。 
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次のモデルは、2 つのテーブルを結合する方法を示しています。



ERDAS IMAGINE 2020 Update1 

2019 年 10 月 30 日 20 

 

 

 
 

 
 

 
 
 

Compute GLCM Texture 

 
 

入力画像のテクスチャ フィーチャーを計算します。指定されたテクスチャ フィーチャーは、ピクセルごとに内部生成された

グレーレベル同時生起行列（GLCM）のさまざまな統計的特性から計算されます。 
 
通常、グレーレベル同時生起行列を使用したテクスチャ計算は、元の画像に存在するテクスチャの「二次」測定と見なされます。

テクスチャ測定は元の画像値から計算された統計（分散など）であり、ピクセルの隣接関係は考慮されないため、通常、従

来のテクスチャ測定は「一次」と見なされます。これに対して、「二次」測定では、元の画像の（通常は隣接する）2 つのピクセ

ルのグループ間の関係が考慮されます。 
 
このようなテクスチャ測定は、画像分類（特に機械学習）などの他のプロセスへの入力や他の目的（次の例の密集した領域

の識別など）のための派生情報として非常に有用と考えられています。 
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GLCM 計算は計算負荷が高いため、OpenCL を実行する GPU 対応グラフィックス カードがあるとメリットが得られます。 
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Create Dice Boundaries 

 
 

Create Dice Boundaries は、画像の境界を、サブセット化に使用できる、一定のサイズと間隔のより小さな境界に分割しま

す。隣接する新しい境界は、XOverlap ポートと YOverlap ポートで指定された範囲で重ね合わせることができます。 
 
次に示す空間モデルの例では、Create Dice Boundaries 演算子を使用して、画像上にエリア ポリゴン ジオメトリの規則的

なグリッドを作成しています。これは、ゾーン変化検出や深層学習のフィーチャー特徴抽出に使用できます。 
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Create Image Pyramid 

 
 

この演算子は、画像データセットの画像ピラミッドと画像統計の存在を保証します。 
 
画像の永続的で最適なシーケンスを生成したり、シーケンスの存在を確認したりします（各画像は、シーケンス内の前の

画像よりも解像度が徐々に低下します）。画像ピラミッドの主な用途は、元の解像度よりも大きいスケールで画像を表示

するときに、レンダリング速度を上げ、エイリアシング アーティファクトを低減することです。 
 
すべての画像ピラミッドを確実に同じタイプ（ジェネレーター）にし、指定したダウンサンプリング方法を使用して作成でき

るようにする場合や、新しい画像ピラミッドを強制的に作成する場合は、この演算子の前に Delete Image Pyramid

演算子を使用します。 
 
この演算子は、画像の画像統計が利用可能であることも保証します。これは、適切な画像ピラミッドがすでに存在する場合で

も行われます。 
 
ピラミッド レベルを生成するこの新しいモードの主な利点の1 つは、PYRX形式のピラミッド ファイルを作成できることです。これ

らは ECW 圧縮を使用するため、高速であるだけでなく、従来のピラミッド ファイル形式よりも使用されるディスク容量がはるか

に少なくなります。 
 
次の例では、元の衛星画像のサイズは 713 MB です。3 つの異なる形式のピラミッド ファイルを生成し、フレームに合わせて

画像を表示しています。PYRX ピラミッド ファイルは、表示品質を維持しながら、他の 2 つの形式の 1/10 のサイズになっています。 
 

 
 
Create Image Pyramid は、Create RSETs でこれまで提供されていたすべての機能に代わるものであることに注意し
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てください。今後は Create RSETs を使用しないでください。 
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ピラミッド ファイルの生成の新しいモードは、Raster Output 演算子、ピラミッドのバッチ作成用の画像コマンド ツール

（[Home]タブ > [Information]グループ > [Metadata]プルダウン > [Edit Image Metadata]）、[Image 

Metadata]ダイアログ（[Home]タブ > [Information]グループ > [Metadata]プルダウン > [View/Edit Image 

Metadata]）、Spatial Modeler を使用して処理を実行するアプリケーションにも組み込まれています。デフォルトで使用され

るジェネレーターのタイプと、関連するダウンサンプリング手法は、[Preferences]で制御できます。 
 
注:（64 ビット バージョンではなく）ERDAS IMAGINE 2020 32 ビットを日常的に実行している場合、プロセスで大きな

画像ファイルの.pyrx 形式のピラミッド ファイルを作成しようとすると、メモリ不足に関するエラーが発生する場合があります。その

場合、（ERDAS IMAGINE 2020 64 ビットを実行する以外に）次の 2 つの回避策があります。 
 

• Preference Editor（[File] > [Preferences]）で、[Percentage of Available Memory to Consume]を 
小さい値（30%など）に変更して、Spatial Modeler の実行に使用できるメモリ量を 
減らします。これにより、ECW/JP2 エンコード エンジンによる圧縮の実行により多くのメモリを使用できるようになります。 

 

• または、Pyramid Layer Generator の基本設定を、デフォルト設定から[Always use the RRD Pyramid 

Generator]に変更します。これにより、2020 リリースより前の方法でピラミッド ファイルを生成するようにソフトウェ

アが効率的に設定されます。 
 

 

Delete Image Pyramid 

 
 
Delete Image Pyramid は、ラスター画像から既存の画像ピラミッドを削除します。 

 
検出されたすべての画像ピラミッドが削除されます（可能な場合）。これには以下が含まれます。 

 
• ERDAS 低解像度データセット（*.rrd） 

• 拡張圧縮画像ピラミッド（*.pyrx） 

• NITF RSET 

• Minifiles 

• GDAL Overviews（*.ovr） 
 
削除できないピラミッドは次のとおりです。 

 
• IMAGINE Image の内部のピラミッド（*.img） 

• ウェーブレット圧縮のピラミッド（*.ecw、*.jp2、*.sid） 
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Enhance Contrast Using CLAHE 
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Contrast Limited Adaptive Histogram Equalization（CLAHE）アルゴリズムは、画像のコントラストを強調するため

に使用される手法です。従来のヒストグラム均等化では、画像ヒストグラムから導出された単一の変換を使用してすべてのピクセ

ルを変換します。そのため、特に、表示されているデータのダイナミック レンジが8ビットよりも大きい場合（およびレンダリング ソフ

トウェアまたは表示デバイスでサポートされているのが、カラー チャネルごとに 8 ビットのみの場合）、ヒストグラムの暗い領域、明

るい領域、 

中間調の領域のコントラストのバランスを取ることができる単一の変換を導出することは困難です。 
 
そこで、変換を空間的に適応させ、中間調の領域のコントラストを維持しながら、ラスターの暗い領域と明るい領域の詳細を明ら

かにするために、CLAHE などの手法が開発されました。たとえば、CLAHE では、大きな建物や雲などによって投じられた影で隠

れている詳細を強調できます。このような場所では、ピクセルの DN 値が小さくなりますが、10、11、12 ビット以上のダイナミック 

レンジを持つセンサーの場合、広範囲の値が存在する可能性があります。しかし、カラー チャネルごとに 8 ビットのディスプレイに画

像をレンダリングする際に使用されるグローバル ルックアップ テーブルでは、すべての影の領域が少数の暗さのビンに分類されます

（つまり、視覚コントラストが低くなります）。CLAHE の空間的に適応する性質により、これらの影の領域に固有のコントラスト

を拡大したり明るくしたりすることが可能となり、隣接する影のない領域とのバランスを取ることができます。 
 
たとえば、明るい領域と暗い影の両方が含まれた次の 12 ビットのカラー画像は、標準の LUT では影の部分の詳細が 

ほとんど表示されていません。 
 

 
 
 
 
次のスクリーンショットは、Contrast Retention Factor を 0.2 に設定して Enhance Contrast Using CLAHE 演算子を使

用した場合の 

結果を示しています。 



ERDAS IMAGINE 2020 Update 1 

2019 年 10 月 30 日 23 

 

 

 
 

 
 
 
 

ご覧のように、すでに明るい領域を飽和させることなく、影の領域のコントラストが強調されています。 
 

 

Get TIFF Options 

 
 

Tagged Image File Format（TIFF）の形式固有の出力オプション ディクショナリを作成します。このディクショナリを

Raster Output 演算子に提供して、必要な BigTIFF 形式、保持するアルファ チャネル、データ圧縮などの形式固有の出

力パラメーターを制御できます。 
 

 

Resize Matrix 
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この演算子の目的は、既存の行列を取得し、行や列を削除するか、新しい行や列（またはそれらの任意の組み合わせ）を

追加して、その行列の次元を変更することです。新しい行や列を追加する場合、それらの新しいセルで使用する値を指定でき

ます。行を削除すると、MatrixInの下部から削除され、列を削除すると、MatrixInの右側から削除されます。同様に、行

を追加すると、MatrixIn の下部に追加され、列を追加すると、MatrixIn の右側に追加されます。 
 
いずれかの次元（行または列）でのみ、MatrixIn を拡張する場合、InitialValues に行列を指定できます。行数を拡

張する場合、InitialValues に指定する行列には、MatrixIn と同じ数の列が含まれている必要があります。行は、単一

行でも、行列に追加する行と同じ数の行でもかまいません。単一行が含まれている場合、行列に追加されるすべての行がその

単一行で埋められます。列数を拡張する場合、InitialValues に指定する行列には、MatrixIn と同じ数の行が含まれて

いる必要があります。列は、単一列でも、行列に追加する列と同じ数の列でもかまいません。単一列が含まれている場合、行

列に追加されるすべての列がその単一列で埋められます。 
 
5 行 9 列の MatrixIn の使用例を次に示します。 

 

 
 

• NumRows を 8、NumColumns を 14 に設定すると、3 行および 5 列で行列が拡張され、新しいセルが InitialValues

に設定されます（InitialValues はスカラーである必要があります）。InitialValues が-1 の場合、MatrixOut は次のよう

になります。 
 

 
 
 

• InitialValues が次のような 1 行 9 列の行列の場合、 
 

 
 

追加された行の列 0 は、InitialValues 行列のセル 0,0 の値に設定され、追加された行の列 1 は、InitialValues 行列の
セル 0,1 の値に設定されます（以降も同様）。MatrixOut は次のようになります。 
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• InitialValues が次のような 3 行 9 列の行列の場合、 
 

 
 

追加された最初の行は InitialValues 行列の行 0 の値に、追加された 2 番目の行は InitialValues 行列の行 1 の値に、

追加された 3 番目の行は InitialValues 行列の行 2 の値にそれぞれ設定されます。MatrixOut は次のようになります。 
 
 

 
 

 

Resize Table 

 
 

テーブルの行数を調整（増減）します。InitialValues ポートは入力としてテーブルを受け取るため、この演算子を使用する

と、複数のテーブルをまとめて追加できます。 
 

 

Set Matrix Values 

 
 

この演算子の目的は、既存の行列を取得し、その行列の特定のセルを、ユーザーが指定した値で変更することです。 
 
RowRangeListまたは ColumnRangeList のみが指定されている場合（1 つ以上の行のすべての列または1 つ以上の

列のすべての行のセルを設定する場合）、Values に行列を指定できます。RowRangeList のみが指定されている場合、

Values に指定する行列には、MatrixIn と同じ数の列が含まれている必要があります。行は、単一行でも、

RowRangeListで指定されている行と同じ数の行でもかまいません。単一行が含まれている場合、RowRangeListで指

定されているすべての行がその単一行で埋められます。ColumnRangeList のみが指定されている場合、Values に指定
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する行列には、MatrixIn と同じ数の行が含まれている必要があります。列は、単一列でも、 
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ColumnRangeList で指定されている列と同じ数の列でもかまいません。単一列が含まれている場合、 

ColumnRangeList のすべての列がその単一列で埋められます。 
 
RowRangeList と ColumnRangeList は、どちらも 0 から始まるインデックスです。つまり、最初の行が行 0、2 番

目の行が行 1 になります（以降も同様）。 
 
5 行 9 列の MatrixIn の使用例を次に示します。 

 

 
 
 
 

• RowRangeList を 1:1,3:4（3 行）、ColumnRangeList を 2:4（3 列）に設定すると、1,2、3,3、4,4 のセルが

Values に設定されます（Values はスカラーである必要があります）。Values が-1 の場合、MatrixOut は次のようになりま

す。 
 

 
 
 

• RowRangeList が 2:4 で、ColumnRangeList が指定されていない場合は、行 2、3、4 のすべてのセルが Values に設
定されます。Values には、スカラー、1 行 9 列の行列、または 3 行 9 列の行列を指定できます。 

 
 

Values がスカラーの場合、行 2、3、4 のすべてのセルがその値に設定されます。Values が-1 の場合、MatrixOut は次のように

なります。 
 

 
 
 

• Values が次のような 1 行 9 列の行列の場合、 
 

 
 

行 2、3、4 の列 0 は、Values 行列のセル 0,0 の値に設定され、行 2、3、4 の列 1 は、Values 行列のセル 0,1 の値に設定

されます（以降も同様）。MatrixOut は次のようになります。 
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• Values が次のような 3 行 9 列の行列の場合、 
 

 
 

行 2 が Values 行列の行 0 の値に、行 3 が Values 行列の行 1 の値に、 
行 4 が Values 行列の行 2 の値にそれぞれ設定されます。MatrixOut は次のようになります。 

 

 
 

 
 

Set Table Values 

 
 
Set Table Values は、テーブルの指定された行の値を設定します。 

 
RangeList で同じ行番号が複数回指定されている場合、テーブルのその行の値が毎回設定されます。つまり、Values が

テーブルの場合、TableOut のその行の値は、RangeList でその行が最後に指定されたときに設定されていた値になります。

たとえば、TableIn が[83,208,180,96,45,234]、RangeList が[1:3,1:1]、Values が[34,27,160,69]の場合、

TableOut は[83,69,27,160,45,234]になります。 
 

Sort Items 

 
リストまたはテーブルを取得し、値のリストまたはテーブルとインデックス（0 から開始）のリストを作成します。これらは指定された

順序（昇順/降順）で並べ替えられます。 
 
次に例を示します。 

 
• 昇順。DataIn が[ 15,12,17,13 ]の場合、DataOut は[ 12,13,15,17 ]、Indices は[ 1,3,0,2 ]になります。 

• 降順。DataIn が[ 15,12,17,13 ]の場合、DataOut は[ 17,15,13,12 ]、Indices は[ 2,0,3,1 ]になります。 
 
値のセットを値の別のセットと同じ方法で順序付けることができるように、出力インデックスは Arrange Items 演算子と共に使
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用されます。たとえば、2 つのテーブルがあり、1 つはクラス名で構成され、もう 1 つはそれらのクラス名に関連付けられたヒストグラ

ム値で構成されているとします。Class Names テーブルが英数字順に並べ替えられている場合、ヒストグラム値も対応するクラ

ス名に対して正しく並べ替えられるように、 
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この演算子によるインデックス出力を Arrange Items 演算子への RangeList 入力として使用して、Histogram テーブ

ルを再編成できます。 
 

 

Update Image with RPCs 

 
 

一部の画像形式リーダーは、関連する有理多項式係数（RPC）情報を自動的には認識しません。この場合、ERDAS 

IMAGINE がその情報を使用してデータを正確にジオリファレンスできるように、ユーザーが画像の RPC 情報を手動で幾何学的

に校正（更新）する必要があります。この演算子は、RasterFilename と SensorModelName を使用して RPC ファイルを

見つけ、これを使用して画像を更新します。 
 
オプションの RPCFilename は、この演算子がファイルの自動検索に失敗した場合の入力として提供されています。 

 
 
 
 

更新された演算子 
 

 

Classify Using Machine Learning 

 
 

TrainingAttributeImportances と呼ばれる新しい出力ポートが追加されました。この演算子を実行すると、このポート

によって、分類に使用される属性の名前と分類における各属性の重要度が含まれたディクショナリが生成されます。これらの

値の範囲は 0～1 で、すべてのトレーニング属性の重要度の合計は 1 に定義されています。MachineIntellect がこの出

力測定をサポートしていない場合は、すべての重要度が 1/<トレーニング属性の数>になります。 
 
重要度の値は、分類の成功に寄与する最も重要な入力変数を特定する際に非常に役立ちます（さらに重要なのは、重要で

はない変数を特定して後の分類から除外できるため、分類プロセスが効率化されます）。 
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Initialize Naïve Bayes 

 
 
この演算子は、Classify Using Machine Learning 演算子を使用してデータを分類する際の入力として使用される単純ベイ

ズ分類器を定義し、 

トレーニングします。 
 
TrainingAttributesScaling と呼ばれる新しい入力ポートを使用して、トレーニング属性値を同様の範囲にスケーリングでき

ます。スケーリングにより、トレーニングの速度と分類の精度が向上する可能性があります。 
 

 

Orthorectify 

 
 
ラスター ストリーム内のデータは、幾何補正されるのではなく、ジオリファレンス可能な場合があります（古い言い方をすると、

データは投影座標系に合わせて修正されるのではなく、2D または 3D 幾何モデルで幾何学的に校正されます）。通常の状況

では、Spatial Modeler はジオリファレンス可能な状態を維持しますが、一部のワークフローでは、ジオリファレンス可能なラス

ターを幾何補正された状態で保持する必要があります。Orthorectify 演算子がこの役割を果たします。 
 
ERDAS IMAGINE 2020 では、これまで Warp 演算子を使用する必要があった機能を組み合わせるために、

Orthorectify 演算子が多数の新しいポートで更新されました。 
 

• CellCalculationMethod 

• AllowApproximation 

• ApproximationTolerance 

• ApproximationMaxOrder 

• ApproximationGridSize 
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• UsePyramids 



ERDAS IMAGINE 2020 Update 1 

2019 年 10 月 30 日 33 

 

 

 
 

Set to NoData 

 
 

NoDataValue 入力ポートが、入力としてラスターを受け入れるようになりました。これは、ラスター レイヤーを使用して別のラ

スター レイヤーをマスクする場合に役立ちます。 
 
NoDataValueへの入力がスカラーの場合、NoDataValue ポートで指定された値と一致するすべてのピクセル値が出力ラス

ター ストリームで NoData としてマークされるように、入力ラスター ストリームがフィルター処理されます。 
 
NoDataValue への入力がラスターの場合、そのラスター内の NoData としてマークされているピクセル位置が、出力ラスター 

ストリームで NoData としてマークされます。NoDataValue ラスターのラスター範囲外の領域は NoData と見なされます。 
 
すでに NoData としてマークされている入力ラスター ストリーム内のピクセルは、NoData としてマークされたままになります。

NoData としてマークされたピクセルの元の値は保持されません。 
 

 

共有演算子 

以下 の演算 子 は、IMAGINE Advantage、 IMAGINE Professional 、GeoMedia Advantage、

GeoMedia Professional のライセンス ユーザーによる使用が許可されています。 
 
これらの演算子を使用する空間モデルは、IMAGINE Essentials または GeoMedia Essentials を使用して 

実行することはできません。 
 

 

Accumulate Flow 

 
 

Accumulate Flow 演算子は、水文解析に使用されるグリッド演算子群に含まれます。この演算子は 

FlowRaster を取得し、サーフェス全体の累積流量を計算します。 
 
Accumulate Flow 演算子によって生成される AccumulationRaster には、各ピクセル値がそのピクセルへの流れに寄与す

るピクセルの総数を示すデータが含まれています。値がゼロのピクセルは、源流ピクセル（流入がなく、流出のみがあるピクセル）

を示します。値が NoData のピクセルは流れがないことを示します。AccumulationRaster を水文解析ワークフローの一部とし

て使用して、河川/河川網を特定したり、流域（集水域）を見つけるために使用できる排水口を特定したりできます。 
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Calculate Flow 

 

Calculate Flow 演算子は、排水網と流域を識別するための一連の演算子の一部です。Calculate Flow は、数値標高

モデル（DEM）などの連続する地表高度データのラスターで 

動作します。この演算子によって生成される FlowRaster の各ピクセル値は、流出が地形上を流れる方向（実際には最

急勾配方向）を表します。 
 
ピクセルごとに、水平距離と垂直距離の両方を考慮して、ピクセルの中心と 8 つの隣接ピクセルの中心を結ぶ線分の勾配が

計算されます。ピクセルの中心と、直接隣接する 4 つのピクセルの中心との間の水平距離は、ピクセル解像度に等しくなりま

す。ピクセルの中心と、斜めに隣接する 4 つのピクセルの中心との間の水平距離は、ピクセル解像度の 2 倍の平方根に等し

くなります。 
 
流出は最も急な下り勾配の方向に流れると想定されています。「タイ」が許可されます。つまり、流出は複数の方向に流れるこ

とができます。結果のピクセル値は流れの方向を示します。 
 
水文解析のために、まず、DEMRaster で Fill Depressions 演算子を実行して窪地のないサーフェスを作成する必要があり

ます。この窪地のないサーフェスを、Calculate Flow 演算子への入力 DEMRaster として使用すると、不明瞭な流れのない

FlowRaster が生成されます。この新しい FlowRaster は、Accumulation Flow 演算子への入力として使用できます。 
 

 

Fill Depressions 

 
 
Fill Depressions 演算子は、水文解析に使用されるラスター演算子群に含まれます。この演算子は、排水網と流域を識別

するための一連のラスター演算子の一部として使用できます。 
 
Fill Depressions は、数値標高モデル（DEM）などの連続する地表高度データのラスターで 

動作します。サーフェスの小さな窪地が取り除かれた FilledRaster が生成されます。 
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Find Watersheds 

 
 

水文解析では、流域（集水域）は、すべての水（降雨、細流、河川など）が共通の出口に流出する土地の領域と定義さ

れます。流域は、1 つの貯水池または 1 つの河川区間に流れ出る土地の領域のように小規模な場合もあれば、 
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主要河川の河口に流れ出る土地の領域のように大規模な場合もあります。Find Watersheds 演算子は、水文解析に使

用されるラスター演算子群に含まれます。この演算子では、FlowRaster を使用して、OutletRaster によって識別された共

通の流出口に水が流れ出る流域を見つけます。 
 
FlowRaster には、各セルの下り排水流方向を示すデータが含まれている必要があります。 

 
OutletRaster には、流域を見つけるための共通の流出口を一意に識別するデータが含まれています。流域の共通の流出

口を定義するピクセルには、同じ整数値を割り当てる必要があります。OutletRaster では、複数の流域の共通の流出口を

定義することができますが、それぞれに一意の整数値を割り当てる必要があります。流域の流出口を定義しないピクセルはす

べて NoData に割り当てる必要があります。OutletRaster では、細流または河川の河口にあるピクセルの単一または小規

模のセット、河川網または河川区間を定義するピクセルの線形セット、あるいは不明瞭な流れのゾーンを定義するピクセル群

として共通の流出口を定義できます。 
 
Find Watersheds 演算子によって生成された WatershedRaster には、OutletRaster で定義された、一意に識別さ

れた共通の流出口ごとに見つかった流域を示すデータが含まれています。流域を定義するピクセルには、関連する共通の流

出口ピクセルと同じ整数値が割り当てられます。流域に割り当てられていないピクセルは、すべて NoData に設定されます。 

Interpolate Using IDW 

 
 

Interpolate Using IDW は、逆距離加重法（IDW）アルゴリズムを使用して不完全なデータから連続ラスター データ セッ

トの作成を試みる補間関数を実行します。値を持つ隣接ピクセルに基づいて、NoData の位置の値が計算されます。 
 
この処理は、等高線やギャップのあるリモート センシング画像などの半連続データに最適です。独立標高点、地質調査データ、

クラスタ化されたデータ、ランダム ポイントなどの非常にまばらなポイント データの場合、クリギング処理を適用して連続データ 

セットを補間します。次のシナリオを処理する場合に、Interpolate Using IDW を使用してください。 
 

• 高度密度や一定間隔のデータ ポイント（標高データ、気温データ、降雨データ、連続的に変化するサーフェスからのデータなど）

の場合 

• 衛星データ、航空写真モザイク、または数値標高モデル（DEM）モザイクの小さなギャップを埋める場合 

• 元のデータの正確さに対する信頼度が低い場合 

• 等高線または稜線および流路データから DEM を作成する場合 
 

 

形式のサポート 

Cloud Optimized GeoTIFF 

ERDAS IMAGINE 2020 では、[Retriever]ペインから Amazon S3 パブリックおよびプライベート クラウド ストレージ 

サービスにアクセスできます。これらのサービスを介して使用する最も効果的な形式の 1 つが、Cloud Optimized GeoTIFF

（COG）形式です。 
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この方法でアクセスされるデータは、Spatial Model Editor で使用したり、画像チェーンを使用して表示したりできます。
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MIE4NITF 

時系列データセットが、MIE4NITF 標準で保存および提供されるようになりました。これは、NITF で保存された数百、

数千の個々の画像フレームで構成できます。 
 
ERDAS IMAGINE 2020 は、時系列を「再生」し、個々のフレームを開いてさらに活用できるようにするために、複数の

MIE4NITF フレームをフリッカー ツールなどのツールで開くことができるように強化されています。 
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GeoPackage 

Spatial Modeler と画像チェーンでは、一般的な GeoPackage 形式で保存されたラスター データを読み取ることができま

す。Spatial Modeler から、ベクター フィーチャーにアクセスすることもできます。 
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Luciad Terrain Services 

オルソ補正や他の目的に使用できる標準のラスター データ ソースとして、LuciadFusion の Luciad Terrain Services を

ERDAS IMAGINE で使用できます。 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

NetCDF 

Spatial Modeler と画像チェーンでは、NetCDF 形式のラスター データを読み取ることができます。 
 

 

WMS の表示の最適化 

ERDAS IMAGINE の 2D View の表示動作は、主にソース データからのタイルの取得に基づいています。（2D View の範

囲よりも大きい範囲をカバーする）これらのタイル要求は、必要な範囲全体をカバーするタイルが 1 つだけ返されることを求めて

いるときに、WMS サーバーの問題を引き起こすように思われます。 
 
そのため、ERDAS IMAGINE 2020 では、すべての WMS データ レイヤー タイプで使用するための別の表示モード/オプショ

ンが導入されました。このオプションは、リボン インターフェイスの[Continuous Roaming]というチェックボックス ボタンとして

表示され、デフォルトでオフ（新しい動作）に設定されています。 
 
このチェックボックスをオンにすると、WMS サーバーに対する要求の対象がビューの範囲ではなくタイルになります。このモードをオ

ンにする利点は、範囲をパンまたはズームしながら（たとえば、マウスの中央ボタンを押したままデータをドラッグしながら）タイル

要求を送信し、データを画面にレンダリングできることです。欠点は、ビューの範囲を埋めるまでの全体的な時間が⾧くなる可

能性があることです。 
 
これに対して、このモードがオフ（新しい動作）の場合、データ要求は現在のビューの範囲のみが対象となります。この場合、

データが返されてレンダリングされるまでの時間がタイルの場合よりも短縮されます。ただし、欠点は、要求を送信できるのが、

ローミング/ズーム アクションが停止しているとき（パン中にマウスの中央ボタンを離したときや、Auto Roam モードが停止また

は一時停止されているときなど）に限られることです。そのため、データがアクティブに「移動」されている間、マウスを離すまで前

のデータ範囲の周りが黒くなります。しかし、WMS レイヤーの場合、一般にパフォーマンスが向上します。 
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ERDAS IMAGINE - 全般 
 

 

画像チェーンの印刷 

画像チェーンを使用して表示されている画像を地図構成に含め、印刷デバイスに送信し、[Send To…]操作（[Send to 

PowerPoint]、[Send to JPEG]、[Send to Geospatial PDF]など）に含めることができるようになりました。 
 

 

最適なシームラインの生成 

シームラインの生成は、モザイク化ワークフローでシームレスな画像モザイクを作成するための非常に重要なステップです。モザイク

化される画像には、通常、放射測定の不整合や未解決の幾何学的なずれがあります。シームラインの生成は、作成されたモザ

イクがシームレスに見えるように、放射測定の不整合や大きなずれがある領域を回避することを目的としています。 
 
上記の目的を果たすために、グラフ カット エネルギー最小化フレームワークを使用する新しいシームライン生成オプションが

MosaicPro に追加されました。ピクセル値と勾配は、画像間のオプションのシームラインを見つけるために使用されるコスト関数

およびグラフ カットとして使用されます。 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

3Dconnexion SpaceMouse Pro 

Viewplex ベースのステレオ ビューアー（Stereo Point Measurement ツール、Terrain Editor、ORIMA、

PRO600）に、デジタル化デバイスとして 3Dconnexion SpaceMouse Pro のサポートが追加され、入力デバイスの

選択肢が増えました。 



ERDAS IMAGINE 2020 Update 1 

2019 年 10 月 30 日 42 

 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

選択したブレークラインのコピー 
 

既存のブレークラインをコピーし、選択したブレークラインからの指定したオフセットにコピーを配置できる新しいブレークライン編

集機能が Terrain Editor に導入されました。この機能には、Terrain Editor の[Terrain Editing]パネルにある

[Operator]ドロップ ダウン メニューからアクセスできます。 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

ブレークラインの頂点の編集 

ブレークライン頂点編集機能が強化されました。質量点の編集と同様に、ブレークラインの頂点を編集できるようになりま

した。頂点が属するブレークラインを選択する必要はなくなりました。
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ブレークライン編集時の等高線の動的更新 
 

ブレークラインの編集中に、等高線が動的に更新されるようになりました。これにより、ユーザーは現在行っている編集の効

果のフィードバックを即座に得ることができます。ERDAS IMAGINE 2020 より前では、等高線はポイントの編集中には動

的に編集されましたが、ブレークラインの編集時はブレークラインの編集が完了するまで更新されませんでした。この更新によ

り、ポイントおよびブレークラインの編集中に、等高線が動的に更新されます。 
 

 

スタイル ライブラリの一貫した場所 
 

ERDAS IMAGINE 2020 では、各「ハイブ」（$PERSONAL、C:/ProgramData/ERDAS/ERDAS IMAGINE 

2020、$IMAGINE_HOME）内の etc ディレクトリの関連するサブディレクトリでのみ、スタイル ライブラリが検索されるよ

うになりました。ソフトウェアは、$PERSONAL、etc、または etc の外部のサブディレクトリ（$IMAGINE_HOME/Colors

や$PERSONAL/LineStyles など）を直接参照しなくなりました。 

 

• 矢印のスタイル:etc/Arrows 

• 色:etc/Colors 

• 塗りつぶしのスタイル:etc/FillStyles 

• 線のスタイル:etc/LineStyles 

• 符号:etc/symbols 

• テキストのスタイル:etc/TextStyles 

 

カスタマイズされたスタイル ライブラリを古い場所のいずれかに保存している場合は、ERDAS IMAGINE 2020

以降で使用するために、それらを新しい場所に移動する必要があります。 
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システム要件 

ERDAS IMAGINE 

コンピューター/プロセッサー 
64 ビット:Intel 64（EM64T）、AMD 64、または同等の CPU 

（マルチコア プロセッサーを強く推奨） 

メモリ（RAM） 16 GB 以上を強く推奨 

ディスク容量 

 ソフトウェア – 6 GB 

 サンプル データ - 7 GB 

データ ストレージ要件は、地図作製プロジェクトによって異なります。1 

オペレーティング システム 2、3 

 Windows 10 Pro（64 ビット）4 

 Windows Server 2016（64 ビット） 

 Windows Server 2019（64 ビット） 

ソフトウェア 

 OpenGL 2.1 以上（通常、サポートされているグラフィックス カードが付属 5） 

 Java Runtime 1.7.0.80 以上 - IMAGINE Objective には JRE が必要です。インストールおよ

び構成済みの JRE バージョン 1.7.0.80 以上を使用できます。 

 Python 3.6.x または 3.7.x （Python は、必要に応じて Spatial Modeler で使用できます。) 

 Microsoft DirectX® 9c 以上 

 .NET Framework 4.0 

 GPU で NNDiffuse およびその他の演算子を高速化する場合は、倍精度（cl_khr_fp64）をサ

ポートするデバイスを使用した OpenCL 1.2 

 CUDA 機能を備えた NVIDIA カードをディープラーニングで使用することをお勧めします。 

推奨グラフィックス カード  NVIDIA® Quadro® K5200、K5000, K4200、K4000, K2200、K600, K420 6 

ステレオ表示用 

推奨モニター 

 NVIDIA 3D Vision™ Kit に対応した 120 Hz（以上）の LCD モニター7 または 3D PluraView 

system from Schneider Digital 7  
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周辺機器 

すべてのソフトウェア インストールに次のデバイスが必要です。 

 スクロール ホイール付き Windows 互換マウスまたは同等の入力デバイス 

 印刷には Windows 対応のハードコピー デバイスが必要 8 

ソフトウェア セキュリティ（Hexagon Geospatial Licensing 2020）には、次のいずれかが必要です。 

 イーサネット カード、または 

 ハードウェア キー用 USB ポート x1 

高度なデータ収集には、次のいずれかのハンド コントローラーが必要です。9 

 TopoMouse™または TopoMouse USB™ 

 Immersion 3D マウス 

 MOUSE-TRAK 

 Stealth 3D（Immersion）、S3D-E タイプ、シリアル ポート 

 Stealth Z、S2-Z モデル、USB バージョン 

 Stealth V、S3-V タイプ（シリアル デバイスとして追加） 

 3Dconnexion SpaceMousePro10 

 3Dconnexion SpaceExplorer マウス 10 

 EK2000 Hand Wheels 

 EMSEN Hand Wheels 

 Z/I マウス 

ArcGIS および GeoMedia との相

互運用性 

 ERDAS IMAGINE は、GeoMedia 2018、または GeoMedia 2020 がインストールされているコン

ピューターに安全にインストールできます。ただし、最大限の互換性を確保するために、適合するバージョ

ンをインストールすることを強くお勧めします。 

 ERDAS IMAGINE 2020でライブ リンクを使用するには、GeoMedia 2020が必要です。インストー

ルの順序は問いません。 

 ERDAS IMAGINE は、* .mdb と*.gdb の両方の種類のパーソナル ジオデータベースと対話できま

す。 

 ERDAS IMAGINE は、ArcGIS® バージョン10.6～10.7.1がインストールされているコンピューター

に安全にインストールできます。 

 ERDAS IMAGINE と IMAGINE Photogrammetry は、ArcGIS Server 10.6-10.7.1 ジオ

データベース サーバー（ArcSDE）と対話できます。エンタープライズ ジオデータベースの読み込みや

操作を行うには、以下が必要です。 

o 適切なバージョンの ArcGIS for Desktop（バージョン 10.6～10.7.1）をインストールし

てライセンスを取得する。または 

o IMAGINE Geodatabase Support（ArcEngine 10.7 ベース）をインストールする

（ライセンスは不要）。 
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データベース エンジン 

 Postgre9.6 と PostGIS 2.3:PostGIS を使用して、GeoMedia フィーチャー（.sfp）を保存でき

ます。 

 Oracle Server 12c 12.2. 64-bit:Oracle Server 12c を使用して、Oracle GeoRaster

（.ogr）（Oracle Spatial が必要）、SDE Raster（.sdi）（ArcGIS for Server が必要）、

Oracle Spatial Features（.ogv）（Oracle Spatial が必要）、および GeoMedia フィーチャー

（.ofp）を保存できます。 

 Microsoft SQL Server 2017 64bit :Microsoft SQL Server 2017 を使用して、GeoMedia

フィーチャー（.sfp）を保存できます。 

ERDAS IMAGINE のシステム要件に関する注意事項 

1 通常、ディスク I/O は、地理空間データ処理において最も時間のかかるタスクです。高速のハード ディスクを使用すると、生産性が向

上します。1 つのディスクからデータを読み込み、2 つ目のディスクに一時データを書き込み、3 つ目のディスクにデータを書き込むと、パ

フォーマンスが向上します。ディスク アレイは生産性を向上させますが、一部の RAID オプションではパフォーマンスが低下します。ネット

ワーク ディスク ドライブは、ネットワークの制限を受けます。 

2 サーバー オペレーティング システムは、IMAGINE Photogrammetry、ORIMA、ERDAS ER Mapper ではサポートされていませ

ん。 

3 IMAGINE Photogrammetry の 3D ステレオ表示と周辺機器の要件により、オペレーティング システムの選択肢が限られます。 

4 ERDAS ER Mapper は、Windows 8 ではサポートされていません。Windows 8.1 では実行可能と見なされています。 

5 Windows では、サポートされているすべてのグラフィックス カードに対応する汎用 OpenGL ドライバーが提供されています。ただし、こ

れらのアプリケーションには、OpenGL に最適化されたグラフィックス カードとドライバーが推奨されます。 

6 以前のバージョンの IMAGINE Photogrammetry と ORIMA で認定済みのグラフィックス カードも互換性がある可能性があります

が、現在のバージョンでは認定されていません。 

7 以前のバージョンのIMAGINE PhotogrammetryとORIMAで認定済みのステレオ モニターも互換性がある可能性がありますが、

現在のバージョンでは認定されていません。 

8 HP-RTL ドライバーが推奨されます。64 ビット版の Windows プリント サーバーには、64 ビットのプリント ドライバーが必要です。 

9 Stealth S-Mouse（S2-S モデル）と MOUSE-TRAK は、Stereo Analyst® for ERDAS IMAGINE でのみサポートされてい

るハンド コントローラーです。 
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10 3Dconnexion マウスは、IMAGINE Photogrammetry でサポートされています。 
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Issues Resolved – ERDAS IMAGINE 2020 Update 1 

Various Product Tiers 

Issue ID  Summary  Description / How to Reproduce  

IM-51400  ERDAS IMAGINE 2020 

Crashes on 3D Line 

Measurement for 

Geographic Projected 

Point Cloud data  

ERDAS IMAGINE 2020 b1339 crashes on 3D Line measurement for Point Cloud 

data which have Geographic Projection. Steps to Reproduce 1. Launch ERDAS 

IMAGINE and open specific Geographic point cloud data 2. Click Show 3D, a new 

3D display will open and wait for the data to load 3. Select "Measure Line" and try to 

measure distance. Select the first point and then the second point. 4. After selection 

of the second point wait for few seconds, ERDAS IMAGINE will 

crash. !null-xform-from-geog-to-utm1.png|thumbnail! The same data set reprojected 

to a Projected coordinate system works fine in 3D Line measurement .  

IM-51275  RSETs not used when 

built for a J2K NITF image 

which has subimage(s)  

Input Image - NITF image using JPEG2000 compression and containing at least one 

subimage. Typically the subimage is a cloud layer. Problem: - generate RSETs using 

Create Image Pyramids operator (or ImageInfo) (ok) - the performance preference is 

ignored and the RSETs always begin at R1 - the processing takes a 2nd long pass. - 

the generated RSETs are not used by the 2D View. - ImageInfo > Pyramid Layer 

Algorithm still shows "JPEG2000 Wavelet Transform". If use the same dataset, but 

go out to .pyrx things are generally good. The .pyrx does not start at R1 and the .pyrx 

is being used by the 2D View.  

IM-51276  Failed creating RRDs for 

NITF image  

Replicated using a WorldView NITF image  

Make sure the "Pyramid Layer Generator" Preference is set to "Always use RRD..." 

Start ERDAS IMAGINE 2020 Home tab > Information group > Metadata pulldown > 

Edit Image Metadata Select the NITF image as input Click the Compute Pyramid 

Layers checkbox Click Options... Error: args Error: Unable to create unique proxy 

file. Image Command Tool exits.  

IM-51348  New pyramids labeled 

"incorrect" when dropping 

NITF into 2DView with 

Preferences set to "all 

segments"  

* Copy a NITF file locally. * Set the NITF "Drag/Drop Behavior" preference to "Open 

all segments in a single view." * Using imageinfo or imagecommand tool create 

pyramids for the NITF image. Set the Generator to PYRX (or RRD once IM-51276 

has been fixed). Leave/set the Downsampling Method to Auto. * Drag and drop the 

NITF into a 2DView. There's a red "x" badge in the TOC, indicating that "Pyramid 

information is incorrect" and "Pyramids needs to be rebuilt for best performance." 

The .aux file for the NITF has RRDInfoList and RRDNamesList for the layers, but 

drag and drop with the NITF "Drag/Drop Behavior" preference set to "Open all 

segments in a single view." creates an .sbi file, and it doesn't seem to recognize that 

the pyramids are optimized.  

IM-51347  Creating RSETs for NITF 

that's J2K compressed 

appears to "lose" its 

pyramids  

* Copy NITF file locally. * Open the NITF in a 2DView. There's no warning/error 

badge on the layer in the TOC, so it appears to have optimized pyramids. * Close the 

image. * Open the image in imageinfo. It says the pyramid layer algorithm is JPEG 

2000 Wavelet Transform. * Click on the sigma button to create RSETs for the NITF 

image. Turn on Compute Pyramid Layers. Set the Generator to any of the RSET 

options. Leave/set the Downsampling Method to Auto. Click OK. * Click "Yes" to the 

warning about existing pyramids (it's not really going to do anything, since they're 

internal J2K). * The pyramid layer algorithm now says Unknown Downsampling, 

which a little disconcerting. * Open the NITF in a 2DView. Now there's a red "x" 

badge in the Contents pane, indicating that "Pyramid information is incorrect" and 

"Pyramids needs to be rebuilt for best performance." * If you Correct the Alert, the 

badge goes away, but if you close ERDAS IMAGINE and restart it and open the 

NITF again, the red "x" badge is back.  
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IM-51341  Auto pyramid 

downsampling looks bad 

for RGB/LUT NITF  

Using a NITF file which has an IREP of RGB/LUT: # Using either imageinfo or 

imagecommand tool create pyramids for the specified image  

# Set the Generator to any of the RSET options. Leave/set the Downsampling 

Method to Auto. # Display the image in a 2DView. It looks great. # Now fit to frame. It 

doesn't look the same–lots of black (transparent pixels).  

The same thing happens using Manage Data | Image | Pyramids & Statistics | 

Process Footprints and RSETs in 16.5.2 and 16.6.0. Same thing happens using the 

Create RSETs operator in 16.5.2.  

IM-51527  Unable to create RSET for 

NITF that has negative 

ILOC values  

Unable to create RSET for NITF that has negative ILOC values in ERDAS IMAGINE 

2020. In 2018 the Create RSETs operator fails with error "Unknown error code - 0"  

IM-51427  Error creating pyramids for 

multi-image TIFF  

When running a Spatial Model that generates pyramid files for a multi-image TIFF 

the following errors occur: 22/10/19 17:31:30 SessionMgr(1476): ERROR: #909 from 

erdas::raster::PyramidManager::ValidatedRRDsWrite 22/10/19 17:31:30 

SessionMgr(1476): ERROR: erdas::raster::PyramidManager::ValidatedRRDsWrite 

failed 22/10/19 17:31:30 SessionMgr(1476): ERROR: #897 from 

erdas::raster::PyramidManager::ValidatedRRDsWrite 22/10/19 17:31:30 

SessionMgr(1476): ERROR: eimg_SSLayerInfoSet failed 22/10/19 17:31:30 

SessionMgr(1476): ERROR: #23443 from eimg_SSLayerInfoSet 22/10/19 17:31:30 

SessionMgr(1476): ERROR: No method found for modifying subsampled layers of 

c:/data/multipage_tif_example.tif(:Untitled_0_RGB~Layer_1) 22/10/19 17:31:30 

SessionMgr(1476): ERROR: #909 from 

erdas::raster::PyramidManager::ValidatedRRDsWrite 22/10/19 17:31:30 

SessionMgr(1476): ERROR: erdas::raster::PyramidManager::ValidatedRRDsWrite 

failed 22/10/19 17:31:30 SessionMgr(1476): ERROR: #897 from 

erdas::raster::PyramidManager::ValidatedRRDsWrite 22/10/19 17:31:30 

SessionMgr(1476): ERROR: eimg_SSLayerInfoSet failed 22/10/19 17:31:30 

SessionMgr(1476): ERROR: #23443 from eimg_SSLayerInfoSet 22/10/19 17:31:30 

SessionMgr(1476): ERROR: No method found for modifying subsampled layers of 

c:/data/multipage_tif_example.tif(:Untitled_0_RGB~Layer_2) 22/10/19 17:31:31 

SessionMgr(1476): ERROR: #909 from 

erdas::raster::PyramidManager::ValidatedRRDsWrite 22/10/19 17:31:31 

SessionMgr(1476): ERROR: erdas::raster::PyramidManager::ValidatedRRDsWrite 

failed 22/10/19 17:31:31 SessionMgr(1476): ERROR: #897 from 

erdas::raster::PyramidManager::ValidatedRRDsWrite 22/10/19 17:31:31 

SessionMgr(1476): ERROR: eimg_SSLayerInfoSet failed 22/10/19 17:31:31 

SessionMgr(1476): ERROR: #23443 from eimg_SSLayerInfoSet 22/10/19 17:31:31 

SessionMgr(1476): ERROR: No method found for modifying subsampled layers of 

c:/data/multipage_tif_example.tif(:Untitled_0_RGB~Layer_3) 22/10/19 17:31:31 

SessionMgr(1476): ERROR: #8043 from edsc_HFATableCreate 22/10/19 17:31:31 

SessionMgr(1476): ERROR: ehfa_ObjectWrite failed 22/10/19 17:31:31 

SessionMgr(1476): ERROR: #7761 from ehfa_ObjectWrite 22/10/19 17:31:31 

SessionMgr(1476): ERROR: ehfa_EntrySeek failed 22/10/19 17:31:31 

SessionMgr(1476): ERROR: #4328 from eimg_DSCTableCreate 22/10/19 17:31:31 

SessionMgr(1476): ERROR: edsc_TableCreateWithMethods failed 22/10/19 

17:31:31 SessionMgr(1476): ERROR: #775 from edsc_TableCreateWithMethods 

22/10/19 17:31:31 SessionMgr(1476): ERROR: TableCreate failed 22/10/19 

17:31:31 SessionMgr(1476): erdas::sb_raster::StatsUtils::UpdateStatistics failed 

22/10/19 17:31:31 eimg_AllStatsStackWrite failed 22/10/19 17:31:31 Error reported 

by function eimg_AllStatsWrite 22/10/19 17:31:32 eimg_TableCreate failed 22/10/19 

17:31:32 edsc_TableCreateWithMethods failed 22/10/19 17:31:32 TableCreate 
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failed It doesn't seem to matter whether PYRX, RRD, or RSETs is selected for the 

Generator–it always fails–but if left as Auto, it works.  

IM-51536  Problems using SIPS 

downsampling to generate 

RSETS for SICD images  

SICD images are large single blocked NITF files. Using the SIPS downsampling 

technique to make RSETs is stressing the memory constraints of the system.  

IM-51454  RRD / SIPS pyramids for 

DTED Level 2 appears to 

have artifact problems  

ERDAS IMAGINE 2020 64-bit b1339 Make a local copy of a DTED Level 2 file (no 

ancillary files, just the .dt2) Bring up ImageInfo and generate pyramids on the DTED 

using Auto / Auto (which should currently apply RRD / SIPS) Display Fit to Frame 

The upper left of the data looks odd - it appears a flat grey expanse with no variation  

IM-51446  Can't auto-generate 

pyramids for a CADRG 

image  

ERDAS IMAGINE 2020 64-bit b1339 Default Preferences Open a CADRG A.TOC 

image into a 2D View You will be prompted that "This Image does not have pyramid 

layers. Click 'Yes' for the pyramid layers to be computed. Click 'No' to not compute 

the pyramid layers." Click Yes Ignore for a second that the message pops up again 

(there's a separate bug on that) Another Error message pops up saying "Did not find 

metadata" ….and no pyramids are generated. Can't generate them in ImageInfo 

either. Works fine in ERDAS IMAGINE 2018 Update 2. If I use ImageInfo and 

manually select to create RRDs (rather than leaving it as Auto) I can generate RRDs 

successfully.  

IM-51426  Crash creating RSETs for 

TIFF image  

ERDAS IMAGINE 2020 exits when creating RSETs for a TIFF image. This worked 

fine using the Create RSETs operator in ERDAS IMAGINE 2018 Update 2.  

IM-51282  ResampleProcess run 

failed in rrd generation  

ERDAS IMAGINE 2020: Outputs from Orthorectification, Reprojection, etc were 

failing to generate RRD format pyramid files. The output images are okay but their 

rrd files are not created successfully. In the output folder, I can only see their partial 

rrd files (such as controlpoints_ikonosrpc_default.partial.rrd).  

IM-50901  Resample process is 

producing rrd rather than 

pyrx (for u16 output)  

Steps to reproduce: In ERDAS IMAGINE 2020 32bit or 64bit go to Raster Tab > 

Geometric Calibration > Orthorectify Without GCP > select a NITF and click OK. In 

Set Geometric Model > select NITF RPC and Click OK. In NITF RPC Model 

Properties dialog, click Apply. In Resample dialog, specify output file and click OK. 

Output file is created. Check output files and note that a .rrd was produced rather 

than the expected .pyrx  

IM-51456  Can't create pyramids for 

certain HDF datasets  

The Create Image Pyramid operator fails with certain HDF datasets that have 

multiple images stored in the file.  

IM-51455  CADRG pyramid 

generation should default 

to PYRX / erdasbino3  

ERDAS IMAGINE 2020 64-bit b1339 Current Auto behavior for generating pyramids 

would be PYRX, but ECW compression doesn't work well with this RGB data that 

has very limited colors. Perhaps the format should be RSETs (since it is a variant of 

NITF), but what downsampler should it default to ? SIPS might be a safe choice. But 

would MPD be appropriate since it is a "pseudo thematic" type of dataset? Probably 

needs testing. Results of tests shown below. PYRX / SIPS came out all black and 

RRD / MPD has missing blocks. RSET fails with "Spatial Model failed in 

CreateImagePyramidImpl. The error was "`anonymous-namespace'::produceLevel 

failed No images in this file!"." Of the "succesful" tests, PYRX / erdasbino3 looks 

best. But I'm not sure if we can trust that for "all" CADRG?  

IM-50882  Abandoned lock file when 

creating hyperspectral 

pyramids  

ERDAS IMAGINE 2020 64-bit b1292 See (33GB) hyperspectral .img file If you add 

this image to ImageInfo, click the Sigma icon, select to create pyramids Auto/Auto 

and stats with ignore 0 and OK. Eventually you get the message: Spatial Model failed 

in CreateImagePyramidImpl. The error was "g:/temp/resample.img.lock has been 
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determined to be abandoned due to time since last modification". OK the dialog and 

you are returned to ImageInfo with no pyramids or stats. Session Log: 19/09/19 

11:29:16 imageinfo; 19/09/19 11:29:16 C:/Program Files/Hexagon/ERDAS IMAGINE 

2020/bin/x64URelease/imageinfo.exe 19/09/19 11:52:14 SessionMgr(19788): 

ERROR: #13610 from eimg_LayerStackClose 19/09/19 11:52:14 

SessionMgr(19788): ERROR: CreateImagePyramid failed 19/09/19 11:52:14 

SessionMgr(19788): ERROR: #13117 from 

`anonymous-namespace'::CreateImagePyramid 19/09/19 11:52:14 

SessionMgr(19788): ERROR: RunWithMeter failed 19/09/19 11:52:14 

SessionMgr(19788): ERROR: #199 from RunWithMeter 19/09/19 11:52:14 

SessionMgr(19788): ERROR: 

c:¥work¥jenkins-home¥workspace¥v16.6-smsdk-x64release¥sources_modeler¥sm

processlib¥getmangledprocaddress.cpp failed 19/09/19 11:52:14 

SessionMgr(19788): ERROR: #142 from 

c:¥work¥jenkins-home¥workspace¥v16.6-smsdk-x64release¥sources_modeler¥sm

processlib¥getmangledprocaddress.cpp 19/09/19 11:52:14 SessionMgr(19788): 

ERROR: HexGeo::SpatialModeler::Operator::Execute failed 19/09/19 11:52:14 

SessionMgr(19788): ERROR: #1739 from 

HexGeo::SpatialModeler::Operator::Execute 19/09/19 11:52:14 SessionMgr(19788): 

ERROR: HexGeo::SpatialModeler::Operator::Execute failed 19/09/19 11:52:14 

SessionMgr(19788): ERROR: #1739 from 

HexGeo::SpatialModeler::Operator::Execute 19/09/19 11:52:14 SessionMgr(19788): 

ERROR: HexGeo::SpatialModeler::Operator::Execute failed 19/09/19 11:52:14 

SessionMgr(19788): ERROR: #1739 from 

HexGeo::SpatialModeler::Operator::Execute 19/09/19 11:52:14 SessionMgr(19788): 

ERROR: HexGeo::SpatialModeler::Operator::Execute failed 19/09/19 11:52:14 

SessionMgr(19788): ERROR: #1739 from 

HexGeo::SpatialModeler::Operator::Execute 19/09/19 11:52:14 SessionMgr(19788): 

ERROR: HexGeo::SpatialModeler::Operator::Execute failed 19/09/19 11:52:14 

SessionMgr(19788): ERROR: #1739 from 

HexGeo::SpatialModeler::Operator::Execute 19/09/19 11:52:14 SessionMgr(19788): 

ERROR: HexGeo::SpatialModeler::Operator::Execute failed 19/09/19 11:52:14 

SessionMgr(19788): ERROR: #1739 from 

HexGeo::SpatialModeler::Operator::Execute 19/09/19 11:52:14 SessionMgr(19788): 

ERROR: HexGeo::SpatialModeler::Operator::Execute failed 19/09/19 11:52:14 

SessionMgr(19788): ERROR: #1739 from 

HexGeo::SpatialModeler::Operator::Execute 19/09/19 11:52:14 SessionMgr(19788): 

ERROR: HexGeo::SpatialModeler::Operator::SetErrorMessage failed 19/09/19 

11:52:14 SessionMgr(19788): ERROR: #2006 from 

HexGeo::SpatialModeler::Operator::SetErrorMessage 19/09/19 11:52:14 

SessionMgr(19788): ERROR: Spatial Model failed in CreateImagePyramidImpl. The 

error was "g:/temp/resample.img.lock has been determined to be abandoned due to 

time since last modification".  

IM-51452  Questionable behavior 

creating pyramids for NITF 

SNIP image  

* Make a local copy of Unclassified NITF SNIP data ** The image is 256 x 3352 with 

172 layers * Generate PYRX pyramids ** Takes (for me) about 4.5 minutes ** 

No .pyrx is created ** When you then open the NITF in the 2DView, it thinks 

pyramids are broken * Generate RSETs ** Takes (for me) over 3 minutes ** No 

RSETs are created ** When you then open the NITF in the 2DView, it thinks 

pyramids are (still) missing * Generate RRDs ** Takes (for me) over 15 minutes 

** .rrd is created and has two levels: 128 x 1676 & 64 x 838 ** When you then open 

the NITF in the 2DView, it thinks pyramids are there and optimized (no badge)  
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IM-51535  Inconsistent pyramid 

generation for a JPEG 

2000 encoded Sentinel-2  

ERDAS IMAGINE 2020 64-bit b1339 Make a local copy of Sentinel-2 (S2*_*SAFE) 

image (no ancillary files) Start ImageInfo Load the Sentinel-2 (S2*_*SAFE) image 

(the directory one) Click the Sigma button Turn on Pyramid Generation and leave it 

at Auto Click OK You'll get an Attention dialog saying IMAGEINFO: Every layer in the 

file already has pyramid layers. If you retain existing pyramid layers, only pyramid 

levels which are missing or no longer meet the current performance threshold will be 

created. Would you like to remove the existing layers first? Click No You get a 

progress meter of "Executing Pyramid Layer Generation" (or similar) and it 

completes within a couple of seconds. Stats have been calculated with a Skip of 16 x 

16. A .pyrx has been created of size 760KB and a similarly size .aux. The .pyrx 

seems to contain ECW data starting at 343 x 343 rows/columns HFA View of 

the .aux seems to indicate the recognition of the external .pyrx levels Quit ERDAS 

IMAGINE Delete the .aux and .pyrx files Start ERDAS IMAGINE Start ImageInfo 

Load the Sentinel-2 (S2*_*SAFE) image (the directory one) Click the Sigma button 

Turn on Pyramid Generation and leave it at Auto Click OK You'll get an Attention 

dialog saying IMAGEINFO: Every layer in the file already has pyramid layers. If you 

retain existing pyramid layers, only pyramid levels which are missing or no longer 

meet the current performance threshold will be created. Would you like to remove 

the existing layers first? Click Yes You get a progress meter of "Deleting 

ReducedLayers" "Executing Create Image Pyramid " (or something) and it slowly 

goes through a progress meter taking a minute or so. Stats have been calculated 

with a Skip of 1 x 1. A .pyrx has been created of size 760KB and a similarly size .aux. 

The .pyrx seems to contain ECW data starting at 343 x 343 rows/columns HFA View 

of the .aux DOES NOT indicate the recognition of the external .pyrx levels Should 

there really be a difference in behavior?  

IM-51602  "Pyramids needs to be 

rebuilt for best 

performance" alert after 

building pyramids for 

SPOT7  

ERDAS IMAGINE 2020 64-bit b1347 Make a local copy of the SPOT7 DIMAP image 

directory (no ancillary files created by ERDAS IMAGINE) Start ERDAS IMAGINE 

Start ImageInfo Load the DIMAP .xml Click the Sigma button Turn on Compute 

Pyramid Layers (if not already on) OK Once complete display the DIMAP .xml in a 

2D View Note the Alert badge which has correction "Pyramids needs to be rebuilt for 

best performance"  

IM-51317  Predict Using Machine 

Learning operator missing 

from UI  

The Predict Using Machine Learning operator missing from the Spatial Modeler 2020 

editor.  

IM-51257  Error of failed to delete 

temp file on removing the 

model containing Grow 

Features operator  

ERDAS IMAGINE 2020 32bit/64bit Run/Preview a spatial model designed to use the 

Grow Features operator and then try to remove the model from the viewer. 

Generates an Error  

IM-51278  Preview of all 3D Features 

is Broken  

ERDAS IMAGINE 2020: Run a Spatial Model Editor Preview for either Filter By 

Geometries or Intersect Features operators. Notice that the preview fails with an 

error message "Spatial Model failed in Coordinate Transformation. The error was 

"Input Features not set properly.". Instead of Preview, if we try to create an output 

then it works fine and the output can be displayed properly in the viewer. Please see 

the attached screenshot of the error.  

IM-51033  Images calibrated with 

small DEM display data 

outside DEM extent  

Open a DigitalGLobe NITF image that is associaited to a DEM which has a smaller 

spatial extent than the image in a 2D View, oriented to map:  

Fit to Frame and then zoom out a little and you will start to see imagery that is 

beyond the extent of the DEM used to calibrate the image show up. They should not.  
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IM-51207  Subpixel - Signature 

Evaluation / Refinement 

completely fails in 64-bit, 

while 32-bit gives an Error 

message but Output is 

created  

ERDAS IMAGINE 2020  

Description - In ERDAS IMAGINE 2020 64-bit, the Signature Evaluation process 

fails. However, in ERDAS IMAGINE 2020 32-bit, the process gets completed and an 

output file gets created, but an error message is displayed at the end of processing. 

Steps to reproduce 1.Launch 64-bit/32-bit ERDAS IMAGINE 2020 and click Raster 

tab 2.Click Subpixel and select Signature Evaluation/Refinement 3.Provide input and 

output data path and click OK 4. For 64-bit error message will be displayed, refer the 

attached image and Session log in the comment section. For 32-bit the process will 

complete but an error message will be displayed at the end of processing  

IM-51305  Performing triangulation 

under Classic Point 

Measurement crashes  

This is reproducible only on 32bit ERDAS IMAGINE 2020 1) Launch ERDAS 

IMAGINE -> File -> Open -> Photogrammetric Project 2) Open laguna.blk 3) Under 

Photogrammetry tab -> Point Measurement -> launch Classic Point Measurement 

tool 4) Run APM -> Now try to perform Triangulation (refer the attached Image) 

Observe that ERDAS IMAGINE crashes while trying to perform triangulation  

IM-51206  Subpixel - Automatic 

Signature Derivation fails 

and gives an Error 

message  

ERDAS IMAGINE 2020 64-bit Description - The Automatic Signature Derivation 

process fails and gives an error message. Steps to reproduce 1.Launch 64-bit 

ERDAS IMAGINE 2020 and click Raster tab 2.Click Subpixel and select Automatic 

Signature Derivation 3.Provide input and output data path and click OK 4. An error 

message will be displayed, refer the attached image and Session log in the comment 

section.  

IM-51423  Model containing Add 

Attributes By Order 

throwing error related to 

coordinate transformation.  

ERDAS IMAGINE 2020  

Spatial Model containing Add Attributes By Order throwing error related to coordinate 

transformation.  

IM-51372  Publisher Information 

shown as unknown in ER 

Mapper Vector Support 

setup.exe installer  

1.Download ER Mapper Vector Support installer from 

[link|http://download.hexagongeospatial.com/search?lang=en&product=74ad85a4d1

4b4836abfc6ae2c6f19529&utm_source=pardot.com] 2.Try to install ER Mapper 

Vector Support using setup.exe in extracted ZIP folder 3.Observe Publisher 

Information shown as Unknown  

IM-51208  Projection information in 

the Grow Features 

operator output is incorrect 

for input SeedLocations of 

type Polyline/Polygon  

ERDAS IMAGINE 2020 :  

In ERDAS IMAGINE run a Spatial Model which attempts to use the Grow Features 

operator.  

Now display the output file on top of input raster, observe that output shp file doesn't 

overlap with input raster, as the projection information is incorrect  

IM-51209  Run/Preview fails for 

SeedLocations as 

Multipoint/Single point 

feature for Grow Features 

Operator  

ERDAS IMAGINE 2020 Run or Preview a Spatial Model which uses Grow Features 

where a Multipoint Feature is given for SeedLocations port. Run/Preview displays a 

warning message on the Feature Output/Preview operator that, 'No feature available 

for Output/Preview. On running the model, Output shp file is created which is invalid, 

as on displaying, following dialog shows up stating: Error-'Nonsense Clip Window', 

Warning- 'Reached the Zooming limit, preventing overflow with 'long'' Error -'Invalid 

World Coordinate System'  

IM-51342  Incorrect json output for 

CRS and image name 

strings  

This only happens in 32-bit ERDAS IMAGINE 2020. Output in x64 IMAGINE 2020 is 

good.  

IM-51311  Viewshed - Clicking on 

Viewshed fails to 

open/launch the tool dialog  

ERDAS IMAGINE 2020 64-bit Steps to Reproduce 1.Launch 64-bit ERDAS 

IMAGINE 2020 2. Open a DEM in 2D View from the given path 3. Click Terrain > 

Viewshed - the tool will not launch and there is no error message. Ideally, Viewshed 

tool dialog must open, as it does in 32-bit ERDAS IMAGINE 2020. IMAGINE Session 

Log ------------------- Starting session log... 16/10/19 11:58:54 SessionMgr(26036): 

Connection success for the external process 'eWkspace_64' 16/10/19 11:59:34 

eWkspace_64(18508): Loading GrayScale Layer: 16/10/19 11:59:34 
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d:/test/viewshed analysis/seattle_dem.img(:Layer_1) 16/10/19 11:59:34 16/10/19 

11:59:36 viewer greyscale "d:/test/viewshed analysis/seattle_dem.img" band 1 

transbackground 1; 16/10/19 11:59:36 viewer magnification toplayer 1 resample 

"Nearest Neighbor"; 16/10/19 11:59:39 C:/Program Files/Hexagon/ERDAS IMAGINE 

2020/bin/x64URelease/viewshed.exe 1 16/10/19 11:59:50 SessionMgr(26036): 

viewshed.exe exited with status -1073741819. 16/10/19 12:00:11 C:/Program 

Files/Hexagon/ERDAS IMAGINE 2020/bin/x64URelease/viewshed.exe 1 16/10/19 

12:00:21 SessionMgr(26036): viewshed.exe exited with status -1073741819.  

 

Issues Resolved – ERDAS IMAGINE 2020 

IMAGINE Essentials 

Issue ID  Summary – IMAGINE 

Essentials  

Description / How to Reproduce  

IM-21970  ERDAS IMAGINE is 

creating gaps between 

images when zooming out 

(lost blocks) - caused by 

3x3 pyramid algorithm  

Customer reported that ERDAS IMAGINE 2014 v14.1 is creating gaps between 

multiple images in the viewer when zoomed fully out. The customer’s images are 

8-bit IMG files. When zooming in, the gap between images disappears.  

Gaps are not visible when creating pyramid layers by using 2x2 kernel, but are 

visible when using a 3x3 kernel.  

IM-39368  Viewer ERROR: bad 

allocation associated with 

large volume of image 

color table attributes  

Viewer does not handle images associated with a large number of attributes (i.e. 

color table).  

Test file displays with color scheme and without error in v10.1 & v11.0.5. Gets the 

bad allocation error in v13.0.2.  

Thematic input has 25 million rows and displays initially without error. The attribute 

table (with no color scheme) is displayed fine (except for scrolling to the very 

bottom). Get an error when trying to add colors from the view. Successfully added 

colors and class names using standalone raster attribute editor. Image is redisplayed 

fine after that. It apparently used the cache; it was still gray.  

Exited ERDAS IMAGINE, restarted, displayed the file. Colors are seen but now a 

“bad allocation” error is generated.  

08/07/14 09:35:09 SessionMgr(8668): ERROR: #2606 from 

erdas::viewerApp::ViewerControl::QueryAndOpenFile  

08/07/14 09:35:09 SessionMgr(8668): ERROR: bad allocation  

IM-41039  Unable to load Chinese or 

Arabic named data from 

Recent button  

1. Launch ERDAS IMAGINE 2018, 64-bit (bld:491)  

2. Load the data using Chinese characters in the filename  

3. Clear the viewer and try to reload the data from Recent button on the File chooser, 

from quick access tool bar.  

4. Observe that a warning thrown saying Data could not be found or invalid.  

IM-48233  New ribbonized Inquire 

Cursor is not recognized 

by applications such as 

Region Growing 

Properties tool  

The “At Inquire” button in the Region Growing Properties tool only works with the 

legacy Inquire Cursor. If the new ribbonized Inquire Cursor is active in a 2D View and 

the user clicks the “At Inquire” button in the Region Growing Properties tool a 

warning message is displayed that states “No Inquire Cursor in Window”.  

Steps to reproduce the problem:  

# Display the attached image in a 2D View  

# Activate the Inquire Cursor (Home tab > Information group > Inquire)  

# Open the Region Growing Properties tool (Drawing tab > Insert Geometry group > 

Grow menu > Growing Properties)  



ERDAS IMAGINE 2020 Update 1 

 
 
 

2019年 10月 30日 55 

# Click the “At Inquire” button in the Region Growing Properties tool.  

# A message pops up warning “No Inquire Cursor in Window”.  

IM-46524  Elevation values messed 

up when Basemap 

removed from 2DView  

Steps to reproduce:  

# Display lanier.img in a 2DView.  

# Left-click in the Elevation Part of the status bar and select Use Elevation Library.  

# Move the cursor around in the 2DView and notice that the elevation is around 350 

meters.  

# Open the OpenStreetMap basemap in the 2DView containing lanier.img.  

# Move the cursor around in the 2DView and notice that the elevation is still around 

350 meters.  

# Right-click on Basemap in the TOC and Remove Layer.  

# Move the cursor around in the 2Dview and notice that the elevation is now WAY 

below sea level (negative).  

IM-46446  Elevation units are wrong 

in measure tool if target 

units are changed  

Steps to reproduce  

# Display and image in the 2DView.  

# Set the view's elevation source to "Use Elevation Library" and set the units to 

"feet".  

# Move your cursor around over the image and verify that the status bar is showing 

you the elevation in feet.  

# Start the measure tool.  

# Measure a Point.  

# See that the elevation is shown in the Point Measurement Description, but, 

although the value is in feet, the units say "meters."  

IM-46523  Elevation part of status bar 

does not remember or use 

the proper vertical units for 

saved elevation sources  

Steps to reproduce:  

# Open lanier.img in a 2DView.  

# Click in the Elevation Part of the status bar and select Use Elevation Library.  

# Click in the Elevation Part of the status bar and select "Show in Feet".  

# Move the cursor around in the 2DView and notice that the elevation is around 1200 

feet.  

# Open lndem.img in Image Metadata and verify that it has Elevation Info and the 

Elevation Units are "feet".  

# Click in the Elevation Part of the status bar and select Choose Elevation Source  

# Select lndem.img as the Source File.  

# Change the Input vertical units to “feet”.  

# Click OK.  

# Move the cursor around in the 2DView and notice that the elevation still shows 

around 1200 feet.  

# Click in the Elevation Part of the status bar and select Use Elevation Library again.  

# Move the cursor around in the 2Dview and notice that the elevation now shows 

around 350 feet.  

You can get the same problem switching between any two previously-used elevation 

sources with different vertical units.  

IM-46522  Elevation Source Selector 

for 2D View should 

initialize input vertical units 

from Elevation Info  

Steps to reproduce:  

# Open lndem.img in imageinfo and verify that it has Elevation Info and the Elevation 

Units are "feet".  

# Open lanier.img in a 2D View.  

# Click in the Elevation Part of the status bar and select Choose Elevation Source  

# Select lndem.img as the Source File.  

# Notice that the Input vertical units remains "meters". It should be “feet”.  
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IM-34455  Save as NITF is not 

responding (nothing 

happens) to an image that 

has been opened as 

Image chain  

1. Open any image as Image Chain.  

2. File > Save as > All layers as NITF, give proper location to save the output.  

3. Click yes for the dialog “save all the layers”  

Observe that nothing happens.  

IM-44349  Cloud Cover segment not 

displaying correctly as 

Image Chain (looks fine as 

Raster)  

Using a NITF with multiple image segments, including a cloud cover (CC) segment:  

# Start a 2D View, click the File Open icon (i.e. as Raster) and select the above NITF 

file.  

# In the Sub-Image tab turn on both the MONO and NODISPLY checkboxes.  

# Raster Options tab select Fit to Frame and click OK  

# The cloud layer has correctly displayed as solid 255s (cloud) and transparent 0s 

(no cloud)  

# Clear the View  

# File / Open / Raster as Image Chain and select the same NITF file.  

# Sub-Image tab turn on both the MONO and NODISPLY checkboxes.  

# Raster Options tab select Fit to Frame and click OK  

# This time the cloud layer has incorrectly displayed as solid grey across the entire 

extent.  

IM-37916  ImageChain 1:1 display 

with Lagrange resampling 

is slower in ERDAS 

IMAGINE 2018 when 

compared to ERDAS 

IMAGINE 2016 Update 1.  

This is observed in the following 3 scenarios..  

* if the multispectral image is opened in map space.  

* if both the pan and multispectral images are opened in image space.  

* if both the pan and multispectral images are opened in map space.  

Steps to reproduce, by taking the above 2nd scenario as example  

- Make sure that both the Pan and Multispectral images are copied into the same 

folder.  

- Select File --> Open --> Raster as Image Chain  

- In the file chooser that launches, select both the Pan and Multispectral images.  

- Go to the Raster Options tab and make sure that the Fit to Frame option is ON.  

- Click OK in the file chooser.  

- Once the images are displayed, go to Multispectral and Panchromatic tabs and 

change the resampling method for both the images as Lagrange.  

- From the Home tab click on the Reset option.  

Note the time it takes for the Reset. This time is slower in the above 3 cases when 

compared to ERDAS IMAGINE 2016 Update 1.  

IM-37917  ImageChain w/Lagrange 

resampling, jump to one 

end of an image using 

Inquire Cursor is slower in 

ERDAS IMAGINE 2018  

- Select File --> Open --> Raster as Image Chain  

- In the file chooser that launches, select the Multispectral image.  

- Go to the Raster Options tab and make sure that the Fit to Frame option is ON.  

- Click OK in the file chooser.  

- Once the images are displayed, go to Multispectral tab change the resampling 

method as Lagrange.  

- From the Home tab click on the Reset option.  

- Launch the Inquire Cursor and feed in the coordinates of bottom right side corner 

and hit enter.  

Note the time it takes for the Inquire Cursor to move and display the image. This time 

is slower compared to ERDAS IMAGINE 2016 Update 1  

IM-29894  ERDAS IMAGINE is 

ignoring the overviews for 

grayscale (and RGB) TIFF 

image with JPEG 

compression  

Overviews are not considered by Image Chain for grayscale image with JPEG 

compression.  

Due to this it is taking a long time to load the image even though the image has a full 

set of overviews.  

For the same image if we use another compressions like LZW then overviews are 

considered and displays the image in seconds.  
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Also, RGB (also w/ JPEG compression) version of same image displays very quickly, 

indicating the overviews are being seen and used. Pyramid info for gray scale image 

is showing as no pyramid layers present in ERDAS IMAGINE 2016 software.  

IM-47229  Problem of opening as 

image chain for image 

calibrated with DEM with 

NoData  

An image was geometrically calibrated using a DEM that was of smaller extent than 

the image (or which otherwise contained NoData locations)  

When opening as Image Chain in the Viewer, the Low Right quadrant is not correct. 

It should be no data area (background color), but showing partial raster.  

IM-46335  Selecting vector symbol 

from "Other" group throws 

errors and sometimes 

crashes  

To recreate:  

# Display a polygon shapefile  

# Vector tab > Style > Styles group > Properties button (to open Fill Style Chooser)  

# Custom Tab > Use Pattern checked on > open Symbol menu > Other > Pick any 

Menu, any Symbol. Errors are thrown.  

# Repeat steps above, then no errors!  

Behavior is inconsistent. Sometime crashes occur. Sometimes errors don’t occur.  

02/10/18 12:26:26 viewer vector “shapefile.shp”;  

02/10/18 12:28:26 SessionMgr(17748): ERROR: #1 from 

eant_CoordSysConversionConvertAndTransformYScale  

02/10/18 12:28:26 SessionMgr(17748): ERROR: Error returned from 

eant_CoordSysConversionScaleAndTransformY  

02/10/18 12:28:26 SessionMgr(17748): ERROR: #2 from 

eant_CoordSysConversionScaleAndTransformY  

02/10/18 12:28:26 SessionMgr(17748): ERROR: Error returned from 

eant_CoordSysConversionScaleY  

02/10/18 12:28:26 SessionMgr(17748): ERROR: #3 from 

eant_CoordSysConversionScaleY  

IM-47264  "Choose Sensor" doesn't 

use its .SAF settings 

correctly still  

Open a three-band RGB image into a 2D View as raster.  

Go to the Multispectral tab.  

In the Bands group note that it has defaulted to Choose Sensor and a RGB order of 

Layer_1, Layer_2, Layer_3 (it should based on default Preferences).  

Now, not a lot of people realize, but "Choose Sensor" is just a standard .SAF file, 

with wavelengths set in it. So you should be able to pull down the Common Band 

Combinations list.  

"False Color Infrared" shouldn't show up on the list - it shouldn't be present based on 

the wavelengths defined in 3BandDefault.saf.  

IM-46915  "Choose Sensor" doesn't 

use its .SAF settings 

correctly  

Open a three-band RGB image into a 2D View as raster.  

Go to the Multispectral tab.  

In the Bands group note that it has defaulted to Choose Sensor and a RGB order of 

Layer_1, Layer_2, Layer_3 (it should be based on default Preferences).  

Now, Choose Sensor is just a standard .SAF file, with wavelengths set in it. So you 

should be able to open the Common Band Combinations list and select True Color.  

But when you do, the RGB display order changes to Layer_1, Layer_1, Layer_1, 

which is incorrect.  

False Color Infrared should not be present based on the wavelengths defined in 

3BandDefault.saf.  

Choose Sensor option has similar problems for other numbers of bands too.  

IM-46880  Clearing View with 

Subset’s Inquire Box up 

crashes ERDAS IMAGINE  

Display an image in a 2D View (e.g. lanier.img)  

On the Multispectral tab start Subset and Chip  

With the Subset and Chip dialog (and its associated Inquire Box) still active, click the 

Clear View icon on the Quick Access Toolbar.  

ERDAS IMAGINE crashes  

Doesn’t happen in ERDAS IMAGINE 2016 v16.1  
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IM-41174  ERDAS IMAGINE crashes 

with Measurement tool 

operation  

1.Launch ERDAS IMAGINE 2018  

2.Load a WorldView-2 GeoTIFF image.  

3.Now Click Measure button from Home tab > Information group  

4.Select Shadow height from Layover from Measurement tab > Measure  

5.Observe Cursor changes to cross  

6.Keep the cursor as cross and clear the viewer from quick access tool bar  

7.Now with cross Cursor click on the viewer and observe ERDAS IMAGINE crashes  

IM-48070  Viewer Banner (Title Bar) 

is Erased  

When a 2D View is resized smaller and then expanded to original size, parts or all of 

the View Title Bar Text is erased.  

IM-47497  Problem with HxIP 

basemap not reprojecting  

Failure Scenario  

1. Display orthorectified IMG image (projected to UTM)  

2. Fit Layer to Window (note that View projection is UTM)  

3. Click the Basemap button and select HxIP  

4. Provide login credentials, Test and (if successful) click Add and then OK  

5. Note that the background of the first image displays as red x’s  

Success Scenario  

1. Click the Basemap button and select HxIP  

2. Provide login credentials, Test and (if successful) click Add and then OK  

3. Note that the basemap displays fine. View projection is Lat/Lon  

4. Display orthorectified IMG image (projected to UTM)  

5. In the Contents pan, right click on the IMG image and select Fit Layer to Window  

6. Note that both images display fine  

There’s an issue with the projection the data is being requested in.  

IM-48186  Variables option cannot be 

changed in Batch 

Command Editor for Map 

Model to World File 

process  

When trying to use the Map Model to World File image metadata command in a 

batch process, the Variables menu in the Batch Command Editor is greyed out and 

stuck at “Original commands”. You cannot choose the option “One input, one or 

more outputs”. The command was only half auto-variablized, i.e., a variable is 

created for the input file, but a variable is not created for the output world file.  

The original command in ERDAS IMAGINE 2016 is: *imagecommand 

c:/input/input1.tif -exportworld c:/output/input1.tfw -meter imagecommand*  

The “original” command in ERDAS IMAGINE 2018 is: *imagecommand ‘$(Input)’ 

-exportworld c:/output/input1.tfw -meter imagecommand*  

You can work around this by creating an output variable and inserting it into the 

command but it is not straightforward to the user.  

IM-45559  Multi-point Geometric 

correction dialog crashes 

while trying to mark a GCP  

1) Launch ERDAS IMAGINE and open a WorldView-2 GeoTIFF image into a 2D 

View  

2) Go to Multispectral tab -> Control Points  

3) Select Worldview RPC under the Set Geometric model dialog and Hit OK  

4) Close the dialogs that come up [by clicking Cancel repeatedly] and now click on 

the Create GCP icon on Multipoint Geometric correction window and click on the 

main viewer to collect the point, note that it throws an error message, Click OK on it  

Observe that the warptool.exe crashes after clicking OK on the error message  

IM-44393  64-bit exporttif outputting 

"E" for "Software" TIFF tag  

# Make sure exporttif is configured to run 64-bit.  

# Manage Data tab | Conversion group | Export Data.  

# Set the Format to "TIFF" (not "TIFF Direct Write").  

# Select any input image.  

# Enter an output filename.  

# Click OK.  

# Take all defaults and click OK on the Export TIFF Data dialog.  

# Open the resultant TIFF in Image Info.  
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# Click on the TIFF Info tab.  

# Expand the Image folder and click on the TIFF Tags folder.  

# The value of the Software tag is "E".  

# If you do this workflow again with exporttif configured to run 32-bit, the value of the 

Software tag is "ERDAS IMAGINE".  

IM-19706  Area Fill tool corrupts TIFF 

images  

After using the Area Fill tool on a TIFF image and saving the image, it becomes 

corrupted and does not appear correct when you clear it from the 2D View and 

display it again. This problem does not occur in ERDAS IMAGINE 2014 v14.1  

How to reproduce:  

1. Open the TIFF image in a 2D View with the No Stretch raster option enabled.  

2. Draw an AOI polygon in any area of the image. Make sure that the AOI is 

selected.  

3. Select TIFF image in the Contents panel.  

4. Open the Area Fill tool by clicking on the Fill button in found in the Edit group 

under the Multispectral tab.  

5. In the Area Fill tool, make sure that the Function option is set to Constant and 

leave the Fill With values is set to 0.0.  

6. Click the Apply button to convert the pixel values within the AOI polygon to the 

new pixel value. An Attention message opens "This layer is using a data stretch 

lookup table. When editing pixel values you may want to remove the data stretch 

lookup table. Do you want to do this now? Click Yes.  

7. Another warning message displays “Since this function modifies the pixel values 

of the image, you may wish to recalculate the statistics and histogram for the layer 

before doing any other operation that depends on this data.” Click OK.  

8. Close the Area Fill tool.  

9. Save your image.  

10. Remove your image from the 2D View and redisplay it. Notice that the image has 

changed, but not like it should have.  

11. This problem does not happen when using an IMG format image instead of a 

TIFF image.  

IM-10616  ERDAS IMAGINE JFIF 

(JPEG) cannot read 

Progressive JPEG profile  

Customer reported that they cannot import JPG with JGW file into IMG or TIFF 

formats. They are also not able to open the JPG file in ERDAS IMAGINE. However 

they can open/ import the JPG file in ER Mapper 2013  

The importer gives error message while importing : “Unsupported SOF Marker type 

0xc2  

While opening the file in the 2D View ERDAS IMAGINE gives : “File open error 

(0-Unknown error”  

IM-44698  Artifacts in Sentinel-2 

images when directly 

viewing the *.safe file in 2D 

View as well as after 

importing  

Customer reported that they can find artefacts in Sentinel-2 images when directly 

viewing the *.safe file in a 2D View as well as after importing the *.safe file into *.img 

by means of the Sentinel-2 Direct Read and Sentinel-2 manifest importers. The 

artifacts seems to be due to the granule tile borders.  

Seems to affect only imagery from before December 2016 when the data structure of 

Sentinel-2 was re-organized.  

Steps to Reproduce:  

1. Open the Sentinel2 *.safe file in IMAGINE Viewer. Zoom to a granule edge. You 

see the broken straight lines artifacts in between granule tiles.  

2. Import the Sentinel 2 *.safe file by means of the Sentinel 2 Direct Read and 

Sentinel-2 manifest importer. Then open the imported output file in IMAGINE Viewer. 

Zoom to a granule edge. You see the broken straight lines artifacts in between 

granule tiles.  
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IM-39173  Opening a hyperspectral 

image in ImageInfo takes 

long time  

To reproduce the problem open a hyperspectral image in a 2D Viewer.  

Go to IMAGINE Home tab and click Metadata button. Notice that it takes quite long 

time before the image info is shown on ImageInfo dialog box.  

On one test machine, it takes more than 10 seconds to open an AVIRIS scene in 

ImageInfo, It has 224 bands and whose width and height are 530 pixels and 301 

pixels.  

IM-12677  Request to add missing 

ground control point gcc 

files in ERDAS IMAGINE 

example data  

Request to add missing ground control point gcc files in the ERDAS IMAGINE 

example data in the download page.  

In the ERDAS IMAGINE 2014 Online Help documentation, in the "Refine the DEM 

Extraction Workflow exercise", it has been mentioned about using two Ground 

Control Points files (gcc files) : "uluru_reference-gcp.gcc" and the 

"uluru_input-gcp.gcc" file. However the customer couldn’t find those two gcc files in 

the ERDAS IMAGINE example data.  

These are now downloadable as part of the ERDAS IMAGINE Radar Example Data 

download.  

IM-43563  Tiff files with Thai 

characters in their names 

fail  

An ERDAS APOLLO customer is seeing failures due to ERDAS IMAGINE not being 

able to handle tiff files with Thai characters in them, for example:  

เชยีงราย.tif  

The issue is not restricted to TIFF. If you rename an IMG file, create pyramids (rrds) 

and then attempt to open the IMG file, you get errors referring to the pyramids not 

being found.  

IM-44567  64-bit ImageInfo displaying 

TIFF GTCitationGeoKey 

incorrectly  

# Open a TIFF file in *64-bit* ImageInfo.  

# Click on the TIFF Info tab.  

# Expand the Image folder and the GeoTIFFKeys folder.  

# The GTCitationGeoKey is displayed in what looks like Chinese characters, 

although the values of the other tags look fine.  

IM-46884  Pleiades DIMAP v2 image 

stats reversed for red and 

blue bands  

If you calculate statistics (for example in Image Info) for a Pleiades DIMAP v2 image 

the resulting stats are correct. Whereas if you look at the "raw" DIM*.XML file (with 

all .aux files, etc., deleted first) ERDAS IMAGINE is trying to use the statistics it finds 

in the .XML header, but is associating the stats in the wrong order.  

IM-44990  Socet GRID file opens in 

32 bit but not 64 bit  

Open a specifc type of Socet GRID *.dth file in a 32-bit 2D View. Image appears.  

Open the same file in 64 bit view. Get error: "Header identifier did not match"  

IM-37447  Additional empty "Image" 

segments shouldn't be 

saved to IMG header  

Open a multi-segment NITF image in a 2D View (using default settings so only one 

image segment is opened).  

File / Save As / Top Layer As.. to an IMG format output.  

Open the resulting IMG file in ImageInfo and click on the NITF tab.  

Note that despite the fact that there is only a single image segment physically 

present in the IMG, all the original Image segments have been copied across even 

though they do not have the associated data to go with them.  

Not only is not removing them confusing, it also causes ERDAS IMAGINE problems 

- e.g. if you try to Save All Layers as NITF, the NITF Exporter crashes.  

IM-46218  TIFF pyramids not 

recognized (APM fails 

with .tiff)  

APM fails with customers .tiff images. All is correct with customer's block setup. 

Image Info does not recognize pyramid layer algorithm. Images do not display 

correctly if you "fit to frame" in IMAGINE Viewer. And in IMAGINE Photogrammetry, 

image is displayed only on a small section of image footprint.  

Re-generating pyramids in IMAGINE Photogrammetry does not solve the problem. 

Only workaround is to convert the imagery to another format. So, I imported these 

files to .img format and re-attached them to the block file and then tested APM. APM 

run successfully collected 90+ points using default pattern.  
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IM-47024  JPEG2000 exporter in 

ERDAS IMAGINE gives 

error message with ArcGIS 

created *.img file  

Customer reported that JPEG2000 exporter (Manage Data > Export Data > JPEG 

2000) in ERDAS IMAGINE gives error message with ArcGIS created *.img file. The 

JPEG 2000 export process runs all the way through, and nearly at the end ERDAS 

IMAGINE gives an error, saying: "Layer_1INode already exist for file *.aux".  

The customer‘s *.img file was created by ArcGIS HillShade Tool from a DEM file 

created by ERDAS IMAGINE’s MosaicPro .  

Even if the ERDAS IMAGINE JPEG 2000 exporter gives the following error 

message, it creates a valid output JPEG 2000 file.  

“The file *.jp2 cannot be deleted  

because it is in use by another application.  

Close the file and then press 'Retry' to continue,  

or press 'Cancel'.  

IM-46584  Help - ML Review Tab 

Hyper link navigating to 

Review Tab of Zonal 

change  

1.Launch ERDAS IMAGINE 2018 Update 2  

2.Launch Machine Learning Layout from File > Layout  

3.Select ML Process tab and click F1  

4.Observe ML Review Tab Hyper link navigating to Review Tab of Zonal change 

layout.  

IM-35331  Errors when trying to 

display features from 

Oracle Features Proxy 

(.ofp) and Spatial Feature 

(.ogv)  

Customer reported that ERDAS IMAGINE gives errors when they tried to display 

features from both Oracle Spatial Feature (.ogv) and Oracle Features Proxy (.ofp),  

The customer has been able to create a connection using both Oracle Spatial 

Feature (.ogv) and Oracle Features Proxy (.ofp), When trying to load .ogv, he gets 

the error:  

"Invalid input ProProjection structure", then "Invalid input units name".  

The feature shows up in the legend, but is not visible in the display (but the bounding 

box can be seen if turned on).  

When trying the .ofp, he gets the error: "Could not open layer. Invalid connection 

parameters". He gets nothing in the legend or display window.  

IM-35332  ERDAS IMAGINE is 

unable to display features 

from Oracle Spatial 

Feature (.ogv) and Oracle 

Features Proxy  

Customer reported that ERDAS IMAGINE is unable to display features from both 

Oracle Spatial Feature (.ogv) and Oracle Features Proxy (.ofp), when connected to 

the database using credentials of a user who is non-owner of the database.  

If the customer uses the credentials of the owner or the credentials of the System 

DBA, he can display the feature in ERDAS IMAGINE. However, customer is not 

seeing any problem with the same data in GeoMedia. It’s only in ERDAS IMAGINE, 

which is not displaying the vector.  

Recreated the problem in ERDAS IMAGINE and in another popular GIS software.  

IM-42876  Unable to open point 

features from an Oracle 

database  

Using specific Oracle database connection, try to display any points features 

available in it. Notice that there are couple of error messages and the display fails.  

IM-48922  Proxy gdb file access, 

without connecting to 

geodatabase throws error, 

which is not clear  

ERDAS IMAGINE 2018 Update 2 could not use an existing .gdb Geodataabse proxy 

file to access the Geodatabase  

IM-48919  Trying to display a Point 

Feature class in gdb 

(having single point) fails 

in ERDAS IMAGINE  

ERDAS IMAGINE 2018 Update - Trying to display a Point Feature class in gdb 

(having single point) fails in ERDAS IMAGINE 2018 Update 2. Whereas Point 

Feature Class with >1 point displays fine.  

IM-48918  Supported version of 

Geodatabase logged in 

session log needs to be 

updated  

In ERDAS IMAGINE > File > Open > Vector layer > ArcGIS Geodatabase (*.gdb) > 

Click Connect.  

Session log reports:  

17/05/19 15:24:52 SessionMgr(5324): Detected geodb version 10.7  

17/05/19 15:24:52 SessionMgr(5324): Unsupported version of GeoDatabase 
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support located. Please note that IMAGINE is only supported for version up to 10.2.  

IM-47243  Fail to launch Texel 

Mapper  

1. Launch ERDAS IMAGINE 2018 (64-bit)  

2. Launch Texel Mapper from Toolbox tab > Common group > Stereo Analyst drop 

down.  

3. It fails.  

IM-45530  Unable to load ers file 

associated with TIFF file in 

ERDAS IMAGINE 2018  

1.Launch ERDAS IMAGINE 2018 (64-bit)  

2.Try to load a specific .ers file and observe Message thrown saying image has no 

layers.  

3.Sessionlog saying ERS Raster error:Filetype unkown.  

IM-44887  Output created using 

LaGrange resampling 

differs from the output 

generated using other 

resampling methods  

Giving the image and the DEM provided as input to "Orthorectify without GCP" 

option, generate 2 outputs one with LaGrange resampling method and the other with 

any other resampling method from the rest available. Open the 2 outputs in 2 

different viewers and notice that in one portion of the image the outputs differ.  

IM-39311  Generating pyramids takes 

an unexpectedly long time 

because of the binary "use 

multithreading" 

hyperspectral preference  

Pyramid layers are taking an unexpectedly long time to be generated for 

hyperspectral images.  

IM-41083  unit test failure when 

locale is set to German 

(bug in etxt::tostring)  

The locale on my development machine is set to German (Control Panel | Region | 

Formats tab | Format = "German (Germany)"). When running the eCommon 

etxtUnitTest::test_ToString_Double unit test, it fails, because the string has a comma 

as the decimal separator. The problem is that the fallback condition at the bottom of 

etxt::tostring is just calling etxt_Text_sprintf, which is ignoring the useCLocale 

parameter passed to etxt::tostring ().  

IM-48813  DEM Tools Revalue 

function does not allow 

DEM recode values to be 

specified  

DEM Tools Revalue application does not add recode values from Range(s) window 

to the Range list. The program does not run unless recode values are added to the 

Range list.  

Does not work with any data type (i.e 1, 2, 4, 8, 16 and 32 bit signed/unsigned 

integers, 32 and 64 bit float).  

Worked correctly in ERDAS IMAGINE 2016  

To recreate:  

Open Terrain tab > DEM Tools > Revalue  

Input DEM: lndem.img  

Add 1300 to Range(s) window  

New Value: 0+  

Select Add Range to List.  

There is no response to this request  

IM-43195  64-bit VersionTool 

reporting garbage for 

Date/Time Stamp  

Session | DLL Information  

Class: Raster Formats  

DLL Instance Information tab  

Instance: ADRG (and others)  

Description shows Date/Time Stamp: 㜲䨠湡㈠㄰ ‸㌱㈺㨰〱  

IM-46366  Coordinate system option 

in Measurements panel 

automatically flips if zoom 

is performed in the viewer  

 

・ • Launch the Preference Editor and change the preference for the 

following option to Lat/Lon (WGS 84).  

・ • Viewing category > Viewer > Show Coordinates As  

・ • Open an image in the viewer and select the Measure option from the 
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Information group of Home tab.  

・ • In the Measurement tab under the Setup group notice that the 

Coordinate Type is Lat/Lon.  

・ • Measure a few points and notice that the measurements are displayed 

as Lat/Long.  

・ • Perform some zoom in the viewer.  

・ • Notice that the coordinate type in the measurements panel flips to Map.  

 

IM-40172  Image Command does not 

print statistics when using 

‘Compute Statistics’ and 

‘Print To File’ together  

Using the ‘Compute Statistics’ and ‘Print To File’ options together does not print 

image statistics to file when the .aux does not exist prior to running Image 

Command.  

If you run Image Command only using ‘Compute Statistics’ first and then run Image 

Command using ‘Print To File’, the image statistics are printed to file.  

To recreate:  

# Be sure doubl_float.aux does not exist  

# Run Image Command, open doubl_float.tif  

# Check ‘Compute Statistics’ and ‘Print To File’, specify .txt  

# OK  

Open the .txt with WordPad. Image statistics are not present.  

IM-46755  SARVI index fails with 

"Empty data on port" error  

On the Raster tab, open the Indices dialog  

Specify Input as lanier.img  

Set Category to All  

Select Index: SARVI  

Click Preview (or OK after providing an output filename)  

Error:  

Spatial Model failed in Multiply. The error was "Empty data on port".  

IM-44665  If you try to save the 

session, ERDAS IMAGINE 

crashes  

Go to File > Save > General Save Options > Session  

ERDAS IMAGINE crashes  

IM-49543  Choosing this .TIL file in 

the file chooser caused 

IMAGINE crash  

Clicking on a specific DigitalGlobe .TIL file in the file chooser causes ERDAS 

IMAGINE to crash.  

IM-49605  Generate System Report 

showing wrong operating 

system information  

1.Launch ERDAS IMAGINE  

2.Generate System report from File > Session  

3.Click OK (make sure all check boxes checked on)  

4.Provide the path for report  

5.Open the report generated and observe operating system information shown as  

Microsoft Windows 8 64-bit (Build 9200) for Windows 10 machine  

IM-47470  Opening individual 

Algorithm file crashes 

ERDAS IMAGINE  

1.Launch ERDAS IMAGINE  

2.Copy Algorithm file RGB.alg to local folder  

C:¥Program Files¥Hexagon¥ERDAS IMAGINE 

2018¥examples¥ermapper¥data_types¥airphoto  

3.Try to open the RGB.alg from File > Open > Algorithm  

4.Observe ERDAS IMAGINE crashes.  

IM-48520  Chart to Chart change 

detection throwing fault 

message in session log 

"Client Failed to connect to 

server"  

1.Launch ERDAS IMAGINE  

2.Launch Chart to Chart change detection from Raster > Change Detection > 

Change Detection Tools > Chart to chart  

3.Provide the inputs as chart1-geo.tif, chart2-geo.tif  

4.Provide the output name and click run  

5.Observe Process run and output got generated but session log showing -Client 

Failed to connect to server  



ERDAS IMAGINE 2020 Update 1 

 
 
 

2019年 10月 30日 64 

+Session log:+  

17/04/19 14:47:17 SessionMgr(9640): Connection success for the external process 

'eWkspace_64'  

17/04/19 14:47:31 C:/Program Files/Hexagon/ERDAS IMAGINE 

2019/bin/x64URelease/smguiprocess.exe 

$IMAGINE_HOME¥etc¥ZonalChange¥ChartToChartChangeDetection.gmdx  

17/04/19 15:01:30 C:/Program Files/Hexagon/ERDAS IMAGINE 

2019/bin/x64URelease/smprocess.exe 

$IMAGINE_HOME¥etc¥ZonalChange¥ChartToChartChangeDetection.gmdx Chart 

To Chart Change Detection.Chart 1=d:¥2019¥data_delete¥chart¥chart1-geo.tif 

Chart To Chart Ch  

ange Detection.Chart 2=d:¥2019¥data_delete¥chart¥chart2-geo.tif Chart To Chart 

Change Detection.Change Image=d:¥2019¥16-04-2019¥charttochartchange.img 

Chart To Chart Change Detection.Threshold=0.5  

17/04/19 15:01:30 SessionMgr(9640): smguiprocess.exe exited with status 1.  

17/04/19 15:01:31 SessionMgr(9640): Running spatial model 

($IMAGINE_HOME¥etc¥ZonalChange¥ChartToChartChangeDetection.gmdx) with 

port values (Chart To Chart Change Detection.Chart 

1=d:¥2019¥data_delete¥chart¥chart1-geo.tif,Chart To Chart Change Detection  

.Chart 2=d:¥2019¥data_delete¥chart¥chart2-geo.tif,Chart To Chart Change 

Detection.Change Image=d:¥2019¥16-04-2019¥charttochartchange.img,Chart To 

Chart Change Detection.Threshold=0.5).  

17/04/19 15:01:31  

17/04/19 15:01:34 SessionMgr(9640): Running command line: C:/Program 

Files/Hexagon/ERDAS IMAGINE 

2019/bin/x64URelease/imagesegmentation_fls.exe -maxpixels "2000000" 

"C:¥Users¥agangumo¥AppData¥Local¥Temp¥SM-da28-05b1-b5f9-1e10-010952¥d

963f69d-9911-4a3e-9  

aef-069d13813d12" 

"C:¥Users¥agangumo¥AppData¥Local¥Temp¥SM-da28-05b1-b5f9-1e10-010952¥1

bd12244-1cdf-493f-ae92-3d74f2a907b7" -scale "100" -scalemin "10" -scalemax 

"2000" -spectral "1" -texture "0" -shape "0.29999999999999999" -size 

"0.30000000000000004"  

-min "10" -max "100000" -randomcolor "1" -meter  

17/04/19 15:01:34 SessionMgr(9640): Connection success for the external process 

'FLS Segmentation'  

17/04/19 15:01:35 SessionMgr(9640): Client Failed to connect to server :No 

connection could be made because the target machine actively refused it  

17/04/19 15:01:36 SessionMgr(9640): Client Failed to connect to server :No 

connection could be made because the target machine actively refused it  

17/04/19 15:01:37 SessionMgr(9640): Client Failed to connect to server :No 

connection could be made because the target machine actively refused it  

17/04/19 15:01:38 FLS Segmentation(6664): Performing FLS Segmentation  

17/04/19 15:01:38 FLS Segmentation(6664): Input File: 

C:/Users/agangumo/AppData/Local/Temp/SM-da28-05b1-b5f9-1e10-010952/d963f

69d-9911-4a3e-9aef-069d13813d12  

17/04/19 15:01:38 FLS Segmentation(6664): Pixel:Segment Ratio: 100  

17/04/19 15:01:38 FLS Segmentation(6664): Spectral Weight: 1.00  

17/04/19 15:01:38 FLS Segmentation(6664): Texture Weight: 0.00  

17/04/19 15:01:38 FLS Segmentation(6664): Size Weight: 0.30  

17/04/19 15:01:38 FLS Segmentation(6664): Shape Weight: 0.30  

17/04/19 15:01:39 FLS Segmentation(6664): Segmenting Tile 1  
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17/04/19 15:01:48 FLS Segmentation(6664): Segmenting Tile 2  

17/04/19 15:01:50 SessionMgr(9640): external process exited normally.  

17/04/19 15:01:52 SessionMgr(9640): Spatial model ran successfully.  

17/04/19 15:01:52  

17/04/19 15:01:53 SessionMgr(9640): smprocess.exe exited normally.  

IM-46613  Opening map composition 

file having '(' in the file path 

of referenced images, 

crashes ERDAS IMAGINE 

2018  

Launch ERDAS IMAGINE 2018.  

Open map composition file "withparentheses.map"  

Observe user is prompted to substitute raster file path. specifying to use the Original 

file through substitute crashes ERDAS IMAGINE.  

Whereas in ERDAS IMAGINE 2016 Update1, throws error.  

6/10/18 14:57:39 SessionMgr(7020): ERROR: #453 from 

efnp_FileNodeListGetNonNodePart  

26/10/18 14:57:39 SessionMgr(7020): ERROR: efnp_FileNodeListGetNonNodePart 

fail  

26/10/18 14:57:39 SessionMgr(7020): ERROR: #774 from efnp_FileNodeListGet  

26/10/18 14:57:39 SessionMgr(7020): ERROR: FileNodeListParse failed  

26/10/18 14:57:39 SessionMgr(7020): ERROR: #1457 from FileNodeListParse  

26/10/18 14:57:39 SessionMgr(7020): ERROR: Parse error; 

<FileNodeListItemSpec> at position 62 is preceded by a <DirectoryName>  

26/10/18 14:57:39 SessionMgr(7020): ERROR: #1148 from 

edis_TrueColorCreateLayerByName  

26/10/18 14:57:39 SessionMgr(7020): ERROR: 

erdas::raster::GridCoverageIdentifierEFNP::FromFileNode failed  

26/10/18 14:57:39 SessionMgr(7020): ERROR: #507 from 

erdas::raster::GridCoverageIdentifierEFNP::FromFileNode  

26/10/18 14:57:39 SessionMgr(7020): ERROR: efnp_FileNodeListGetNonNodePart 

failed  

26/10/18 14:57:39 SessionMgr(7020): ERROR: #453 from 

efnp_FileNodeListGetNonNodePart  

26/10/18 14:57:39 SessionMgr(7020): ERROR: efnp_FileNodeListGetNonNodePart 

fail  

26/10/18 14:57:39 SessionMgr(7020): ERROR: #774 from efnp_FileNodeListGet  

26/10/18 14:57:39 SessionMgr(7020): ERROR: FileNodeListParse failed  

26/10/18 14:57:39 SessionMgr(7020): ERROR: #1457 from FileNodeListParse  

26/10/18 14:57:39 SessionMgr(7020): ERROR: Parse error; 

<FileNodeListItemSpec> at position 62 is preceded by a <DirectoryName>  

26/10/18 14:57:39 SessionMgr(7020): ERROR: #595 from 

erdas::mapComposerApp::MapComposerControl::Open  

26/10/18 14:57:39 SessionMgr(7020): ERROR: 

erdas::mapComposerApp::MapComposerControl::Open failed  

26/10/18 14:57:39 SessionMgr(7020): ERROR: #549 from 

erdas::mapComposerApp::MapComposerControl::Open  

26/10/18 14:57:39 SessionMgr(7020): ERROR: edis_MapComposerBuildFrames 

failed  

26/10/18 14:57:39 SessionMgr(7020): WARNING: #1 from 

edis_MapComposerBuildFrames  

26/10/18 14:57:39 SessionMgr(7020): WARNING: Error filling in frames  

26/10/18 14:57:40  

26/10/18 14:57:40 SessionMgr(7020): WARNING: #1 from 

edis_MapComposerPopulateFrame  

26/10/18 14:57:40 SessionMgr(7020): WARNING: Couldn't open truecolor layers:  

26/10/18 14:57:40 
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//ingrnet.com/in/sgi/geospatial/gs2/imaginedata/pixeldata/del/(copy)/limerick_2007_

subset.img(copy)/limerick_2007_subset.img(:Layer_1)  

26/10/18 14:57:40 

//ingrnet.com/in/sgi/geospatial/gs2/imaginedata/pixeldata/del/(copy)/limerick_2007_

subset.img(copy)/limerick_2007_subset.img(:Layer_2)  

26/10/18 14:57:40 

//ingrnet.com/in/sgi/geospatial/gs2/imaginedata/pixeldata/del/(copy)/limerick_2007_

subset.img(copy)/limerick_2007_subset.img(:Layer_3)  

IM-47986  Reprojecting MrSID image 

much slower in ERDAS 

IMAGINE 2018 vs ERDAS 

IMAGINE 2015  

It was reported that ERDAS IMAGINE 2018 takes over two hours to reproject a 17 

MB MrSID image, but the same image can be reprojected in ERDAS IMAGINE 2014 

in 20-30 seconds. The same pattern can be observed with other larger MrSID files. 

Reprojecting similar images in other formats such as IMG or TIFF only takes 20-40 

seconds in ERDAS IMAGINE 2018.  

IM-11214  Double && in Preferences  File > Preferences  

Under User Interface folder you will see the entry “User Interface && Session”  

IM-42604  After using Add/Change 

Projection in Edit Image 

Metadata, the Unit 

disappears in the 

metadata  

Reported that after editing or adding Projection in a file, using Edit Image Metadata, 

the Unit disappears in the metadata.  

To recreate the problem, use the customer’s data in Edit Image Metadata or 

ImageInfo  

1. Set the Map Model as “Transverse Mercator” and Meters.  

2. Set the projection as EPSG:25835  

Note that the unit vanished from the metadata. When you set the Map Model again, 

the unit shows again.  

IM-49222  Reprojecting ECW image 

to GDA2020 Conformal 

(NTv2) datum fails  

Reprojecting an ECW image from EPSG:23855 (GDA94 datum) to the GDA2020 

Conformal (NTv2) datum takes a very long time (~12 hours) and eventually the 

process fails. There is no EPSG code for the same projection as EPSG:23855 

instead using the GDA2020 Conformal (NTv2) datum, so it has to be set manually. 

The projection parameters are outlined below. Reprojecting to the EPSG:7855, 

which is essentially the same projection but using the GDA2020 datum instead of 

GDA2020 Conformal (NTv2), works and only takes a couple of hours.  

Steps to reproduce the problem:  

# Start the Reproject Images tool and select the image “input_image.ecw” as the 

input file.  

# Enter a name for the output file and make sure the file format is ECW.  

# Set the Processing Option to “Resample to Output File”.  

# Set the Resampling Method to “Nearest Neighbor”.  

# Choose “Rigorous Transformation”.  

# Use the Projection Chooser to set the output map projection using these 

parameters:  

## Projection Type: UTM  

## Spheroid Name: GRS1980  

## Datum Name: GDA2020 Conformal (NTv2)  

## UTM Zone: 55  

## North or South: South  

## Axis Order: E,N  

# Click OK and wait while it processes and eventually stops.  

IM-37584  Raster attributes lost after 

reprojection  

When reprojecting a thematic raster image, the output image does not retain the 

same raster attributes that were included in the input image.  

Steps to reproduce the problem:  

Start the Reproject Images tool (Raster tab > Geometry group > Reproject)  
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Select the thematic image (with attribute field called “CLC Land Cover”) as the input 

file.  

Enter a name for the output file.  

Use the default settings in the Reproject tool and click OK to begin reprojecting the 

data.  

Display the input image in one 2D View and the reprojected image in a separate 2D 

View.  

Display the raster attribute tables for both images (Table tab > View group > Show 

Attributes).  

Notice that the column titled “CLC Land Cover” with the class names is missing from 

the reprojected image.  

IM-41736  Image Chain / Sensor 

Look Angle is Disabled  

When displaying an image as an Image Chain, the "Sensor Look Angle" option in the 

lower right corner is grayed out. However the Up_is_Up in the Smart Control works.  

The “Sensor Look Angle” option is not grayed out if the image is displayed not using 

image chains.  

IM-48811  Login to Smart M.App link 

in ERDAS IMAGINE 

ribbon is no longer 

functional  

Login to Smart M.App link used in the ERDAS IMAGINE ribbon is no longer 

functional. The broken link opens a page error.  

This is due to a change in the address of the Smart M.App marketplace.  

IM-40404  Bubble help for Launch 

Command Window button 

is outdated  

Click the Help tab to search for the Session Command History window. It states that 

that the path is Application Menu > Session Options menu, but it is actually File tab > 

Session > Launch Command Window.  

The Application menu is from an older version of ERDAS IMAGINE and is no longer 

used.  

IM-49188  Ribbon tabs not being 

hidden when switching to 

Spatial Modeler through 

title bar  

# Open ERDAS IMAGINE 64-bit  

# Open a raster image in 2D View  

# Open Spatial Modeler  

# switch to the 2D View layer  

# switch to the Spatial Modeler layer by clicking on its title bar (not in the table of 

contents or inside of the layer itself)  

Note that the ribbon tabs for the raster image have not been hidden.  

IM-41512  Confusing error message 

in zonal change project 

when regions shapefile is 

locked  

Use two ERDAS IMAGINE sessions in parallel.  

ERDAS IMAGINE Session1:  

1) Open regions.shp  

2) On Drawing tab click Enable Editing  

ERDAS IMAGINE Session2:  

1) Switch to the Zonal Change Layout and create a new project  

2) Specify Before and After images  

3) Go to Process tab and click Edit Project.  

3) Click Add New Regions > One Per File. Select regions.shp  

Get an error message ”The new region is empty. It will not be created”. But it is not 

empty.  

When loading regions.shp via Add New Regions > One Per Polygon the error 

message is more appropriate:  

Spatial Model failed in Features Input. The error  

was "erdas::sb_CGP::VectorSource_X::OnExecute  

failed  

Cannot open specified Vector source".  

IM-39921  Formula does not apply to 

first row of vector attribute 

table  

Open an image.  

Open a vector layer over the top.  

On the Drawing tab select Enable Editing.  
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On the Table tab, select Show Attributes.  

In the attributes CellArray select a numeric attribut column  

Select, for example, rows 5 to 10.  

Right click on the column titles and select Formula.  

In the Formula dialog type the value 2 and click Apply.  

First problem is that you lose the row selection – it should not remove your selection.  

Second problem is that row 5 is still a 1, not a 2. The edit was not applied to the first 

selected row.  

IM-46339  Large Shapefile causes 

problems with viewing 

vector attribute table  

A Shapefile with a lot of records (~1.8 million arcs) causes a problem when scrolling 

down through the vector attribute table. When scrolling to the bottom of the table it 

bounces back up to the first record. The workaround is to right-click in the Record 

column and select Goto to open the Row Position dialog and then click the Last 

button or enter the desired row number and click Goto.  

IM-46430  Shapefile with a lot of arcs 

(~1.8 million) causes 

Features Input operator 

error  

A Shapefile with a lot of records (~1.8 million arcs) causes a problem when 

processing it through the Features Input operator. When running the spatial model, it 

fails at the Features Input operator with the message “Read fewer bytes than 

expected.”  

The customer also reports that the Convert To Raster operator fails using the same 

input Shapefile with the error message “The object reference was not set to an 

object entity". They claim that it does work sometimes, but not reliably and if it works, 

not all of the records are converted to the output raster image.  

Session log:  

SessionMgr(5768): Executing spatial model: c:/steve/convert_to_raster.gmdx  

SessionMgr(5768): Read fewer bytes than expected.  

SessionMgr(5768): Read fewer bytes than expected.  

SessionMgr(5768): ERROR: #2348 from 

HexGeo::SpatialModeler::Operator::InternalApply  

SessionMgr(5768): ERROR: HexGeo::SpatialModeler::Operator::SetErrorMessage 

failed  

SessionMgr(5768): ERROR: #1985 from 

HexGeo::SpatialModeler::Operator::SetErrorMessage  

SessionMgr(5768): ERROR: Spatial Model failed in FeaturesInputCGP. The error 

was "Read fewer bytes than expected.".  

SessionMgr(5768): ERROR: #2348 from 

HexGeo::SpatialModeler::Operator::InternalApply  

SessionMgr(5768): ERROR: HexGeo::SpatialModeler::Operator::SetErrorMessage 

failed  

SessionMgr(5768): ERROR: #1985 from 

HexGeo::SpatialModeler::Operator::SetErrorMessage  

SessionMgr(5768): ERROR: Spatial Model failed in FeaturesInputCGP. The error 

was "Read fewer bytes than expected.".  

SessionMgr(5768): Spatial model execution failed.  

IM-43624  Vector features stored in 

ArcGIS Geodatabase with 

units set to degrees 

causes “Units are not of 

same type” errors  

A long stream of error messages are displayed when opening vector feature data 

that has its projection units set to decimal degrees and is stored in an ArcGIS 

Geodatabase. It appears that ERDAS IMAGINE does not recognized the map units. 

The projection is Geographic (Lat/Lon), WGS 84, decimal degrees.  

The same data exported to a Shapefile does not cause any problems when opening 

it. Displaying the Geodatabase features in ArcGIS does not cause any issues.  

IM-46621  File Chooser does not 

show shapefiles for Copy 

Vector Layer, Rename 

This was only reproducible in 64-bit ERDAS IMAGINE  

1) Launch ERDAS IMAGINE > Vector tab > Copy Vector Layer  

2) Observe that both input and output has default *.arcinfo as formats  
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Vector Layer, and Delete 

Vector layer  

3) Now launch input file chooser by clicking open button > go to any location where 

Shapefiles are present  

4) Observe that until the file format is re-selected as Shapefile, the Shapefiles are 

not visible in the file chooser  

5) Next open the output File chooser by clicking open button of Output (note that 

default output format is Shapefile)  

6) Now give an output name and click OK, observe that the output format is *.arcinfo  

7) Unless the output format is re-selected in the file chooser, the output is not 

produced  

Case is same for Rename Vector layer and Delete Vector layer  

IM-45038  ERDAS IMAGINE crashes 

while deleting ID attribute 

from vector data  

1.Launch ERDAS IMAGINE  

2.Load a specific Shapefile and display attribute table.  

3.Select the Drawing tab and Enable editing.  

4.Select table tab and click on Column Properties  

5.ID got selected itself on Column Attributes dialog  

6.Click delete and then Ok. Observe ERDAS IMAGINE crashes.  

IM-44889  Zonal Change Process 

failing with Image 

difference algorithm  

1.Launch IMAGINE 2018 v 16.5, Launch Zonal Change Layout.  

2.Create a New Project , load input images and Zone files  

Data location:¥¥alpha¥JIRA_data¥IM-44888  

* TheVillagesSubset2007.ecw  

* TheVillagesSubset2008.ecw  

* TheVillagesParcelsSubset.shp  

3.After Loading inputs, Select Algorithm as Image Difference and Click Run Region  

4.Let Image Difference Value Parameter Threshold as default Zero and Click ok 

observe that process failing.  

>> Session log attached for reference.  

NOTE:  

* The same workflow is not giving an indication of process failing in IMAGINE 32 bit.  

* The same workflow if tried with same raster input for both Before image and After 

image (EX: TheVillagesSubset2007.ecw) to make input image difference as zero, 

again also process failing, which should be theoretically wrong for end user.  

* Not giving user friendly pop-up message that Image difference threshold should not 

be Zero  

IM-17921  Not replacing an 

not-existent Before image 

or After image caused 

IMAGINE crash  

Take any projects from here  

¥¥alpha¥teamspace¥Pixel¥Temp¥ZCim14diff  

Open the project  

It tells you files are missing and to correct the path.  

If you do not select the right img file (by clicking Cancel, for instance), IMAGINE 

would crash.  

If you select the right img file and press substitute, error is thrown that shapefile link 

is incorrect and the project does not open.  

IM-37622  Zonal Mean produces 

incorrect result (1.#QNAN) 

with float class raster (and 

NoData set to 0)  

See model copied to ¥¥alpha¥Siebel_Bug_Data¥1-KZ8EUF. It’s basically takes a 

shapefile as raster as the Zones, a floating point image as the Class Raster and 

feeds them into Zonal Mean.  

Run the model once and note that the mean is stated as 1.#QNAN  

IM-49444  With only Before or After 

Image in the Zonal 

Change Layout, closing it 

with/without saving 

crashes ERDAS IMAGINE  

1) Launch IMAGINE > File > Layout > Zonal Change Layout  

2) Process tab > New > create a new project C:¥temp¥example.zcp  

3) Add only Before or After Image in the 2D Viewer, click Close in the Process tab, 

click Yes/No  

Observe that it crashes ERDAS IMAGINE while trying to close the Zonal Change 

layout with only Before or After Image in the layout  
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Note:  

1) If both Before and After images are loaded in the Zonal Change Layout and the 

Zonal Change layout is closed no crash is observed.  

2) This is not reproducible in ERDAS IMAGINE 2016  

IM-36621  Selecting Help tab > 

ERDAS IMAGINE Release 

Guide & HexGeoWiki, 

throws ewinopen crash 

dialog  

Goto Help tab > select ERDAS IMAGINE Release Guide. Dialog opens stating, 

ewinopen has stopped working.  

Goto Help tab > select Reference Book > HexGeoWiki. Dialog opens stating, 

ewinopen has stopped working.  

IM-33825  Image recode is not 

working from Raster tab > 

Thematic > Recode  

1.Launch ERDAS IMAGINE, Load the Image landcover_cherokee.img  

2.Select Recode from Raster tab > Thematic > Recode.  

3.Recode dialog opens,click Setup Recode  

4.Change the value of water-1 ,Coniferous Forest-2,Mixed Forest-2,Deciduous 

Forest-2 and remaining all -0 and click Ok  

5.Provide the output File name and click OK and observe process failing with an 

error out of the Range LUT  

NOTE: The same work flow from Thematic tab > Recode producing output without 

any issues.  

IM-22019  BigTIFF gives error 

messages when displaying 

in ERDAS IMAGINE  

BigTIFF created by Intergraph ISIS does not display in ERDAS IMAGINE, but does 

in other GIS products. While the file extention is .btf, the TIFF DLL searches the file, 

determines it is a BigTIFF, and then gives multiple errors.  

IM-43993  Error when creating 

RSETs for large Float IMG 

file  

Make a local copy of the large (>2GB) .img and .ige files (only)  

Start Spatial Model Editor  

Start the Session Log  

Add a Generate RSETs operator  

Set the copy of the .img file as the input filename.  

Click Run  

.r1 seems to generate OK, but then you start seeing these messages in the Session 

Log:  

28/03/18 12:18:37 SessionMgr(816): Connection success for the external process 

'eWkspace_64'  

28/03/18 12:19:14 SessionMgr(816): Executing spatial model  

28/03/18 12:20:28 SessionMgr(816): ERROR: #22879 from 

eimg::details::SSLayerGetNames  

28/03/18 12:20:28 SessionMgr(816): ERROR: <NULL> failed  

28/03/18 12:20:28 SessionMgr(816): ERROR: #67 from <NULL>  

28/03/18 12:20:28 SessionMgr(816): ERROR: eimg_FileImageNamesGet failed  

28/03/18 12:20:28 SessionMgr(816): ERROR: #14930 from 

eimg_FileImageNamesGet  

28/03/18 12:20:28 SessionMgr(816): ERROR: eimg_FileOpen failed  

28/03/18 12:20:28 SessionMgr(816): ERROR: #5968 from eimg_FileOpen  

28/03/18 12:20:28 SessionMgr(816): ERROR: h:/temp/super-stack_4-dates.img.r2: 

eimg_FileOpen failed (33:Unsupported Raster format or non-Raster format)  

28/03/18 12:20:52 SessionMgr(816): ERROR: #22879 from 

eimg::details::SSLayerGetNames  

28/03/18 12:20:52 SessionMgr(816): ERROR: <NULL> failed  

28/03/18 12:20:52 SessionMgr(816): ERROR: #67 from <NULL>  

28/03/18 12:20:52 SessionMgr(816): ERROR: eimg_FileImageNamesGet failed  

28/03/18 12:20:52 SessionMgr(816): ERROR: #14930 from 

eimg_FileImageNamesGet  

28/03/18 12:20:52 SessionMgr(816): ERROR: eimg_FileOpen failed  
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28/03/18 12:20:52 SessionMgr(816): ERROR: #5968 from eimg_FileOpen  

28/03/18 12:20:52 SessionMgr(816): ERROR: h:/temp/super-stack_4-dates.img.r3: 

eimg_FileOpen failed (33:Unsupported Raster format or non-Raster format)  

28/03/18 12:20:59 SessionMgr(816): ERROR: #22879 from 

eimg::details::SSLayerGetNames  

28/03/18 12:20:59 SessionMgr(816): ERROR: <NULL> failed  

28/03/18 12:20:59 SessionMgr(816): ERROR: #67 from <NULL>  

28/03/18 12:20:59 SessionMgr(816): ERROR: eimg_FileImageNamesGet failed  

28/03/18 12:20:59 SessionMgr(816): ERROR: #14930 from 

eimg_FileImageNamesGet  

28/03/18 12:20:59 SessionMgr(816): ERROR: eimg_FileOpen failed  

28/03/18 12:20:59 SessionMgr(816): ERROR: #5968 from eimg_FileOpen  

28/03/18 12:20:59 SessionMgr(816): ERROR: h:/temp/super-stack_4-dates.img.r4: 

eimg_FileOpen failed (33:Unsupported Raster format or non-Raster format)  

28/03/18 12:21:03 SessionMgr(816): Spatial model execution complete.  

The RSETs do seem to be created (and used) correctly.  

IM-36660  Image Chain stretch panel 

enhancement not correctly 

responding by entering 

values from keyboard  

1.Open Raster image (16-bit Multispectral) as Image chain data  

2. Launch Stretch panel, change the type to Two Point Linear.  

3. Change the Gray Max to 400 by entering from Keyboard and click enter.  

Observe that image changes to white. But when the same value is adjusted through 

moving the slider the colour changes as expected.  

IM-36198  CGCF-ECW and 

CCGF-JP2 Not Persisting 

GeoTIFF Tag Correctly  

Creatable Grid Covergage Fromat (CGCF) ECW and CCGF JP2 Not Persisting 

GeoTIFF Tag Correctly  

GeoTIFF tags are not persisted as "2240" as is found in the source TIFF. Rather, 

they are persisted as "Unknown-2240".  

This test was done using the "Save As" Viewer capability in ERDAS IMAGINE 2016 

v16.1  

IM-22018  CellArray with large 

number of rows is wrong 

when scrolled to bottom  

Start Raster Attribute Editor on Segmentation or Clump output with upwards of 

400,000 classes. Scroll to bottom - you see the first few rows instead of the last few 

rows.  

Resize the dialog to make it taller (or enlarge docked panel within the ribbon).  

Try again - it now works OK. Shrink the dialog back - the problem reappears.  

For larger CellArrays (a million rows) the resizing trick does not work. This makes it 

virtually impossible to see the last rows of the table.  

Use RasterToVector to create arc coverage with same amount of records. View 

coverage and view vector attributes - has similar problems.  

This affects all CellArrays in ERDAS IMAGINE when dealing with a long list.  

IM-11221  ERDAS IMAGINE not 

recognizing Hebrew 

characters in the folder 

name  

ERDAS IMAGINE 2013 and 2014 are not recognizing any files in the folder when the 

folder name is written in Hebrew character  

IM-20577  GeoEye TIFF image 

without 

GTRasterTypeGeoKey tag 

delivers many repeat 

errors  

When reading the GTRasterTypeGeoKey tag from a GeoEye TIFF image, the 

session log posts the following message 13 times:  

eWkspace(1724): ***WARNING NUMBER 1758 IN FUNCTION 

GeoTIFFGeoreferencingGet***  

eWkspace(1724): >>>Cannot locate GTRasterTypeGeoKey; assuming 

RasterPixelIsArea<<<  

IM-35798  ERDAS IMAGINE crashes 

on pressing Enter Key 

from keyboard after 

clicking on File > New 

Launch ERDAS IMAGINE  

Select File > New  

Click on the White space below 2D View #1 New Options  

Press Enter Key  
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white space  Observe that ERDAS IMAGINE crashes  

IM-20588  Spatial Profile tool crashes 

when trying to calculate a 

second line of sight profile  

Observed while performing tests to validate a M.App X geoprocessing service.  

Display a DEM  

Fit to Frame.  

On the Panchromatic tab select Spatial Profile.  

Say OK to the warning that no vector layers are displayed.  

Draw a line corner to corner of the DEM.  

Observe that a profile is drawn.  

In the Spatial Profile tool click the Edit menu and select Overlay Sight.  

Specify the height off the ground as 6 feet and click Apply.  

Observe that line of sight is calculated and overlaid onto the profile.  

Leave the Line of Sight overlaid.  

Select the digitise polyline tool and draw a new profile line (shorter than the original if 

you want).  

Observe that memory usage gradually goes up to 4GB and the profile tool eventually 

crashes (after several minutes).  

16/03/15 09:58:56 SessionMgr(7376): advprofile.exe exited with status 

-1073741819.  

Instead, if Sight overlay was turned off before creating the new line, it would have 

worked fine.  

IM-19745  TIFF DLL not handling 

multi-page TIFFs correctly  

ERDAS IMAGINE 2013 correctly handled multi-page TIFFs.  

In ERDAS IMAGINE 2014, a regression crept in where only the first page of the TIFF 

can be displayed. All the pages in the TIFF can be seen in the Multi-Image tab, and 

all of the pages can be selected as sub-images, but the selected TIFF page is not 

displayed. Rather, the first page is displayed.  

IM-21166  Alone Algorithm File 

Crashes ERDAS IMAGINE  

Sequence to Reproduce:  

(1) Install ERDAS IMAGINE 2015, but do not include ER Mapper  

(2) Copy 

<IMAGINE_HOME>/examples/ermapper/miscellaneous/test_patterns/HSI_Wheel.al

g to a folder on the local disk. (Do not copy the Demo_wheel.* files).  

(3) Open / Algorithm on the copy of the ALG file  

ERDAS IMAGINE terminates abnormally.  

It does not terminate if you copy the Demo_wheel files.  

IM-13358  ERS DLL does not use 

ECW file referenced in 

ERS Header correctly  

ERS DLL does not use ECW file referenced in ERS Header correctly.  

Add the two ERS header files referencing ECW files to MosaicPro  

Run the mosaic to a .ecw file  

A message appears once the process begins: ERS Raster error: Filetype Unknown 

error message when mosaicking .ers files. Mosaic slowly completes.  

Session Log:  

02/12/13 10:01:47 C:/Program Files/Intergraph/ERDAS IMAGINE 

2014/bin/x64URelease/mosaicprocesspro.exe -m 

c:/temp/mosaic_tmp_mos_008780 -temporary -background 0 -ignore 0 

-excludeempty 0 -meter mosaic  

02/12/13 10:01:56 SessionMgr(6056): ERROR: #46 from 

ersFileTitleIdentifyAndOpen  

02/12/13 10:01:56 SessionMgr(6056): ERROR: erdas::ers::FileHandle::DoOpen 

failed  

02/12/13 10:01:56 SessionMgr(6056): ERROR: #95 from 

erdas::ers::FileHandle::DoOpen  
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02/12/13 10:01:56 SessionMgr(6056): ERROR: ERS Raster error: Filetype unknown  

02/12/13 10:01:58 mosaicprocesspro(4312): One or more input files or output files 

cannot be opened by 64 bit MosaicProcessPro. Starting in 32 bit.  

02/12/13 10:01:58 C:/Program Files/Intergraph/ERDAS IMAGINE 

2014/bin/Win32Release/mosaicprocesspro.exe -m 

c:/temp/mosaic_tmp_mos_008780 -temporary -background 0 -ignore 0 

-excludeempty 0 -meter mosaic  

IM-18862  Opening ERS file gives 

incorrect NODATA 

message in Session Log  

Launch ERDAS IMAGINE.  

In 2D View, open an ERDAS ER Mapper (*.ers) file,  

In Session log, see “16/12/14 08:33:25 eWkspace(14248): The input NullCell Value 

is out of range for the current pixel type  

16/12/14 08:33:25 eWkspace(14248): The input NullCell Value is out of range for the 

current pixel type…....”  

IM-20601  Computing pyramids on a 

Virtual Mosaic (VMCX) 

pointing to 15k by 5k PNG 

throws a series of errors  

Computing RRDs on a VMCX pointing to 15k by 5k PNG throws a series of errors.  

In Image Metadata, open the VMCS file and compute Pyramids.  

ERDAS IMAGINE throws a series of errors.  

After some time, Image Metadata crashes.  

 

IMAGINE Advantage 

Issue ID  Summary – IMAGINE 

Advantage  

Description / How to Reproduce  

IM-22547  Incorrect and inconsistent 

output parameters for 

orthorectification in both 

ERDAS IMAGINE and 

IMAGINE Photogrammetry  

In trying to create Operators for Spatial Model for orthorectification we needed to 

look at the default behavior for orthorectification of calibrated images.  

Generally, when rectifying or reprojecting an image you want the default settings to 

never result in a loss of pixel information. Obviously this cannot be eradicated 

entirely (except by gross oversampling), but you want to generally produce an output 

image where few pixels have been dropped out from the input image.  

A rough measure of this is that no matter how rotated or warped the model is, the 

output would generally have to have more pixels than the input in order to preserve 

every input pixel.  

Unfortunately not only do the ERDAS IMAGINE output defaults often not meet this 

requirement, they are also frequently inconsistent between the numerous 

approaches you can take to producing a transformed output image. We need to be 

both consistent and correct.  

See specific NITF sample image  

Open the image in a 2D View.  

Click Image Metadata and note that the image is 8820 columns x 4696 rows.  

Scenario1:  

Multispectral tab / Transform & Ortho tab / Transform & Ortho menu, select Ortho 

Using Existing Model.  

Note in the dialog that the output image defaults to having only 6599 columns x 6278 

rows.  

Given the nature of this image’s geometric model, which is a “shear” into a 

parallelogram shape, the reduction in columns means that 1/3rd of the original image 

pixels will be missing from the output. Go ahead and produce the output and take a 

look at it – it has a degraded appearance.  

Scenario2:  

Multispectral tab / Transform & Ortho tab / Transform & Ortho menu, select 
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Reproject.  

Set to Geographic / WGS84, which is the same as Scenario1.  

Note strange default pixel dimensions.  

Produce the output – note that this one is 8820 columns x 4696 rows – same as the 

input.  

IM-33588  Horrendous edge artifacts 

introduced with Bicubic 

resampling  

See data geometrically calibrated using RPCs.  

On the Multispectral tab / Transform & Ortho / Ortho Using Existing Model.  

In the Resample dialog, specify square pixels, ignore 0 in stats, use Elevation 

Library and set resampling to Bilinear.  

Specify output filename and OK.  

Display results in a 2D View with background set to red.  

Observe perfectly crisp left-hand edge of the image.  

Now repeat, but this time select Bicubic resampling.  

Observe nasty edge artifacts of near-black introduced around the edges of the data.  

IM-41647  Condor processes using 

32-bit Batch process for 

the jobs submitted from 

64-bit ERDAS IMAGINE  

From Submitting node, Distributed processing is started using Batch Command 

Editor of ERDAS IMAGINE 64-bit.  

On the Processing node, the job is processed using 32-bit Batch process instead of 

64-bit Batchprocess.  

IM-22790  MosaicPro should default 

to Bilinear when 

resampling must occur  

MosaicPro should default to Bilinear when resampling must occur to ensure the best 

quality image by default. By default Nearest Neighbor is used and creates blocky 

and lower quality data than MosaicPro can deliver.  

Several other tools default to Bilinear when resampling is needed. MosaicPro should 

follow the move to better default data output.  

IM-46606  Adding images with “Active 

Areas by Corners” is 

generating very bad 

output, whereas the 

“Active Area by Edges” is 

giving good output  

Customer reported that in MosaicPro by adding images with “Active Areas by 

Corners” is generating very bad output, whereas the “Active Area by Edges” is giving 

good output.  

“Active Areas by Corners” was occasionally mis-identifying corners thereby clipping 

too much from the input data.  

IM-25246  MosaicPro: sometimes 

leaves holes when 

creating specific dataset  

Occasionally Seamlines in MosaicPro would result in small (1 pixel) gaps in the 

output mosaic  

IM-45744  Reset button not working 

as expected in MosaicPro 

> Adjust individual image 

radiometry  

1.Launch ERDAS IMAGINE, Launch MosaicPro from Raster tab > Geometry  

2.Add images, make them visible and select from table  

3.Click Adjust individual image radiometry, Change the brightness by dragging 

Brightness bar  

4.Click Reset Button and observe Brightness bar reverting to original state but image 

still persist with brightness change.  

NOTE: Instead of reset button at the bottom if we click the reset brightness beside 

the brightness bar image reverting to original state.  

IM-43093  Mosaic Express does not 

include Lagrange 

resampling method  

Mosaic Express does not include Lagrange resampling method  
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IM-44279  MosaicPro Workstation 

crashed when opening a 

specific project  

In some instances, where input images overlap each other almost 100%, crashes 

could occur.  

IM-44912  Some input image is 

missing in mosaicking 

output  

There are only two input images, the left and the right. They look good in MosaicPro 

workstation. However, the left is missing in the output file.  

IM-48504  Toggling raster display 

after editing seam polygon 

crashes MosaicPro  

Launch ERDAS IMAGINE 2018  

Open MosaicPro, load two overlapping airphotos.  

Make the images visible and display the rasters.  

Click ‘Automatically generate seamlines for intersections’ button and in ‘Seamline 

generation options’ dialog, click ok.  

Click ‘Edit seam polygons’ and draw a polygon at the intersection. Observe seam 

polygon is edited.  

Now click ‘Display raster images’ and observe MosaicPro crashes.  

IM-46883  running 

mosaicprocesspro.exe 

from Command window 

ignores TIFF compression 

parameter  

When running mosaicprocesspro.exe from the Command window, the TIFF 

compression argument is ignored. The compression setting from the TIFF 

preferences is used instead. The help documentation for mosaicprocesspro states 

that “If you do not specify this option when the output is a TIFF image, the 

compression type specified in the TIFF preferences is used.”  

IMAGINE Objective 

Issue ID  Summary – IMAGINE 

Objective  

Description / How to Reproduce  

IM-39533  Running FLS 

Segmentation crashed 

fe_process  

Specific data would cause FLS Segmentation to run out of memory and 

crash.  

 

IMAGINE Photogrammetry 

Issue ID  Summary – IMAGINE 

Photogrammetry  

Description / How to Reproduce  

IM-47032  IMAGINE Photogrammetry 

ATE Report cannot be 

loaded using the Ribbon 

function  

After a successful ATE run it is actually not possible to load the ATE Report by 

activating the Photogrammetry ribbon function “Reports/Automatic Terrain 

Extraction (ATE) Report”. It seems that the blockfile name and the blockfile path are 

not saved properly when executing ATE (see line 8 and 9 of the ATE reportfile).  

Error messages and warnings reported in the session log:  

18/12/18 14:16:30 SessionMgr(7256): ERROR: #2277 from StartATEReport  

18/12/18 14:16:30 SessionMgr(7256): ERROR: eatm_DTMExtractionReport Failed  

18/12/18 14:16:30 SessionMgr(7256): WARNING: #598 from 

eatm_DTMExtractionReport  

18/12/18 14:16:30 SessionMgr(7256): WARNING: No valid report file exists  

18/12/18 14:16:40 SessionMgr(7256): ERROR: #2277 from StartATEReport  

18/12/18 14:16:40 SessionMgr(7256): ERROR: eatm_DTMExtractionReport Failed  

18/12/18 14:16:40 SessionMgr(7256): WARNING: #598 from 

eatm_DTMExtractionReport  

18/12/18 14:16:40 SessionMgr(7256): WARNING: No valid report file exists  
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IM-46924  3D ASCII output from 

Create Mean Terrain has 

characters for space 

making the output not 

useful  

* Launch ERDAS IMAGINE 2018 64-bit.  

* Open a blockfile in the viewer.  

* From the Photogrammetry tab, under Generate drop down menu, click Create 

Mean Terrain.  

* In the Create Mean Terrain dialog, select 3D ASCII as Output DTM Type.  

* Give the name of the output and click OK in the dialog.  

Open the output in a text editor and notice that there are characters for spaces in 

the file. This makes the file not useable in any other tools like Surfacing tool.  

IM-44828  Unable to import a project 

into IMAGINE 

Photogrammetry  

1.Launch ERDAS IMAGINE 2018  

2.Load any block file  

3.Launch Import Inpho project from Photogrammetry Tab > Conversion group  

4.Try to import InphoProject file of Type .prj , observe that you are not able to import 

as block file loaded in the input file field and trying to load .prj from file chooser is not 

showing the file in the respective folder  

IM-48674  Unable to open SPOT-7 

DIMAP V2 

(DIM_SPOT.xml) 

projected (PRJ) raster data  

SPOT-7 DIMAP V2 projected (PRJ) PMS data fails to open in ERDAS IMAGINE 

2018  

Launch ERDAS IMAGINE 2018  

Right-click > Open Raster  

from the file chooser > Files of type  

select > SPOT DIMAP V2  

choose DIM file DIM_SPOT7_PMS_*_PRJ_*.XML  

Error message appears. “Unknown DIMAP format”  

IM-47013  No footprints when loading 

a block file with offline 

terrain file  

A specific .blk adjusted in ERDAS IMAGINE 2016 can be open as expected in the 

LPS Project Manager, with footprints, etc. displayed.  

But if opened as a photogrammetric project, in ERDAS IMAGINE 2016 or 2018, 

only the CellArray displays, the footprints do not. And when you fit to frame or zoom 

out an error message displays.  

This is caused by an offline LTF file under the Terrains folder. Once you remove it, 

the error message is gone.  

IM-48409  Block files created with an 

older version (ERDAS 

IMAGINE 2016 and 

earlier) are not compatible 

with IMAGINE 

Photogrammetry 2018  

Block files created with an older version (2016 and earlier) are not compatible with 

IMAGINE Photogrammetry 2018 for the purpose of making orthophotos.  

Orthorectification with 2018 fails, generates corrupted image.  

Data is TiFF aerial RCD30 data.  

IM-47866  IMAGINE Photogrammetry 

Orthoresample error with 

ADS L1 blk project  

Orthoresample function with ADS L1 blk project fails with ERDAS IMAGINE 2018 

Update 2. If you attempt to orthorectify L1 imagery you get a “Failed to recognize 

Authority Code” error.  

IM-46599  Under Photogrammetry 

tab, Import ISAT, Inpho, 

PATB and SS project is 

not showing up the input 

files unless the format in 

the Import window is 

re-selected  

1) Launch ERDAS IMAGINE -> Open any block file  

2) Under Photogrammetry tab -> Import ISAT Project  

3) In the Import window click open for Input File and browse to a location with ISAT 

Project files  

Observe that the ISAT project icon is not shown.  

Also for other 3 formats Inpho project, SS project and PATB project also the case is 

same, that is, the respective format files do not show. But if Format is re-selected in 

the Import window, then the input files do show.  

IM-41918  Deleted points in .las are 

still there after exporting to 

HPC file  

Several point clouds in LAS format were edited in IMAGINE Professional to remove 

incorrect elevation points.  

The resulting LAS were now used in GeoMedia 3D using the HPC Point Clouds 

workflow to Construct a HPC and then insert the resulting HPC into an access 

warehouse, The two processes ran with no error.  
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The HPC is now displayed in GeoMedia 3D. The points previously edited in ERDAS 

IMAGINE are still there.  

IM-45013  Height Above Ground tool 

does not preview and 

throws error message  

ERDAS IMAGINE 2018  

1) Launch ERDAS IMAGINE > Terrain tab > Height Above Ground  

2) Provide a classified LAS file as input  

3) Give input raster elevation file  

4) Give output name  

5) Click Preview button  

Observe that it throws this error saying: No PreviewOperators in model.  

IM-46256  Errors pop up if a file from 

recent list is opened on top 

of a point cloud preview  

Data: GMDX, LAS, SHP and IMG files of the same project area  

Steps to reproduce:  

* Open the LAS, SHP and IMG files in the 2D View.  

* Clear the View and launch Spatial Modeler Editor.  

* Open a gmdx file and give the LAS file from the project as input to the Point Cloud 

Input operator.  

* Click on Preview.  

* Once the preview is up and the Preview View selected, from the Point Cloud tab 

select Classification in the Color by drop down menu.  

* From File > Recent select either the SHP or IMG file that were previously opened 

in the 2D View.  

Notice that error pop up.  

Session log:  

26/09/18 14:38:44 SessionMgr(26760): ERROR: #124 from ArrangeLayersCB  

26/09/18 14:38:44 SessionMgr(26760): ERROR: 

erdas::EmlFramework::ShellMeter::Create failed  

26/09/18 14:38:44 SessionMgr(26760): ERROR: #56 from 

erdas::EmlFramework::ShellMeter::Create  

26/09/18 14:38:44 SessionMgr(26760): ERROR: Trying to change a running meter 

from modal to non-modal is not supported!  

IM-40464  Loading a specific LAZ file 

as Raster crashes ERDAS 

IMAGINE  

1.Launch ERDAS IMAGINE 2018  

2.Load the file specific .laz ,by selecting files of type as LAZ as Raster (.laz) ( not 

LAZ as Point Cloud (*las) )  

3.Observe ERDAS IMAGINE crashes.  

When the same file is opened as LAZ as Point Cloud(.las), ERDAS IMAGINE does 

not crash  

IM-49425  ERDAS IMAGINE 2018 

Update 2 is unable to open 

customer’s *.las file  

Customer reported that ERDAS IMAGINE is unable to open their las and laz files. 

According to the customer the same las file opens in a popular GIS application.  

In ERDAS IMAGINE the following error messages show in the session log, while 

opening the customer’s las in a 2D View  

24/06/19 00:30:42 SessionMgr(12944): Connection success for the external 

process ‘eWkspace_64’  

24/06/19 00:31:27 SessionMgr(12944): ERROR: #192 from vr_lidarvlLayerOpen  

24/06/19 00:31:27 SessionMgr(12944): ERROR: erdas::laslib::GenericVlr::Read 

failed  

24/06/19 00:31:27 SessionMgr(12944): ERROR: #228 from 

erdas::laslib::GenericVlr::Read  

24/06/19 00:31:27 SessionMgr(12944): ERROR: emif_ConvertToMIF failed  

24/06/19 00:31:27 SessionMgr(12944): ERROR: #6148 from emif_ConvertToMIF  

24/06/19 00:31:27 SessionMgr(12944): ERROR: emif_MIFtoObject failed  

24/06/19 00:31:27 SessionMgr(12944): ERROR: #6207 from emif_MIFtoObject  

24/06/19 00:31:27 SessionMgr(12944): ERROR: Invalid object or design!  
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IM-47189  ERDAS IMAGINE crashes 

with point cloud polyline 

profile  

1.Launch ERDAS IMAGINE  

2.Load a point cloud image, Select point cloud Tab  

3.From Profile group, select Polyline Profile  

4.Draw a polyline and end it by single mouse click and double click Left Mouse 

button at the exact same point  

5.Observe ERDAS IMAGINE crashes.  

IM-45910  ERDAS IMAGINE 32-bit 

crashes while trying to pan 

in the HPC file’s profile 

views after zoom is 

performed  

* Launch ERDAS IMAGINE 2018 32-bit and load a HPC file.  

* From the Profile group of Point Cloud tab, click the Rectangle Profile option and 

draw a rectangle in the viewer.  

* In either the Sideview Profile viewer or the Frontview Profile viewer, zoom in and 

then pan using either the middle mouse button or the pan tool from the Home tab.  

Notice that ERDAS IMAGINE crashes.  

ERDAS IMAGINE 2018 64-bit doesn’t crash but only shows up error while panning.  

Session log:  

_31/08/18 15:16:56 SessionMgr(3096): ERROR: #4 from 

EFGA_DERIVEPOLYCOEFS_  

_31/08/18 15:16:56 SessionMgr(3096): ERROR: EFGA_SOLVELINEAREQS 

failed_  

_31/08/18 15:16:56 SessionMgr(3096): ERROR: #4 from 

EFGA_SOLVELINEAREQS_  

_31/08/18 15:16:56 SessionMgr(3096): ERROR: egda_MatrixDivide failed_  

_31/08/18 15:16:56 SessionMgr(3096): ERROR: #6 from egda_MatrixDivide_  

_31/08/18 15:16:56 SessionMgr(3096): ERROR: egda_MatrixDivideF64 failed_  

_31/08/18 15:16:56 SessionMgr(3096): ERROR: #2 from egda_MatrixDivideF64_  

_31/08/18 15:16:56 SessionMgr(3096): ERROR: egda_MatrixLUDecomposition 

failed_  

_31/08/18 15:16:56 SessionMgr(3096): ERROR: #7 from 

egda_MatrixLUDecomposition_  

_31/08/18 15:16:56 SessionMgr(3096): ERROR: egda_MatrixLUDecompositionF64 

failed_  

_31/08/18 15:16:56 SessionMgr(3096): ERROR: #1 from 

egda_MatrixLUDecompositionF64_  

_31/08/18 15:16:56 SessionMgr(3096):  

IM-45741  While Exporting to ISAT 

project for which sensor 

models are Unsupported, 

the exportisat.exe process 

crashes  

# Launch ERDAS IMAGINE  

# File > New > Photogrammetric Project and give the path of the Block fie to be 

saved  

# Select *Rational Functions* for Geometric Model Category and *Quickbird* *RPC* 

for Geometric Model on Model Setup dialog and Click OK  

# Leave the default settings on Block Property Setup dialog and Click OK  

# Now add NITF format QuickBird images to the block file  

# Save the Block file and go to Conversion group > *Export to ISAT Project*  

# Provide output project name and Hit OK  

# Observe that the exportisat.exe crashes while exporting to ISAT project  

Note: Similar is the observation for Formosat2 orbital pushbroom model, Triplesat 

RPC  

IM-43782  Failure at the end of the 

process due to tridicon 

intermediate files limitation  

To produce a DSM with 6 granules of satellite images, customer uses the 

Semi-Global Matching (SGM) tool. The first step of SGM is to calculate Tridicon 

Intermediate files for each pair of images. If a Tridicon intermediate file generated is 

bigger than 4GB, ERDAS IMAGINE returns an error and stop the process (since the 

Tridicon software does not support BigTIFF).  

If possible please compute output intermediate image size in advance, for example 
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displaying a warning to prevent having to wait until at the end of the process before 

it fails.  

IM-48126  ERDAS IMAGINE crashes 

while trying to get the 

report after changing the 

Remove Points over n 

Standard Deviations value 

multiple times  

ERDAS IMAGINE 2018 Update 2 64-bit  

1) Launch ERDAS IMAGINE > Load a specific Block File > Launch Stereo Point 

Measurement (SPM)  

2) Under SPM > Tools > launch Tie Point Uncertainty Analysis  

3) Change the value of Remove Points over n Standard Deviations to 0 and Apply > 

Click Report > Observe that Report launches  

4) Now again Change the value of Remove Points over n Standard Deviations to 0 

and Apply > Click Report and again repeat the same step  

Observe that ERDAS IMAGINE crashes while trying to get the report after changing 

the value of Remove Points over n Standard Deviations multiple times.  

IM-47477  Under Stereo Point 

Measurement (SPM) 

Viewing Properties in 

Image Correlation texts 

are not properly visible for 

Correlation Contrast  

1) Launch ERDAS IMAGINE > File > Open > Photogrammetric Project > open a 

specific Block project  

2) Launch Stereo Point Measurement Tool from Point Measurement dropdown 

menu  

3) In SPM under Tools Menu launch Viewing Properties, select Image Correlation 

tab  

Observe that the Text for 'Low' and 'High' are not visible properly  

 

IMAGINE Professional 

Issue ID  Summary – IMAGINE 

Professional  

Description / How to Reproduce  

IM-20641  Every so often an ECW in 

a batch list fails to 

calculate stats  

Running a batch statistics/histogram calculation (32-bit application) with a total of 

more than 5000 ECWs; running 3 jobs in parallel. Each image is 4000 x 4000 x 

3bands x ECW v2.  

Every so often, an ECW fails to calculate stats. Locate the ECW, open it in the 

Viewer, it displays fine and is visually fine. Open the ECW in Image Metadata, it 

looks fine. Calculate stats, and the process completes fine.  

Failure in Session log states: imagecommand.exe exited with status -1073741819.  

IM-45743  Number of output files 

produced is not the same 

as number of inputs 

provided in Batch, Start 

Processing Later At  

1.Launch Unsupervised Classification from Raster tab > Classification > 

Unsupervised  

2.Provide the input file, specify output file, provide required number of classes and 

click on Batch  

3.Now select variables as one input, one or more outputs  

4.Add three more files, click on submit , select Start Processing Later At  

5.Provide Simultaneous Processes as 4 and click OK  

6.Provide the proper credentials and click Ok  

7.Scheduled batch process listed and process become active at start time and done 

after a while.  

8.Observe the output folder. The outputs produced are one or two files, rather than 

the expected four. This is not the case with Batch > Start Processing Now  

IM-36818  Spatial Modeler batch 

command file (.bcf) is not 

saved from the Batch 

Command Editor  

Spatial Modeler batch command file (.bcf) is not saved from the Batch Command 

Editor when accepting the default batch command name after clicking OK  

To recreate:  

- Open Spatial Model  

- select Run in Batch (opens the Batch Command Editor)  
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- select Save. The Batch Command file chooser opens with the temp batch filename.  

- select OK.  

The batch command file is not saved in the default temp location  

If you manually add the .bcf extension, the batch command file is saved.  

If you change the name, the batch command file is saved.  

If you redirect to a different folder, the batch command file is saved.  

If you click <Enter> instead of OK, the file is saved.  

IM-8447  Spectral Euclidean 

Distance value continues 

to change when clicking 

other areas than the 

nudgers  

In the Region Growing Properties tool, the Spectral Euclidean Distance nudger is 

“sticking” when changing the value and then proceeding to grow regions in the 2D 

View. The Spectral Euclidean Distance value continues to be adjusted even though 

the mouse clicks are elsewhere in the ERDAS IMAGINE interface.  

This problem does not occur in ERDAS IMAGINE 2011. The Region Growing 

Properties dialog did not have a thumbwheel for adjusting the Spectral Euclidean 

Distance in 2011, so maybe that is contributing to the problem.  

Steps to reproduce:  

Display the raster file lanier.img in a 2D View.  

Open the Region Growing Properties tool (Drawing tab > Insert Geometry group > 

Grow menu > Growing Properties).  

Click the Grow icon (Drawing tab > Insert Geometry group > Grow) to place a seed 

pixel in an area of water.  

Click on the up nudger a couple of times to increase the Spectral Euclidean Distance 

value.  

Now click on an empty area in the Region Growing Properties tool and notice that 

the Spectral Euclidean Distance value continues to change and the polygon region 

in the 2D View continues to grow to reflect the change of the Spectral Euclidean 

Distance value.  

Even if you click elsewhere in the ERDAS IMAGINE interface, the Region Growing 

Properties tool remains active and the Spectral Euclidean Distance value continues 

to change.  

IM-45028  Image Alarm crashes 

64-bit version of ERDAS 

IMAGINE 2018  

Image Alarm tool crashes ERDAS IMAGINE 2018 64-bit. Session log reports 

“Unusual file mapping size 264248”. The 32-bit versions of ERDAS IMAGINE 2018 

and ERDAS IMAGINE 2016 Update 1 do not crash when using this tool.  

Steps to reproduce:  

# Display Multispectral image in a 2D View  

# Start the Signature Editor. (Raster tab > Classification group > Supervised menu > 

Signature Editor).  

# Open a signature file derived from the Multispectral image.  

# Re-associate the signature file and the image. (Signature Editor > Edit menu > 

Image Association)  

# Select one of the rows in the Signature Editor.  

# Start the Signature Alarm tool. (Signature Editor > View menu > Image Alarm) and 

click OK.  

# Click inside the 2D View.  

# ERDAS IMAGINE 2018 crashes.  

IM-47545  Unsupervised 

classification generates 

output with a missing block 

of data  

Unsupervised classification generates output with a missing block of data.  

Failure appears be related to the number of classes to be created and to the output 

file type (i.e. TIFF). A specific lower and upper range fails when writing TIFF output. 

Using this same range works when writing IMG output. Specifying a different number 

of output classes works when writing TIFF output.  

If the input TIFF file is converted to IMG and used as input, the problem is not seen.  

These errors are seen when the failure occurs  
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06/02/19 11:37:39 SessionMgr(14936): etif_HandleBlockRead failed  

06/02/19 11:37:39 SessionMgr(14936): etif_HandleBlockRead failed  

06/02/19 11:37:39 classifyisodata(2656): Creating signature file: 

C:/Temp/imagine/name  

06/02/19 11:37:39 SessionMgr(14936): etif_HandleBlockRead failed  

06/02/19 11:37:40 SessionMgr(14936): etif_HandleBlockRead failed  

IM-46109  classifyisodata.exe 

crashes for running 

Unsupervised 

classification operator to 

an ECW output  

In ERDAS IMAGINE, open Spatial Model Editor.  

Drag and Drop Unsupervised classification operator.  

Double click the operator and specify 'Input Raster Layer' and 'Output cluster layer'.  

Input raster can be any format e.g. img.  

Output format should be ECW.  

Click ok and run the model.  

Observe run fails and session log info is as below:  

external process exited with status -1073741819.  

IM-47278  Geophysical Processing 

not working in ERDAS 

IMAGINE 2018  

1.Launch ERDAS IMAGINE 2018.  

2.Launch Geophysical Processing from Raster > Classification > Unsupervised  

3.Provide the input as lanier.img , provide the output and click ok  

4.Observe Process failing and session log showing errors  

Session log:  

18/01/19 18:25:40 SessionMgr(11576): Connection success for the external process 

'eWkspace'  

18/01/19 18:26:08 eWkspace(6800): Loading [geophysical.eml]...  

18/01/19 18:26:37 C:/Program Files/Hexagon/ERDAS IMAGINE 

2018/bin/x64URelease/smprocess.exe 

$IMAGINE_HOME/etc/models/HorizonDip_NoClip.gmdx Raster 

Input.Filename=d:/2019/data_delete/lanier.img Raster 

Output.FilenameIn=d:/2019/16-01-2019/delete/geop.img  

Raster Output.PixelType=F64 Band Selection.BandRange=1:1  

18/01/19 18:26:37 eWkspace(6800): Unloading [geophysicalalgorithms.eml]...  

18/01/19 18:26:38 SessionMgr(11576): Running spatial model 

($IMAGINE_HOME/etc/models/HorizonDip_NoClip.gmdx) with port values (Raster 

Input.Filename=d:/2019/data_delete/lanier.img,Raster 

Output.FilenameIn=d:/2019/16-01-2019/delete/geop.img,Raster Output  

.PixelType=F64,Band Selection.BandRange=1:1).  

18/01/19 18:26:38  

18/01/19 18:26:38 smprocess:  

18/01/19 18:26:39 SessionMgr(11576): HexGeo::SpatialModeler::Operator::Execute 

failed  

18/01/19 18:26:39 HexGeo::SpatialModeler::Operator::Execute failed  

18/01/19 18:26:39 HexGeo::SpatialModeler::Operator::Execute failed  

18/01/19 18:26:39 HexGeo::SpatialModeler::Operator::Execute failed  

18/01/19 18:26:39 HexGeo::SpatialModeler::Operator::Execute failed  

18/01/19 18:26:39 HexGeo::SpatialModeler::Operator::Execute failed  

18/01/19 18:26:39 HexGeo::SpatialModeler::Operator::SetErrorMessage failed  

18/01/19 18:26:39 Spatial Model failed in Raster Input. The error was "No valid input 

Filename available".  

18/01/19 18:26:39 SessionMgr(11576): Spatial model failed.  

18/01/19 18:26:39  

18/01/19 18:26:39 SessionMgr(11576): smprocess.exe exited with status 1.  
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IM-47261  Loading JP2 output from 

Unsupervised 

classification crashes 

ERDAS IMAGINE  

1.Launch ERDAS IMAGINE  

2.Launch Unsupervised classification from Raster > Classification > Unsupervised  

3.Provide the input as lanier.img  

4.Provide the output as unsuper.jp2 (File of type:JPEG2000)  

5.Provide the number of classes as 3 and click OK  

6.Process fails,, ignore it and try to load output from File open > Recent button  

7.Obvserve ERDAS IMAGINE crashes.  

IM-47533  LaGrange resampling 

method not present in 

Geophysical Processing 

dialog  

1.Launch ERDAS IMAGINE  

2.Select Geophysical Processing from Raster > Classification > Unsupervised > 

Geophysical  

3.Observe LaGrange resampling method not present but help page contain 

LaGrange also  

IM-46046  Opening this 

Hyperspectral Image is 

slow through Image Chain  

Open a specific .hdr hyperspectral image through Image Chain. Takes way too long.  

 

IMAGINE SAR Interferometry 

Issue ID  Summary – IMAGINE 

SAR Interferometry  

Description / How to Reproduce  

IM-45591  Coherence image 

produced by sentinel 

Swath CCD (mosaic) 

crashes 2D View  

Coherence image produced by sentinel Swath CCD (mosaic) crashes viewer. 

Simply open the image after mosaic  

Spatial Modeler 

Issue ID  Summary – Spatial 

Modeler  

Description / How to Reproduce  

IM-49746  Preview operator: Is not 

automatically re-projecting 

feature data when a 

Basemap is displayed  

This problem occurs in ERDAS IMAGINE as well as in the Spatial Model Editor. A 

feature layer can be added to a 2D View window. When this occurs, the window 

recognizes and displays the data using the appropriate coordinate system. If a 

Basemap is displayed in the window, the feature data is automatically re-projected 

to register to the Basemap - in this case OpenStreetMap, which uses EPSG 3857. 

Following a similar workflow using the Preview command to display the feature 

data, the data is not automatically re-projected (correctly) when a Basemap is 

displayed in the Preview window.  

IM-46647  OLH-Description of one 

port missing in help for 

Machine Intellect 

Information operator  

1.Launch ERDAS IMAGINE 2018, and then launch Spatial Model Editor  

2.Drag the Machine Intellect Information operator to Spatial Model Editor.  

3.Observe MethodInformation port exists.  

4.Launch help page and observe no description MethodInformation port and the 

screenshot also needs to be updated.  

IM-46629  OLH-Description of one 

port missing in help for 

Image Segmentation FLS 

operator  

1.Launch ERDAS IMAGINE 2018, and then launch Spatial Model Editor  

2.Drag the Image Segmentation FLS operator to Spatial Model Editor.  

3.Check ON the Show All Ports option and observe Max Tile Size port exists.  

4.Launch Help page and observe no description for Max Tile Size port  
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IM-46028  Proximity (and Cost) 

Spread operator's Help 

references a deprecated 

capability  

Start Spatial Model Editor  

Drag the Proximity Spread (or Cost Spread) operator onto the canvas  

Display the AutoStudyArea port  

Right-click on the Operator and select Help  

In the Help, look at the section for the AutoStudyArea port. It states:  

"If set to True, the StudyArea will be set to the same extent as the extent of 

OriginPointsRasterIn file. If set to False, the StudyArea is determined by the 

settings of Processing Properties dialog for the particular Spatial Model. Default 

setting is True."  

But there is no longer have a "Processing Properties dialog"  

Seems like the port has no purpose any more.  

IM-46624  OLH-Description of two 

ports missing in help for 

Raster Attribute Output 

operator  

1.Launch ERDAS IMAGINE 2018, and then launch Spatial Model Editor  

2.Drag the Raster Attribute Output operator to Spatial Model Editor.  

3.Check ON the Show All Ports option and observe Low Fill , High Fill exist.  

4.Launch Help page and observe no description for Low Fill , High Fill ports and 

also show all ports figure missing.  

IM-46623  OLH- No help for Sort 

Method in ICA operator.  

1.Launch ERDAS IMAGINE 2018, and then launch Spatial Model Editor  

2.Drag the ICA operator to S Spatial Model M Editor.  

3.Click on SortMethod port and launch help from SortMethod dialog pop-up  

4.Observe Help page navigating to errors page  

IM-46735  OLH for Machine Intellect 

Information operator 

needs to be updated  

A new output port, MethodInformation, was added to the operator in v16.5.2. But the 

OLH does not describe that port.  

IM-46543  OLH-Create Centroid 

operator figure to be 

updated in help page.  

1.Launch ERDAS IMAGINE 2018 Update 2  

2.Launch Spatial Model Editor and drag Create Centroid operator to Spatial Model 

editor  

3.Launch online help and observe figure in help page and figure in UI are not same.  

IM-46564  OLH- Multi Filename input 

operator should be 

updated with Default and 

show all ports figures.  

1.Launch ERDAS IMAGINE 2018 Update 2  

2.Launch Spatial Model Editor, drag Multi Filename input operator to Spatial Model 

editor and launch help  

3.Observe operator in UI having only three ports but help shows four ports. Shown 

in UI by checking ON Show all ports  

IM-45008  Some operators to be 

updated with show all 

ports in the Help  

1.Launch IMAGINE 2016, Spatial modeler, check on show all ports.  

2.Drag these operators from the Surface category:  

* Aspect  

* Degreeslope  

* Insolatio  

* LeastCostPath  

* Percent Slope  

* Relief  

3.Click on each operator help and observe that help needs to be updated with 

figures corresponding to show all ports.  

IM-46027  Proximity Spread 

operator's Elevation 

Restriction dialog has no 

Help  

Start Spatial Model Editor  

Drag the Proximity Spread (or Cost Spread) onto the canvas  

Display the Elevation Restriction port  

Double-click the Elevation Restriction port to bring up the Elevation Restriction 

dialog.  

Click Help  

Help goes to the generic Help Error page  

IM-47761  Screenshot in the 

Generate Functional 

The screenshot of the Generate Functional Attributes operator in its OLH mentions 

it as Functional Attributes. So the screenshot should be updated. Please see the 
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Attributes operator OLH 

should be updated  

attached screenshot.  

IM-46597  OLH- Create Buffer Ring 

operator help showing 

Inner Distance default 

value as Nearest 

Neighbor.  

1.Launch ERDAS IMAGINE 2018 Update 2  

2.Launch Spatial Model Editor from File > New  

3.Drag Create Buffer Ring operator to Spatial Model Editor and launch help  

4.Observe Inner Distance port showing default value as Nearest Neighbor, which 

was incorrect.  

IM-46596  OLH-Create Buffer Ring 

figures are placed instead 

of Create Buffer Zone in 

help page.  

1.Launch ERDAS IMAGINE 2018 Update 2, Launch Spatial Model Editor.  

2.Drag Create Buffer Zone operator and launch Help.  

3.Oberve Create Buffer ring operator figures are placed instead of Create Buffer 

Zone  

IM-46213  Join Features operator 

when Previewed for 2 

features with different 

Projection types, Preview 

is not correct even after Fit 

to Frame  

ERDAS IMAGINE 2018 Update 2  

1) Launch ERDAS IMAGINE > Toolbox Tab > Spatial Model Editor  

2) Open specific Spatial Model and then Preview  

3) Observe that the preview is blank initially, now Do Fit to Frame for the 2D Viewer  

Observe that the Features are not visible properly until its zoomed in  

Note:  

1) Here the FeaturesInLeft is having an input with State Plane projection and 

FeaturesIn Right is having UTM projection  

2) Even the other way around i.e., FeaturesInLeft with UTM projection and 

FeaturesIn Right with State Plane also has the same problem  

3) If both the Features of same projection, it shows the features properly after Fit to 

Frame  

IM-46714  Summarize Related 

Features to Preview or 

Feature Output fails for 

specific geometry-based 

expression  

ERDAS IMAGINE 2018 Update 2  

Spatial Model contains two Features Input , Summarize Related Features, Preview 

and Features Output operators:  

-> on preview, displays blank Preview.  

-> running the model, errors out at Features output and creates a 1kb shp and shx 

file; 0kb dbf file.  

(02/11/18 15:20:32 SessionMgr(8900): Executing spatial model  

02/11/18 15:20:32 SessionMgr(8900): erdas::sb_CGP::FeaturesOutput::OnExecute 

failed  

02/11/18 15:20:32 Unable to cast object of type 'Intergraph.Geometry.GDOBlob' to 

type 'System.Byte[]'.  

02/11/18 15:20:32 SessionMgr(8900): Spatial model execution failed.)  

IM-46560  Default Values are not set 

in the ports of Create 

Buffer Ring and Create 

Buffer Zone operator  

ERDAS IMAGINE 2018 Update 2  

Default values of the Distance Units, Linear End Caps and Geometry Field Name 

are not set in the Operator UI as per the documentation of Create Buffer Ring and 

Create Buffer Zones operators  

Also if the Geometry Filed name is set it doesn't seem to add the field name in the 

output  

IM-47759  Expression allowed in the 

Generate Functional 

Attributes operator errors 

out when executed  

ERDAS IMAGINE 2018 Update 2  

Open a specific Spatial Model containing a Generate Functional Attributes operator 

and click Preview  

20/02/19 11:16:45 SessionMgr(57492): ERROR: #125 from featuresvlLayerCreate  

20/02/19 11:16:45 SessionMgr(57492): ERROR: Error happened during 

compilation of the expression with message: 

System.CodeDom.Compiler.CompilerErrorCollection.  

IM-48952  The datatype in the user 

interface (UI) for a port of 

some operators isn't in 

The datatype for a port of the following operators in the UI is 

HexagonGeospatial.FeaturesAnalysis.FunctionalAttribute. Whereas in the OLH it is 

IMAGINE.FunctionalAttribute.  
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sync with OLH.  * SummaryAttribute1 port of Summarize Related Features operator  

* Functional Attribute1 port of Generate Functional Attributes operator  

* Functional Attribute port of Define Functional Attribute operator  

* SummaryAttribute1 port of Merge Features operator  

UI and OLH for these operators should be in sync.  

IM-48349  Running “Raster Statistics 

per Feature” operator is 

hanging and eventually 

crashing ERDAS 

IMAGINE  

Customer reported that they tried to run the “Raster Statistics per Feature” operator 

to get the mean value of a polygon. When they run the process, ERDAS IMAGINE 

is hanging and eventually crashing.  

IM-48363  Input calibrated files are 

incorrectly placed in output 

PDF by Create Geospatial 

PDF operator  

Run specific Spatial Model.  

Open the output pdf file.  

Observe output of ERDAS IMAGINE 2018 Update 2 are incorrectly placed.  

Valid output is created in ERDAS IMAGINE 2016 only.  

IM-41134  Progress bar stays at 0% 

when running Machine 

Learning operators  

All Python-based Machine Learning operators have this problem.  

IM-46592  Executing Machine 

Learning (ML) Process 

-session log pointing to 

unknown classification 

server  

1.Launch ERDAS IMAGINE 2018 Update 2 and change to Machine Learning 

Layout.  

2.Select ML Train and train a model by collecting image chips for a few classes.  

3.Now select ML Process tab, create a Project and try to execute the ML Process by 

selecting the model created in step2.  

4.Observe that session log showing classification server pointing to 

C:/tf_jenkins/workspace/rel-win/M/….etc. This does not exist in the system.  

NOTE: In this work flow execution was success and classification done.  

Session log:  

22/10/18 15:15:51 C:/Program Files/Hexagon/ERDAS IMAGINE 

2018/bin/x64URelease/MachineLearningProcessChain.exe 

d:/2018/19-10-2018/lauoutproject2.mlp 1 Run 1  

22/10/18 15:15:57 SessionMgr(3436): Starting classification server process...  

22/10/18 15:16:27 SessionMgr(3436): Classifying 

C:/Users/agangumo/AppData/Local/Temp/SPATIAL_MODELER-5ec4-774c-9a62-

155a-009920/cc4ac0f0-17a9-492c-ba2c-92a297e68855img  

22/10/18 15:16:27 SessionMgr(3436): classification server: 2018-10-22 

15:16:27.207485: I 

C:¥tf_jenkins¥workspace¥rel-win¥M¥windows-gpu¥PY¥35¥tensorflow¥core¥platfo

rm¥cpu_feature_guard.cc:140] Your CPU supports instructions that this 

TensorFlow binary was not compiled to use: AVX2  

22/10/18 15:16:27 SessionMgr(3436): classification server: 2018-10-22 

15:16:27.539761: I 

C:¥tf_jenkins¥workspace¥rel-win¥M¥windows-gpu¥PY¥35¥tensorflow¥core¥comm

on_runtime¥gpu¥gpu_device.cc:1212] Found device 0 with properties:  

22/10/18 15:16:27 SessionMgr(3436): classification server: name: Quadro M1200 

major: 5 minor: 0 memoryClockRate(GHz): 1.148  

22/10/18 15:16:27 SessionMgr(3436): classification server: pciBusID: 0000:01:00.0  

22/10/18 15:16:27 SessionMgr(3436): classification server: totalMemory: 4.00GiB 

freeMemory: 3.35GiB  

IM-47764  Doc: Classify using 

machine learning has a 

limitation on raster data 

type that needs to be 

Raster Classification using Machine Learning fails if the data has No Data set or if 

the data type is Double. Here is the error message from the session log.  

12:16:13 SessionMgr(9000): Input contains NaN, infinity or a value too large for 

dtype('float32').  
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documented  

IM-47505  Initialize Inception operator 

performs validation test 

even when no data is set 

aside for validation  

It seems Initialize Inception always performs validation even when no data is set 

aside for validation. With Validation percentage set to zero, I still get some 

percentage values.  

In the session log, I see this  

Step 99: Validation accuracy = 84.0(N=100)  

This should not be the case if I have not reserved any data for validation.  

IM-43613  Criteria Selection on the 

Probability field in Machine 

Learning Layout crashes 

ERDAS IMAGINE  

On the File tab, change to the Machine Learning Layout  

Load a project that you've already trained and classified.  

Load the results.  

In the Change Likelihood Rank panel right click in the Row column and select 

Criteria...  

Use the Selection Criteria dialog to specify $"Probability" > .5  

Click Select.  

ERDAS IMAGINE crashes  

IM-42556  Session log records a 

warning message when 

running a model consisting 

of Machine Learning 

operators  

Steps To Reproduce:  

(1) Create a valid model with any of the Machine Learning operators.  

(2) Run the model  

Observation:  

Session log records a warning message as below:  

{color:#d04437}11/12/17 13:54:21 eWkspace_64(17412): WARN 

com.hexgeo.smsdk.spatialmodeler.core.Data - SizeInBytes must be implemented 

for data type: IMAGINE.FeatureSubset{color}  

IM-42504  Zonal Max operator does 

not support float data  

Zonal Max operator only outputs integer data. This causes a problem if the input is 

data type is float - the output values lose precision. It really causes a problem if the 

input data type is float and the values are negative - the Zonal Max always outputs a 

value of 0 instead of the true negative zonal max value.  

Whereas the Zonal Attributes tool (Save Zonal Statistics To Polygon Attributes) 

outputs correct zonal max floating point values.  

IM-42614  Select Attributes is 

throwing an error dialog on 

removing all the attributes 

from the included list  

Steps to reproduce:  

(1) Create a spatial model as follows:  

Feature Input > Select Attributes > Initialize Naive Bayes > ...  

(2) In 'Feature Input' select any shapefile that has some attributes defined.  

(3) On 'Select Attributes' operator double-click on the 'AttributeNames' port to bring 

up Select Attributes dialog.  

(4) From the 'Available Attributes' list add couple of attributes to the 'Included 

Attributes' list.  

(5) Once the attributes are listed in the 'Included Attributes' list, remove both the 

listed attributed by clicking "<" tool bar icon.  

Observation:  

(6) An error dialog is thrown when the last attribute from the list is removed  

Session log records:  

_{color:#d04437}13/12/17 12:43:42 SessionMgr(4132): ERROR: #223 from 

ScrollList::SelectByPos(){color}_  

_{color:#d04437}13/12/17 12:43:42 SessionMgr(4132): ERROR: 

eeml_ScrollListSelectByPos failed{color}_  

_{color:#d04437}13/12/17 12:43:42 SessionMgr(4132): ERROR: #2 from 

eeml_ScrollListSelectByPos{color}_  

_{color:#d04437}13/12/17 12:43:42 SessionMgr(4132): ERROR: Scrollist has no 

members in the set!{color}_  

IM-48617  Convert to Surface Convert to Surface fails if it is used in combination with other point cloud operators.  
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operator fails if it is used in 

combination with other 

point cloud operators  

But if the intermediate result is saved to a file and the file is then used as an input to 

convert to surface operator, it works fine.  

IM-48885  Stack Max operator does 

not output correct value if 

the input is a negative 

floating point number  

Stack Max operator always returns a value of 2.22507e-308 if the input value is 

negative and the data is 64-bit floating point. It returns a value of 1.17549e-038 if 

the input is 32-bit floating point data.  

These are not the correct values. 2.22507e-308 is the maximum value for the 

floating point 64-bit data and 1.17549e-038 is the maximum value for the floating 

point 32-bit data.  

Stack Max operator provides the correct output value if the input is a negative 8-bit 

or 16-bit value. This problem does not occur with ERDAS IMAGINE 2016 Update 1.  

IM-46535  Measure Area is affecting 

the geometries (some 

large holes are being filled)  

ERDAS IMAGINE 2018 Update 2  

A Spatial Model was built which takes an input shapefile, merges features and then 

measures the Area of each feature.  

The result of the merge appears to be correct, but the result of the subsequent 

Measure Area are wrong - large holes in the original geometries have been filled 

(i.e. removed).  

Measure Area should not affect the geometries at all!  

Measure Perimeter has the same effect on the geometries.  

Also tried Measure Length and Measure Center and they all modified the output 

geometries.  

As a workaround, use Generate Functional Attributes again.  

IM-49761  Spatial Model changes 

datum of input feature data  

When processing input feature data that are projected to Lambert Conformal Conic 

with the datum “MGI AT (EPSG: 1618)”, the output features and raster data have a 

different datum, which causes a shift of approximately 300 meters in the X-direction. 

The output features data are assigned the datum “MGI”. The output raster data is 

assigned the datum “Militar-Geographische Insttut [To WGS 84 8]”.  

IM-44602  Producing ER Mapper 

(*.ers) file from vector file 

throwing error in ERDAS 

IMAGINE 2018  

1.Launch ERDAS IMAGINE 2018  

2.Launch Spatial Model Editor, create model Features Input > Convert to Raster > 

Raster Output  

3.Provide the input as *cities.shp* and output raster as *ermapp.ers*  

4.Run the model and observe an error thrown Vector<T> too long  

IM-46625  One extra port 

(Expression) shown for the 

operator Point Cloud Build 

Selection Criteria operator 

in UI  

1.Launch ERDAS IMAGINE 2018 Update 2, launch Spatial Model Editor  

2.Drag Point Cloud > Build Selection Criteria operator to Spatial Model Editor.  

3.Check ON show all ports, observe Expression port present. This is not explained 

in Help.  

IM-46381  OLH Default values 

disagree with Filter By 

Geometries operator  

1.Launch ERDAS IMAGINE 2018 Update 2  

2.Launch Spatial Model Editor from File > New  

3.Drag Filter By Geometries operator to Spatial Model Editor  

4.Click SpatialOperator port and observe default value is set to Meet but OLH says 

default value is Touch  

IM-39578  Convolve a F32 DEM 

using non-normalised 

Kernel, fails with Unable to 

allocate OpenCL Image 

message  

Open specific spatial model in the Editor.  

Click Run  

See these messages in the Message panel and the model fails to run:  

Unable to allocate OpenCL Image  

Unable to allocate OpenCL Image  

Unable to allocate OpenCL Image  

Unable to allocate OpenCL Image  

Unable to allocate OpenCL Image  

Unable to allocate OpenCL Image  
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Unable to allocate OpenCL Image  

Unable to allocate OpenCL Image  

If you change the Input Raster from Native Type to Float (which should be the 

same) the model runs successfully.  

Or, you can leave it as Native Type, but change Normalize to True on the input 

kernel. That works as well.  

Note – if you close ERDAS IMAGINE after attempting (and failing) to run this model, 

you get a Runtime Error.  

IM-45023  Initial input values in 

Spatial Model Editor 

causes errors  

Spatial Modeler reports an error on initial inputs.  

Test Model is in: ¥¥alpha¥JIRA_data¥IM-45023  

Open Spatial Modeler  

Scenario 1:  

# Load model from above folder  

# Run model  

# When the dialog opens, press "OK" without changing any values.  

# Output should report an error.  

IM-45259  Slope to NTF give errors in 

the session log  

Run a specific Spatial Model which generates slope from a DEM and outputs to 

NITF format. Notice the errors in the session log:  

09/07/18 11:14:43 SessionMgr(18828): ERROR: #22935 from 

eimg::details::SSLayerGetNames  

09/07/18 11:14:43 SessionMgr(18828): ERROR: <NULL> failed  

09/07/18 11:14:43 SessionMgr(18828): ERROR: #67 from <NULL>  

09/07/18 11:14:43 SessionMgr(18828): ERROR: eimg_FileImageNamesGet failed  

09/07/18 11:14:43 SessionMgr(18828): ERROR: #14930 from 

eimg_FileImageNamesGet  

09/07/18 11:14:43 SessionMgr(18828): ERROR: eimg_FileOpen failed  

09/07/18 11:14:43 SessionMgr(18828): ERROR: #5968 from eimg_FileOpen  

09/07/18 11:14:43 SessionMgr(18828): ERROR: c:/work/output.ntf.r2: 

eimg_FileOpen failed (33:Unsupported Raster format or non-Raster format)  

It looks like when outputting NITF in this case, we try to compute stats while 

generating RSETs, which tries to open the RSET as it's being generated (and fails). 

It doesn't seem to negatively affect the process though.  

IM-46858  Rename Attributes does 

not work  

Open a specific Spatial Model desinged to take an input shapefile, attempts to 

rename one of the attribute fields and write out a new shapefile.  

However if you click Preview (or Run) you'll get this error:  

Spatial Model failed in Rename Attributes. The error was  

"HexGeo::SpatialModelerFeatures::Feature::TransferFieldValue  

failed Unsupported field type".  

IM-46567  OLH Default values 

disagree with Compute 

Affine Coefficients 

operator  

1.Launch ERDAS IMAGINE 2018 Update 2  

2.Launch Spatial Model Editor from File > New  

3.Drag Compute Affine Coefficients operator to Spatial Model Editor  

4.Observe default value set for Scale X ,Scale Y ports are 0 but OLH says default 

values are 1  

IM-46565  OLH Default values 

disagree with APM 

Parameters operator  

1.Launch ERDAS IMAGINE 2018 Update 2  

2.Launch Spatial Model Editor from File > New  

3.Drag APM Parameters operator to Spatial Model Editor  

4.Observe default value set for PointsPerImage port is 25 but OLH says default 

value is 9  

IM-46762  Some LAS inputs cause 

the Classify Ground 

Operator to crash ERDAS 

Classify Ground operator causes ERDAS IMAGINE to crash with some point cloud 

input files. The cause of the problem has been identified with using point cloud files 

small enough not to need tiling.  
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IMAGINE  After a crash you may see a session log error that looks like:  

14/11/18 09:22:16 SessionMgr(4972): Executing spatial model: 

//cheryltest/sfdc/00036404_cloud_crash/classifyground/groundpoints.gmdx  

14/11/18 09:25:45 SessionMgr(4972): external process exited with status 

-1073741819.  

IM-46705  Spatial Model failed in Add 

Attribute By Order  

Customer submitted a model where errors are reported at the Add Attribute By 

Order operator. Tests indicate the source of the errors may be coming from how the 

Filter By Geometries Operator is sending the temporary output to the next operator.  

31/10/18 13:47:05 SessionMgr(3336): ERROR: #2348 from 

HexGeo::SpatialModeler::Operator::InternalApply  

31/10/18 13:47:05 SessionMgr(3336): ERROR: 

HexGeo::SpatialModeler::Operator::SetErrorMessage failed  

31/10/18 13:47:05 SessionMgr(3336): ERROR: #1985 from 

HexGeo::SpatialModeler::Operator::SetErrorMessage  

31/10/18 13:47:05 SessionMgr(3336): ERROR: Spatial Model failed in Add Attribute 

By Order. The error was "Table count 209 does not match FeaturesIn count 14.".  

31/10/18 13:47:06 SessionMgr(3336): Table count 209 does not match FeaturesIn 

count 46.  

IM-48093  Add Attributes by Location 

does not accept just DN 

values  

Add Attributes by Location seems to rely on there being an attribute table present 

on the raster stream. Whereas, frequently there will not be if the raster stream has 

been generated as part of the model.  

Open specific Spatial Model in a Spatial Model Editor  

Click Run.  

Note that the second Add Attributes by Location fails with a message "can't find 

attribute table"  

The only difference between the two Add Attributes by Location operators is that in 

the second one, the input raster stream has been multiplied by 2, thereby 

invalidating its attribute tables (but still having DN values).  

If instead you attach the output of Attach Attributes to the Related Data port of Add 

Attributes by Location 2, it runs successfully.  

Help states that DN values should be supported. It needs to be.  

IM-48392  Add Attributes By Location 

operator fails with float 

values  

Add Attributes By Location operator fails when the input raster is of float data type.  

9/04/19 17:46:18 SessionMgr(23780): ERROR: #1985 from 

HexGeo::SpatialModeler::Operator::SetErrorMessage  

09/04/19 17:46:18 SessionMgr(23780): ERROR: Spatial Model failed in Add 

Attributes By Location. The error was "HexGeo::SpatialModeler::Typedefs<class 

HexGeo::SpatialModeler::Data>::CastRef failed  

09/04/19 17:46:18 Unable to cast a class HexGeo::SpatialModeler::Data to a struct 

HexGeo::SpatialModeler::DoubleData".  

IM-18871  ERDAS IMAGINE crashes 

while saving read-only 

Spatial Model  

Open a read-only Spatial Model file  

Add a new operator to the Spatial Model  

Click on the Close button of Spatial Model Editor  

Click Yes button of 'Verify Save on Close' Dialog  

Observe that ERDAS IMAGINE crashes  

IM-46622  ERDAS IMAGINE crashes 

with ICA operator if Count 

exceeds number of bands  

1.Launch ERDAS IMAGINE 2018, launch Spatial Model Editor  

2.Connect a Model as Raster Input > ICA  

3.Provide inputs  

* Raster Input : sub4road1.img (a 3 band image) from examples > Objective  

* Count : 16  

* Sort Method: ICASORT_SKEWNESS  

4.Click Run to execute model , observe ERDAS IMAGINE crashes.  
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IM-46536  ERDAS IMAGINE crashes 

while creating Geometry 

using Create Bounding 

Box operator  

1.Launch ERDAS IMAGINE 2018 Update 2  

2.Launch Spatial Model Editor and open specific Spatial  

3.Click on preview and observe ERDAS IMAGINE crashes.  

IM-34996  Convert to Features output 

does not carry the 

attributes of the input if 

"IsClumped" option is OFF  

ERDAS IMAGINE 2016 Update 1  

- Give Lnsoils.img from the example data as an input to *Convert to Features* 

operator and generate an output using the default options.  

- Open the output shapefile in the viewer and check the Attribute table.  

Notice that the attributes from the input thematic image are missing.  

Repeat the same with the "IsClumped" option ON and notice that the attributes are 

carried to the output.  

IM-49241  Add Attributes By Location 

takes wrong values if no 

related data found  

If the operator Add Attributes By Location cannot find a suitable object to fill 

attributes, the attributes of the object with previous Primary Key value are taken to 

fill the attribute table. This is wrong. The entry should stay empty instead.  

IM-49459  Update Statistics operator 

not properly setting skip 

factors, exclude values, 

etc.  

Update Statistics operator is not writing the correct Statistics Parameters and 

Histogram Parameters (skip factors, exclude values, bin function, and AOI) to the 

image layers.  

It's writing out the default values, not what was actually used for the stats.  

IM-49456  Add Attributes by Location 

operator causes ERDAS 

IMAGINE to exit  

ERDAS IMAGINE 2018 Update 2  

See specific Spatial Model  

Open the model in Spatial Model Editor  

Double-click the <StringList> port on the Add Attributes by Location operator. This 

should open a dialog enabling you to select attribute names  

ERDAS IMAGINE exits.  

IM-48930  Least Cost Path model 

hangs  

See the data and model available here:  

https://community.hexagongeospatial.com/t5/Spatial-Modeler-Tutorials/Calculating-

a-Least-Cost-Path-using-a-DEM/ta-p/6115  

In ERDAS IMAGINE 2016 v16.1 you can open this model in the Spatial Model 

Editor and run it to completion in about 4 minutes.  

If you try to do the same in ERDAS IMAGINE 2018 it just hangs in the Least Cost 

Path operator.  

IM-46540  Density Interpolation 

operator throwing error in 

combination with Create 

Center Point operator  

The problem is with the way the Density Interpolation operator interprets the primary 

geometry field of the input features. Output features from the Create Centerpoint 

operator contain 2 geometry fields, the original input areas and the newly created 

centerpoints. The operator also correctly sets the primary geometry to 

GC_Centerpoint, which can be proven by passing features into the Features 

Information operator and observing the PrimaryGeometryFieldName port.  

When passing features directly from Create Centerpoint to Density Interpolation, the 

Density Interpolation operator incorrectly attempts to use the original area geometry 

field "Geometry" presumably because it appears first in the list.  

IM-44641  Rapid Atmospheric 

Correction tool does not 

pass calibration file to 

Spatial Model  

The calibration file is not getting passed from the Rapid Atmospheric Correction tool 

to the Rapid Atmospheric operator in the Spatial Model. When you try to run the 

tool, the process fails. Session log reports the error "No input file available".  

To work around this problem, click the View button in the Rapid Atmospheric 

Correction tool and it opens the spatial model. Double-click on the 

CalibrationFilename input port for the Rapid Atmospheric operator and select the 

calibration file, then run the spatial model.  

IM-47466  Performing a sort on a 

Features Table column in 

Connection Manager 

dialog crashes Spatial 

A crash of the Spatial Model Editor application occurs when the Connections 

Manager dialog is used to make a proxy file connection (for Oracle, PostGIS, or 

SQL Server) if the Feature Tables list is then sorted (by selecting the ‘Name’ column 

and choosing the ‘Sort A..Z’ or ‘Sort Z..A’ option).  
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Model Editor  

IM-46722  Previewing a raster with 0 

rows and 0 columns 

crashes ERDAS IMAGINE  

After analyzing why a customer's Spatial Model was crashing, in the end tracked it 

down to an error defining the output pixel dimensions that resulted in an output 

raster with no rows or columns. Previewing this crashes ERDAS IMAGINE.  

IM-35174  Raster (Color) Attribute 

Output wipes Color Table 

with u8 output  

See model attached.  

You can use Bands 4 and 3 from a Landsat dataset such as this one:  

¥¥alpha¥ARRAY5¥Cherokee County Data¥Landsat¥New Landsat Data¥Landsat 5 

May1997  

Open the model in Spatial Model Editor.  

Click Run.  

Leave Stretch flag set to False (so you'll get floating point NDVI results), fill in the 

input images, click OK.  

Open the resulting image file as PseudoColor.  

Results look good (dark to light green color ramp is applied – let’s ignore the fact 

that it seems to have created a valid color for NoData).  

Click Run again and give a different output file name.  

Change Stretch flag to True (to give u8 output).  

Open the resulting image file as PseudoColor.  

The image is displayed all black because the colors applied to each class are all 

black.  

IM-35173  Attach (Color) Attributes 

does not work with 

Floating Point output  

Open a specific Spatial Model in Spatial Model Editor.  

Click Preview.  

Leave Stretch flag set to False (so you'll get floating point NDVI results), fill in the 

input images, click OK.  

Results look good (dark to light green color ramp is applied).  

Click Run.  

Open the resulting image file as PseudoColor.  

No color ramp was saved to the output file (so it does not look the same as the 

Preview)  

IM-47841  RGBtoIHS causes stats 

problem when data is out 

of specified range  

A Spatial Model was build which performs a RGB to IHS on an input 8-bit RGB 

image. However, the actual data range of the input image exceeds the specified 

Max values on the RGB to IHS operator, causing problems in a subsequent 

Statistics operator.  

 

IM-47534  Preview of DirectLookup 

not behaving well when 

Table is a color table  

* Build a Model like this with a Thematic input image:  

 

* Click Preview  

* On the Multispectral tab, try changing the band combination. Notice that nothing 

happens.  

* Select the Panchromatic Image Chain. You'll get red Xs.  

IM-46904  NDVI model from the 

Ribbon GUI ignores the 

‘stretch to Unsigned 8 bit’ 

option  

Running NDVI from the ribbon gui does not produce a properly rescaled image 

when using ‘Stretch to Unsigned 8 bit’. The output value range is 0 – 1.  

After selecting the *Stretch to Unsigned 8 bit* option from the I/O options tab, the 

default spatial model opened from the NDVI dialogue's View button has the 

StretchFlag value in the Properties dialogue set to Integer (0) and produces the 

same unexpected result. If you change the StretchFlag value to Integer (1), the 

model rescales the output image to a 8 bit value range that appears to be correct.  
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IM-48405  Remove Item fails when 

DataIn is a Table  

Remove Item operator says that it supports "Dictionary, List (of Data), and Data" for 

DataIn. There's a TableToList conversion, so you'd think that you could remove 

items from a Table.  

But it fails, even though the connection is not shown in red.  

IM-48058  Example 2 missing from 

Spatial Modeler Guide  

Apparently this got lost. All the current Guide says is "Example 2: Load/Save/Edit a 

Spatial Model".  

IM-49513  Feeding an AOI to 

Features Input causes 

ERDAS IMAGINE to exit  

ERDAS IMAGINE 2018 Update 2  

Start Spatial Model Editor  

Add a Features Input operator  

Double-click the input port  

In the File Chooser select the All Files (*.*) filter option  

Select an .AOI file and OK the file Chooser  

Click Run  

ERDAS IMAGINE exits.  

IM-49575  ERDAS IMAGINE crashes 

with model containing 

Update Attribute operator  

1.Launch ERDAS IMAGINE  

2.Launch Spatial Model Editor and Load the model and click on Preview.  

 

3.Observe ERDAS IMAGINE crashes.  

IM-47233  Set Primary Geometry 

operator UI does not 

present all available 

geometry fields with IFC 

format  

Attempted to use Set Primary Geometry to select a geometry field in a model but 

was unable to select the field via the dialog, entering it manually worked fine. The 

model uses Generate Functional Attributes to create a new geometry field. This new 

field becomes primary after GFA executes.  

Wanted to use Set Primary Geometry to set the original geometry field back to 

primary. However, it was not in the drop down list on the UI.  

IM-49844  Convert to Features 

operator fails in execution  

 

Click Preview  

Model fails in the Convert to Features operator  

IM-40485  Alert messages in Python 

while running Spatial 

Model containing the 

Generate Surface operator  

Customer reported that when running a python script that is using a Spatial Model 

containing the Generate Surface operator, they get alert messages about starting 

processing pyramid levels. The user had to manually click OK in order the Python 

script to process to the next pyramid levels. This continues until all the pyramids 

levels are processed.  

IM-46859  Previewing a Model 

containing Rename 

Attributes has 

scale-dependent problems  

Open specific Spatial Model in the Spatial Model Editor.  

Click Preview  

The model successfully previews the buffer "donuts" in a View  

Now zoom in in the Preview.  

At some stage the geometries stop drawing.  

Zoom back out and they re-appear.  

IM-47572  Operators do not warn if 

an inappropriate object 

type is connected to them  

The following two operators do not warn (red color connection) if an inappropriate 

object type is connected to them.  

# Initialize Deep Intellect – AddLayer1 port is expecting a Dictionary object type. But 

it does not warn if any other object type is connected to it.  

# Detect Objects Using Deep Learning – MachineIntellect port expects a 
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MachineIntellect object type. But it does not warn if any other object type is 

connected to it.  

IM-46526  Preview results from 

Convert to Surface 

operator are incorrect  

ERDAS IMAGINE 2018 Update 2  

A Spatial Model was built which takes vectors with a height attribute and runs them 

through Convert to Surface and sends to a Preview.  

Click Preview  

At first the results may appear correct. But if you zoom in to the area that has been 

interpolated, the results chop and change - sometimes large gaps appear, 

sometimes almost all the interpolated values disappear, etc.  

Also, when you open the Inquire Cursor, it reports NoData for the interpolated 

areas.  

However, when you click Run and output a file of the interpolation, the results look 

fine.  

IM-49617  Error opening image with 

Elevation Info in Image 

Metadata in Spatial 

Modeler SDK  

In an installation of Spatial Modeler SDK:  

# Launch Spatial Model Editor  

# Launch Image Metadata  

# Open lndem.img in the Image Metadata tool  

Error  

10/07/19 12:34:26 imageinfo(21724): Error opening file [recalculateelevation.eml] 

for input!  

10/07/19 12:34:28 SessionMgr(11492): ERROR: #8226 from eeml_Parse  

10/07/19 12:34:28 SessionMgr(11492): ERROR: Problem in EML macrofile 

recalculateelevation.eml  

10/07/19 12:34:28  

10/07/19 12:34:28 SessionMgr(11492): ERROR: #1156 from elex_Parse  

10/07/19 12:34:28 SessionMgr(11492): ERROR: Input is empty Error processing 

unknown file at or near "Unexpected End"  

10/07/19 12:34:28 SessionMgr(11492): ERROR: #1 from eeml_Parse  

10/07/19 12:34:28 SessionMgr(11492): ERROR: Input is empty  

IM-49558  Point Cloud > Convert To 

Surface output is too small  

Both 32- and 64-bit versions of the operator are generating output files that are 

much too small, only several pixels large.  

IM-43943  Spatial Model Editor 

"hangs"  

ERDAS IMAGINE 2018 Update 1:  

Open specific Spatial Model in Spatial Model Editor.  

Scroll over until you can see the Zonal Summary Max operator.  

Right click on it and select Run Just This.  

Once it has completed left-click on the Summary operator.  

The Spatial Model Editor may immediately go "busy". If not, try to pan the model 

using the middle mouse button. At some stage the Editor decides to go "busy" for a 

minute or so. Eventually you might get control back, but left-clicking on the Zonal 

Summary Max operator sets it off again and you have to wait, again.  

IM-34174  Spatial Model operator 

Bitwise Not is giving output 

Binary(1) even if the input 

is Binary(1)  

Customer reported that when using the Bitwise operator Not, if false is input, it 

returns a true, if true is input, it returns a true.  

Steps to reproduce:  

1. Create new spatial model, drag Bitwise Not in  

2. Use true as input, change to Binary(1)  

3. Run model, output is Binary(1)  

However, using false, the result is the same.  

IM-20602  Raster Input operator is 

failing while displaying 

VMCX file pointing to PNG 

in Spatial Model Editor  

Display a VMCX file pointing to PNG using a Spatial Model (Port Input > Raster 

Input > Preview). Randomly Raster Input Operator is failing (cross mark).  
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IMAGINE Terrain Editor 

Issue ID  Summary – IMAGINE 

Terrain Editor  

Description / How to Reproduce  

IM-42325  Recalculate Elevation for 

Images no longer offers 

millimeters as an elevation 

unit  

Users need the ability to change elevation height units to millimeters. This cannot 

be done with the Recalculate Elevation for Images tool found under the Terrain tab 

(Manage group) or within the Image Metadata tool (or the Image Commands tool).  

IM-41348  Geomorphic Edits not 

saved  

In some cases when applying geomorphic edits, they are not being saved. This 

seems to happen randomly but more often when one closes the Terrain Editor 

dialog and clicking the save button from the popup dialog when prompted to save 

the changes.  

IM-31142  Move AOI Home icon is 

changed in Terrain Editor  

Launch ERDAS IMAGINE.  

Load a block file having DEM.  

Launch Terrain Editor.  

Go to Terrain Files and Display tab > Area of Interest section > Navigation > Center 

icon i.e 'Move AOI Home' icon is changed from house symbol to dot.  

IM-46872  Unknown characters 

shown on Button Mapping 

Window Title  

1.Launch ERDAS IMAGINE 2018  

2.Load any photogrammetric project  

3.Launch Terrain Editor window.  

4.Launch Button Mappings from Edit > Devices > System Mouse  

5.Observe that unknown characters shown on Button Mapping Window Title.  

IM-46903  Terrain Editor produces 

errors when editing 

geographic LTFX DTMs  

When points of a geographic LTFX DTM are edited with the Terrain Editor in a 

geographic projection blockfile, the changes are very often not saved. The effect 

could not be observed using UTM LTFX DTMs generated within a UTM blockfile.  

IM-47462  Terrain Prep Tool cannot 

merge two overlapping 

LAS files using both Thin 

and Filter preprocessing 

options  

If you try to create a DEM from two overlapping LAS files using either the Surface 

process (Rasterization) or the Merge process, it fails at the merge step if both the 

Thin and Filter preprocessing options are enabled. If you only use one of the 

preprocess settings (Thin or Filter) it works as it should.  

IMAGINE Expansion Pack – 3D 

Issue ID  Summary – IMAGINE 

Expansion Pack 3D  

Description / How to Reproduce  

IM-48196  ERDAS IMAGINE crashes 

while selecting Digitize 

Flight Path with Tablet in 

3D view  

1.Launch ERDAS IMAGINE (64-bit)  

2.Close 2D view and create new 3D View  

3.Select Scene tab and launch Flight Path Editor from Navigation group  

4.Select New Configuration from Flight Path Editor > Utility > Digitize Flight Path 

With Tablet  

5.Observe ERDAS IMAGINE crashes.  

IM-45759  Unable to Start Movie 

Recording of type 

Microsoft AVI in 3D view, 

as file was defaulting to 

a .mpg extension  

1.Launch ERDAS IMAGINE 2018 Update 2  

2.Close 2D View and launch 3D View from Add views > Create New 3D View  

3.Load data  

4.Click on Start button from Scene tab > Recording  

5.Provide the output movie file as test.avi.  

6.Click OK and observe a dialog opens. Unable to start Movie recording. This is not 

the case with File of type IMAGINE Movie (*.mov)  



ERDAS IMAGINE 2020 Update 1 

 
 
 

2019年 10月 30日 95 

IMAGINE Expansion Pack – AutoSync 

Issue ID  Summary – IMAGINE 

Expansion Pack 

AutoSync  

Description / How to Reproduce  

IM-47057  AutoSync not displaying 

coordinates legibly  

Start AutoSync workstation and load a specific project.  

Points have already been generated.  

Try to read the coordinates - you cannot because the significant digits have been 

displaced off the left side of the columns.  

IM-47056  AutoSync not recognising 

RPC model as being valid  

See the Community thread here:  

http://community.hexagongeospatial.com/t5/Spatial-Modeler/autosync-automatically

/m-p/29178/highlight/false#M518  

Start AutoSync workstation and load a specific project.  

Points have already been generated so click the Sigma button to try to solve the 

RPC models the input images are calibrated with.  

Error  

Invalid output geometric model  

IM-45119  AutoSync workstation 

crashes while creating 

GCP with single input 

image  

1.Launch ERDAS IMAGINE and launch Autosync Workstation  

2.Create a Project as Georeference workflow  

3.Provide input image as residential.image from Examples > Objective  

4.Click on Create GCP button and Click on input image and observe AutoSync 

crashes.  

IM-46612  AutoSync CellArray 

displays values with 

incorrect formatting  

ERDAS IMAGINE2018: AutoSync CellArray format displays coordinate values in the 

cell array that are not right justified and contain an excessive number of decimal 

places.  

Autosync 2016 displays the cell array values as expected.  

Coordinate values are represented 8 decimal places.  

Residual values are represented with 16 decimal places.  

Compare with Autosync 2016. The numerical values are right-centered with the 

coordinate values represented with 3 decimal places and the Residual values 

represented with 6 decimal places.  

IM-47855  Run APM does not do 

anything in AutoSync 2018 

with data in custom datum 

and projection  

Customer is using a custom datum and projection in Autosync for georeferencing 

ZY3 sensor data. According to the customer in ERDAS IMAGINE 2018 with Update 

1 or 2, Autosync is unable to start the “Run APM” . The session log gives the 

following error message:  

28/02/19 16:09:47 SessionMgr(13104): WARNING! The two images do not overlap 

with each other, output may not be generated.  

The problem does not occur if ERDAS IMAGINE 2018 without Updates is used.  

IMAGINE Expansion Pack – NITF 

Issue ID  Summary – IMAGINE 

Expansion Pack NITF  

Description / How to Reproduce  

IM-45772  SNIP NITF: 1.5 minutes to 

display image  

ERDAS IMAGINE 2018 Update 2  

Start ERDAS IMAGINE  

Click the File icon on the Quick Access Toolbar.  

Select a SNIP RIP .ntf file  

Go to the Sub-images tab.  

Click on the Multi checkbox.  

On my computer it took 2 minutes before I regained control of the File Chooser.  

Once you can, click OK to display the image.  
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On my computer it took 1.5 minutes until the image displayed (at 1:1)  

IM-45773  SNIP NITF: 26s to change 

a band  

ERDAS IMAGINE 2018 Update 2  

Start ERDAS IMAGINE  

Click the File icon on the Quick Access Toolbar.  

Select the SNIP RIP .ntf file  

Go to the Sub-images tab.  

Click on the Multi checkbox.  

Once the image is displayed go to the Multispectral tab and select a different 

band for the Green color gun.  

On my system it took 26s for the new band to display.  

IM-45771  SNIP NITF: 2 minutes for 

File Chooser Sub-image 

tab to respond  

ERDAS IMAGINE 2018 Update 2  

Start ERDAS IMAGINE  

Click the File icon on the Quick Access Toolbar.  

Select the SNIP RIP.ntf file  

Go to the Sub-images tab.  

Click on the Multi checkbox.  

On my computer it took 2 minutes before I regained control of the File Chooser.  

IM-45777  SNIP NITF: 5 minutes to 

open ImageInfo  

ERDAS IMAGINE 2018 Update 2  

Start ERDAS IMAGINE  

Click the File icon on the Quick Access Toolbar.  

Select the SNIP RIP.ntf file  

Go to the Sub-images tab.  

Click on the Multi checkbox.  

On my computer it took 2 minutes before I regained control of the File Chooser.  

Once you can, click OK to display the image.  

On my computer it took 1.5 minutes until the image displayed (at 1:1)  

Once the image is displayed click the ImageInfo button.  

On my system it took 5 minutes and 30s for ImageInfo to come up and populate 

with information (for one band).  

Each time you change band it takes another 5 minutes.  

IM-49812  Chipping errors likely 

caused by delayed 

TRE/DES parsing  

In ERDAS IMAGINE 2018 Update 2 it was discovered that NITF chipping of 

various classified data was erroring out. This same behavior did not occur with 

earlier versions. It also did not occur when the DPM was uninstalled. [~bshelley] 

traced this down in the debugger to the presence of TRE/DES in the data that 

had delayed parsing implemented in the DPM for Update.  

ERDAS IMAGINE Installation 

Issue ID  Summary – ERDAS 

IMAGINE Installation  

Description / How to Reproduce  

IM-48920  ArcGIS Geodatabase 

Compatibility Table in OLH 

should be updated with 

10.6 and 10.6.1  

ArcGIS Geodatabase Compatibility Table in OLH should be updated with 10.6 and 

10.6.1 (supported versions)  

The table shows support till 10.5.1  

IM-46782  Borrowing XML does not 

include IMAGINE SAR 

Feature  

The XML file that controls the dependencies for Borrowing does not seem to include 

the IMAGINE SAR Feature module:  

"C:¥ProgramData¥Intergraph¥Licensing¥Borrowing¥IMAGINE2018.xml"  
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IM-43159  Undesirable auto CSM 

configuration behavior  

Observed in ERDAS IMAGINE 2018.  

The utility configure_all.exe now also automatically configures several CSMs 

delivered with the software (for 32 bit SICD,SIDD,VM sensor models, for 64 bit 

SICD,SIDD sensor models). This behavior is undesirable for the following reasons:  

(1) If CSMs were already configured by the user, most likely they are in a different 

location than the "Imagine native" CSMs. When both are in place, get a Warning 

window complaining that the "Data directory for CSMs" cannot be set to two 

locations.  

(2) ERDAS IMAGINE 2018 displays a Message window recommending that 32 and 

64 bit CSM configurations be the same. But this auto CSM configuration does not do 

this (the VM sensor model is only configured in 32 bit).  

(3) If the user had already configured SICD and SIDD sensor models, their 

configuration is overwritten by the "native CSMs".  

IM-43327  Unnecessary install 

directories  

For some reason there are several new directories included with ERDAS IMAGINE 

2018 that weren't there before (and aren't necessary for the software to run)  

IM-48028  The following files don't 

have a valid signature  

The following files that don't have a valid signature,  

* hdf.dll  

* mfhdf.dll  

IM-37464  SIX CSM is not 

automatically configured 

on startup  

SIX CSM is not automatically configured on installation.  

IM-49536  Setup-Manager GUI is 

messed up on my Virtual 

Box with German OS  

With eRDAS IMAIGNE 2018 onwards the Setup Manager (installer) the GUI is 

messed up on machine with a German OS. It seems to have some (unexpected, 

undesired) links to the right of the tree view where you select the product that are not 

there on a system with English OS.  

ERDAS ER Mapper 

Issue ID  Summary –ERDAS ER 

Mapper  

Description / How to Reproduce  

IM-40262  When Big ERS files are 

compressed in ER Mapper 

into ECW v3, it outputs into 

a completely different and 

bad looking image  

Problem replicated with big ERS files, including that of the customer. ER Mapper 

is actually compressing the big ERS file with an extremely high compression 

ratio. Actual Compression ratio more than 500, even if the target compression 

ratio was just 2 or 3.  

When compressing the ERS file into JPEG 2000 format, the problem does not 

happen. Also, when using ERDAS IMAGINE ECW Exporter, that problem does 

not happen for ECW v3. Therefore, the problem seems to be only in ER Mapper 

ECWv3 exporter.  

IM-45954  Execution of creating 

rotated tiff file is terminated  

ERDAS ER Mapper 2018  

Go to Toolbars > Common Functions > Ortho and Geocoding Wizard.  

Input file: -Copy file to a new 

location:...¥examples¥ermapper¥applications¥airphoto¥1_geocoding¥ San_Die

go_Airphoto_34_rectified.ers and San_Diego_Airphoto_34_rectified.  

Geocoding type: Rotation  

Go to Rotation Setup tab, Rotation angle: 45  

Go to Rectify Tab specify output file and write to tif. and select Save file and Start 

Rectification.  

Observe process is terminated, whereas execution is successful for .ers, ECW  

IM-48647  Regions to Vectors and 

Vectors to Regions 

Conversion commands 

1) Launch ER Mapper > Toolbars > Classification Toolbar  

2) Launch Regions to Vector conversion / Vector to Regions conversion 

command  
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Help are pointing to Raster 

to Vector conversion Help 

page  

3) Click on Help button  

Observe that it navigates to Raster to Vector conversion help page  

PRO600 

Issue ID  Summary – PRO600  Description / How to Reproduce  

IM-46078  CALSPOT not working on 

PRO600 2018 Installation  

The collect calspot command does not seem to work, and the PRO600 Library 

settings seem to match the help file for calspot.  

IM-46058  PRO600 viewplex fails to 

load JPG images  

* Open a specific blockfile and attach the JPG images associated with it.  

* Launch Terrain Editor and load the image pair in it.  

* Notice that the image pair is displayed fine.  

* Close Terrain Editor and launch PRO600.  

* After the viewplex is launched, try to load the image pair in the viewplex.  

Notice that an error pops up and the image pair fails to load. The same images work 

fine if converted to img. JPG images were able to load in the PRO600 viewplex fine 

with ERDAS IMAGINE 2013.  

IM-45842  PRODTM hangs for a very 

long time while trying to 

measure masspoint 

manually  

In PRO600, while trying to measure the points (mass points) in a grid in PRODTM, 

using measure tool, PRO600 / PRODTM hangs for a very long time.  

While working with the customer data, discovered:  

If import more than 20,000 points (grid 20X20 meter) from the DEM file (IMG format), 

the PRO600 hangs.  

For the same data, created a less dense grid (100X100 meter) where less than 5000 

points are imported, now the PRO600 / PRODTM works fine.  

Stereo Analyst for ERDAS IMAGINE 

Issue ID  Summary – Stereo 

Analyst  

Description / How to Reproduce  

Various  Various issues for Stereo 

Analyst for ERDAS 

IMAGINE  

・ Numerous issues have been addressed for the Stereo Analyst for ERDAS 

IMAGINE product (part of the IMAGINE Expansion Pack module) including 

the following problems/fixes:  

・ Added a new escape event so that parallel lines get stopped (when you press 

escape)  

・ Added escape to save/close buttons (This gets rid of the empty place holders 

- infinity points)  

・ Add a new check for parts (faces) that are elements attached to other 

elements, check if these are empty  

・ Stops crash when using parallel line then quitting.  

・ Clicking quickly on the start button should not cause two errors to pop-up  

・ After save as, if failure, the user can repair errors  

・ Spelling in warning dialogue for large memory use fixed.  

・ Add Element should no longer create zero points  

・ Changed precision in vertices editor (to 6 decimal points)  

・ Export features fixed  

・ Added extra verification checks on save to make sure points have at least 1 

point, lines have at least 2 and polygons have 3 or more points.  

・ Restart application when closing all layers to ensure all memory is reset.  

・ Label Added for version number  

・ Set read only flag when reading TIL files  

・ When escaping the second point of a parallel line, remove all vestiges of the 
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line and set the measured width to 0  

・ After escaping or changing feature after using parallel tool, remove the entry 

in the table  

・ If a user deletes the same face (attached element) twice, the software would 

crash  

・ Fixed drop to ground (check for NULL pointer failing)  

・ Check parts (tiles) of the file are not only there but can be opened  

・ Auto-clean for projects  

・ Remove "Infinity Point" generation when user selects to add element, but then 

does NOT add an element - i.e. escapes or chooses another feature  

・ Added new controls for the feature attributes (add standard attributes if 
preference "Add standard attributes if missing" is turned on)  

・ If attributes are added by the system, the user is informed  

・ Cleaned up feature import dialogue  

・ Cut is properly added to the undo stack  

・ Moved the check for existing to the first thing done (can’t check earlier)  

・ Reversed the order of deletion so that multiple errors within the same feature 

can be autocleaned  

・ Always clean empty faces (elements) that cannot be deleted from the 
interface  

・ Autoclean added better messages for when an error occurs on save  

・ Autoclean working consistently  

・ Extra parallel line no longer created when 3D snap is on and parallel lines are 
being drawn. 3D snap is tested on the first point (not the measured point) if no 

snap, then behave like normal  

・ Redo multiple deletes, no longer crashes  

・ Added flags to allow reads while reading (image format inside another format)  

・ Changing a vertex enables the save button  

・ Enabled delete from table (Right click in ID column delete is enabled)  

・ Header drawn correctly when no shapefile available  

・ Modified error message for missing vertices  

・ Added check for Duplicate Attributes (It was just adding 1 to the last in the list)  

・ Select does not cancel current edits  

 

・ Spelling mistake  

・ Added check for calculated box. If out of bounds don't use  

・ Fix Undo if no undo to undo  

・ Removed Error message when final shape check is done (and fails), only the 
warning message is now returned, telling the user how to correct.  

・ Fix vertex removal issue  

・ Fix selection of faces  

・ Fix undo selected face  

・ Notify user of deletion to the face / element (automated)  

・ Update error messages when checking for errors in digitizing  

・ Update (and create) function to remove orphan parts of elements  

・ Fix issue when the first part of a segment is removed  

・ Slight modification to write/check function so that the check is completed on 

all appropriate layers before any writing  

・ Cone fix  

・ New preference for Minimum number of vertices (PolyLines and Polygon)  

・ Implementation of delay (configurable) before saving  
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・ Secondary save on save error. (If an error occur when a tempv file is 

encountered, attempt the save again)  

・ Crash on Save fixed (if tempv file error created and user continues)  

・ Surface layer feature hang error (again when tempv file has been 

encountered)  

・ Bug when selecting a feature, then dropping the feature to ground and 

splitting an element group and adding a part/face all at the same time.  

・ Parrallel Line fix  

・ New Preference to save all layers or just changed layers  

・ Only save feature layers that have changed  

・ If a rename fails (tempv, temp) when saving shapefile retry up to 3 times with 
a delay (300ms) between  
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Contact Us  
https://go.hexagongeospatial.com/contact-us-today 
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Portions of the user interface copyright 2012- Telerik AD.  

Links To Third Party Websites  

This Document may provide links to third party websites for your convenience and information. Third party 
websites will be governed by their own terms and conditions. Hexagon Geospatial does not endorse 
companies or products to which it links.  
Third party websites are owned and operated by independent parties over which Hexagon Geospatial has 
no control. Hexagon Geospatial shall not have any liability resulting from your use of the third party website. 
Any link you make to or from the third party website will be at your own risk and any information you share 
with the third party website will be subject to the terms of the third party website, including those relating to 
confidentiality, data privacy, and security.  

Trademarks  

The trademarks, logos and service marks ("Marks") displayed in this Document are the property of 
Hexagon Geospatial, Intergraph or other third parties. Users are not permitted to use Marks without the 
prior written consent of Hexagon Geospatial, Intergraph or the third party that owns the Mark. "Intergraph" 
is a registered trademark of Intergraph Corporation in the United States and in other countries. Other 
brands and product names are trademarks of their respective owners.  
Find additional trademark information https://www.hexagongeospatial.com/legal/trademarks.  
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Procedure For Making Claims Of Copyright Infringement  

Notifications of claimed copyright infringement should be sent to Hexagon Geospatial by mail at the 
following address: Intergraph Corporation, Attn: Intergraph Legal Department, P.O. Box 240000, Huntsville, 
Alabama 35824.  

US Government Restricted Right  

Materials are provided with "RESTRICTED RIGHTS." Use, duplication, or disclosure of Materials by the 
U.S. Government is subject to restrictions as set forth in FAR 52.227-14 and DFARS 252.227-7013 et seq. 
or successor provisions thereto. Use of Materials by the Government constitutes acknowledgment of 
Hexagon Geospatial or Intergraph’s proprietary rights therein.  

International Use  

You may not use or export Materials in violation of U.S. export laws and regulations. Hexagon Geospatial 
makes no representation that Materials are appropriate or available for use in every country, and access to 
them from territories where their content is illegal is prohibited.  
Hexagon Geospatial provides access to Hexagon Geospatial international data and, therefore, may contain 
references or cross references to Hexagon Geospatial products, programs and services that are not 
announced in your country. These references do not imply that Hexagon Geospatial intends to announce 
such products, programs or services in your country.  
The Materials are subject to U.S. export control and economic sanctions laws and regulations and you 
agree to comply strictly with all such laws and regulations. In addition, you represent and warrant that you 
are not a national of, or otherwise located within, a country subject to U.S. economic sanctions (including 
without limitation Iran, Syria, Sudan, Cuba, and North Korea) and that you are not otherwise prohibited 
from receiving or accessing the Materials under U.S. export control and economic sanctions laws and 
regulations. Hexagon Geospatial makes no representation that the Materials are appropriate or available 
for use in every country, and access to them from territories where their content is illegal is prohibited. All 
rights to use the Materials are granted on condition that such rights are forfeited if you fail to comply with 
the terms of this agreement.  

Revisions  

Hexagon Geospatial reserves the right to revise these Terms at any time. You are responsible for regularly 
reviewing these Terms. Your continued use of this Document after the effective date of such changes 
constitutes your acceptance of and agreement to such changes.  

Applicable Law  

This Document is created and controlled by Hexagon Geospatial in the State of Alabama. As such, the 
laws of the State of Alabama will govern these Terms, without giving effect to any principles of conflicts of 
law. You hereby irrevocably and unconditionally consent to submit to the exclusive jurisdiction of the United 
States District Court for the Northern District of Alabama, Northeastern Division, or the Circuit Court for 
Madison County, Alabama for any litigation arising out of or relating to use of this Document (and agree not 
to commence any litigation relating thereto except in such courts), waive any objection to the laying of 
venue of any such litigation in such Courts and agree not to plead or claim in any such Courts that such 
litigation brought therein has been brought in an inconvenient forum. Some jurisdictions do not allow the 
exclusions or limitations set forth in these Terms. Such exclusions or limitations shall apply in all 
jurisdictions to the maximum extent allowed by applicable law. 
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Questions  

Contact us with any questions regarding these Terms. 


